Bug #4855

Loading mission stops

Added by Li0n over 5 years ago. Updated almost 5 years ago.

Status:Expired Start date:09/26/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Multiplayer
Target version:-
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

If any button was pressed while loading mission, it will stops during loading data. It is bad when the server closes after mission starts.

sample.mp4 (16.7 MB) Li0n, 10/18/2009 09:29

serverconfig.rar (1.3 kB) Li0n, 11/01/2009 11:53

rpt.rar (238.4 kB) Li0n, 11/03/2009 16:07

rpt.rar (11.4 kB) Li0n, 12/26/2009 19:12

mis.rar (47.2 kB) Li0n, 12/27/2009 11:07

mis2.rar (1.4 MB) Li0n, 12/28/2009 11:20

History

Updated by kju over 5 years ago

  • Status changed from New to Feedback

Can you please be more specific or attach a video showing the problem?
Never heard of it or experience that.

Updated by Li0n over 5 years ago

When all players are ready, starts loading of mission file. If any key pressed in that time, or during loading data ( after loading mission file ) it will stop the loading. However, I see all types of the chat, I can write only in "dead`s" channel. Ping of players also updates in players list. I`ll try the make video, or I can take screenshots.

Updated by Fireball over 5 years ago

  • Due date changed from 10/11/2009 to 10/29/2009
  • Reproduced by another DH user set to No
  • CPU set to Please specify!

Updated by Li0n over 5 years ago

CPU - Pentium (R) Dual Core E2500 2.5 GHz x2
Here is 8 minutes of video. I start recording when I understand that the loading of mission stops again. This time it is seems to be because of larger time of loading mission.

Updated by Li0n over 5 years ago

What do you want else?

Updated by Fireball over 5 years ago

So are you saying that happens only when you are the host and it won't load for anyone? Or does that happen for each client individually?

Updated by Fireball over 5 years ago

We need to know exactly how to reproduce it:

Repro:
1. you load a MP mission as host?
2. everyone clicks OK to say they're ready or you start the mission as admin
3. the mission loads
4. while the mission loads who presses a key? you as the host? or any client joined to you?

Current:
You get stuck as the mission does not load.

Expected:
The mission loads.

As you can see many questions yet and maybe the repro steps are not complete - that's why we need feedback.

Updated by Fireball over 5 years ago

  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Then, lastly, did you try running the latest beta patch?

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball over 5 years ago

  • Due date changed from 10/29/2009 to 11/29/2009

Updated by Li0n over 5 years ago

Today it happened again.
I`m not using betapatch, it is not allowed on this server.
Also:
Server is Dedicated. I`m connecting as a usual player. The server has an admin. There are aprox. 40 men on the server. Server was locked at the startup. IF time of loading file of mission or "loading" screen time will too big, loading will stop at any phase. Today, for example, all was good before briefing. I was on brifieng screen (with map, but I don`t see the markers that the leader created.) After that my friends start to play, but I was still on the briefing screen. I tried to exit to lobby and re-enter, but loading file of misssion progress stops at 0 kb. Then I had to get out from the server. :(

Updated by kju over 5 years ago

Can you please make a short step by step explanation in Russian.
We will get it translated. :)

Possible to get the server config files?

Do you have the problems on another server?
Does it happen with less players? With any mission?
What do you mean by:

If any button was pressed while loading mission, (it will stops during loading data.)

Updated by Li0n over 5 years ago

Ok here it is:
???? ????? ?? ?????? ????, ?? ????? ?? ???????????. ? ???? ???? ???? ?????????. ???? ??? ???? ?????? ??? ?? ???? ????? ??? ??? ?????, ???? 30 - 40 ?????. ? ?? ?? ???? ? ?? ???? ????????? ????? ??? (???? ? ????) ?? ?????? ??? ???????? ? ??? ????. ???? ????? ?? ????? "???????? ????" ? ???????? ?? ????. ???? ?? ??? ?? ????????? - ???? ???? ??? ? ???????. ? ???? ???? ??? ??????? ???? (? ?? ???????? ?????) ? ???? - ?? ??????????? ? ? ???????? ??? ?? ????, ?.?. ?? ????. ? ? ????????, ???? ???? ????? ?????? ? ???? ??? ?? ???????, ? ??????? ?????? ?? ?????, ?.?. ?? ????. - it is an explanation in russian =) Russian language is not supported.
I will try to get config. I have no problems with another servers because they all are open. It doesn`t happen with less players, but it happens with any mission if there are too many players on server. About pressed button - I made a mistake, I think there is 3 reasons:
1. Unnormal long loading of mission ( for ex. when 40 players start a mission loading time will too long and then A2 will freeze. Or if I will alt+tab during loading - process will be slowed)
2. Server closed on the startup. I think that server sometimes breaking connection, and client can`t establish it again because the server is locked.
3. A lot of players on the server. It happens only when 30 - 40 players on the server.
Step by step : Server Dedicated. Admin is present. 30 - 40 players enter. Server closed. Game started. Freeze ( on Loading data or on loading file of mission or on briefing ). I can see all types of chat.

Updated by kju over 5 years ago

Damn. Cyrillic should work for Redmine. Sorry :(
I understand now. Seems familiar from a1.

Do you need to download the mission or do you already have it?

Updated by Li0n over 5 years ago

I need to download it

Updated by kju over 5 years ago

I see. Do you think you (guys) can test,
if the problem persists, if you get the mission
download via other means beforehand?

Updated by Li0n over 5 years ago

I can`t confirm it in this way because the bug appears not every time. I can`t predict it to compare.

Updated by Li0n over 5 years ago

Here is server config files

Updated by Fireball over 5 years ago

I'm just wondering that I've been joining so many Warfare BE games with any version (also vanilla 1.04) and it never got stuck.

The only thing that I can tell, which is different from those server, that they were capped at 32 players, not 52.

Maybe there is a bug in missions with more than 32 players? All speculation...maybe the server has some RPT too, which we can examine?

Updated by kju over 5 years ago

Messiah is the server admin?

verifySignatures = 0;
checkfiles[] =

It is very strange you use this combination.
At best one should check single small files inside pbos
with checkfiles.

Updated by Li0n over 5 years ago

The only thing that I can tell, which is different from those server, that they were capped at 32 players, not 52.

And they all was closed after mission began? I think this is the most important difference.

Messiah is the server admin?

Yes, do you know him?)

maybe the server has some RPT too, which we can examine?

I`ll ask. Tell me now if you need something else from server.

Updated by kju over 5 years ago

Yep we know each other well. Old arma friends. ;)

Updated by Li0n over 5 years ago

RPT

Updated by kju over 5 years ago

tx

a lot of

Server: Network message XXX is pending

Updated by Li0n over 5 years ago

It happened again. I think because of too large time of loading file of mission again.

Updated by Fireball over 5 years ago

Actually, it seemed to happen to me too today in a Berzerk mission with about 87 players - but it wasn't really stuck - somehow the admin knew that it would take another minute for the mission to begin, so you only get apparently stuck.

Sounds like this is mission-specific; maybe it is the time needed to coordinate all the players for mission start - I really don't know how the admin saw that it's taking "1 min to start", but somehow he did, while we players only saw the loading screen (over the player roster).

EDIT: And indeed - after 1 min it started; it downloaded the mission file again though, which seemed strange first, but since it started out regularly after this, somehow it felt like being part of the process.

Updated by kju over 5 years ago

Li0n how long did you wait before rejoining?

Updated by Li0n over 5 years ago

Half an hour, I think. While server was locked I didn`t even try to join.

Updated by kju over 5 years ago

ok damn :(

Updated by Fireball over 5 years ago

  • Due date changed from 11/29/2009 to 12/31/2009

Needs feedback, potentially after 1.05 release some time.

Updated by Li0n over 5 years ago

Ok I `ll try.

Updated by Li0n over 5 years ago

Today it happened again. Loading stopped after loading of mission file. 2 previous missions 300-400 kb was fine, but this one was 1900 kb, so I think it is because of that. Here is an rpt. (1.05)

UPD. - secod bug happened in next mission. That mission was light, downloaded and played few minutes earlier, and when we start it in 2d time - i got "black map". I wrote about it earlier. After that I`m appeared as a bird.

Updated by Fireball over 5 years ago

Can you attach this mission zipped or put a link where to download it (if available)?

Updated by Li0n over 5 years ago

second bug mission

Updated by Fireball over 5 years ago

  • Status changed from Feedback to Assigned

Thanks. Let's see if we can do something with that.

Updated by Li0n over 5 years ago

First bug mission

Updated by kju over 5 years ago

  • Due date changed from 12/31/2009 to 03/02/2010

Updated by kju almost 5 years ago

  • Due date changed from 03/02/2010 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Still valid in 1.07 / OA?

Updated by kju almost 5 years ago

  • Due date deleted (07/14/2010)
  • Status changed from Feedback to Expired
  • I am using some Mods set to No
  • Reproducible for you set to No

Expired.

Feel free to reopen after retesting with OA.

Also available in: Atom PDF