Bug #4851

Hidebody not always working

Added by solrac42 over 5 years ago. Updated over 5 years ago.

Status:Rejected Start date:09/25/2009
Priority:Normal Due date:12/25/2009
Assignee:Dwarden % Done:

0%

Category:Gameplay
Target version:-
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

I have used the hidebody command in a script whereby no unit is used to animate it.
I just use "hidebody player" and it works fine in ArmA but does not always work in ArmA 2 all versions to date.

Sometimes the command does not hide the dead player.
Tested in SP mode only.

hideBody.wmv (15.4 MB) solrac42, 01/04/2010 21:50

History

Updated by zGuba over 5 years ago

  • Due date set to 12/25/2009
  • Category set to Gameplay
  • Status changed from New to Assigned

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden
  • Reproduced by another DH user set to No

Updated by Luca over 5 years ago

  • Status changed from Assigned to Rejected

You can't hide player never. You can't erase him or whatever.

Updated by solrac42 over 5 years ago

Hello Luca,

I have written a small mod for ArmA 1 and I am working on a version for ArmA 2 (See video), which allows the player to observe the gameplay even though the player is dead, it is called the ArmA II SPR Mod, which means 'Single Player Respawn'

With this mod I can use "hideBody player" in a script and watch him sink below the terrain from the camera view that my mod uses, so it definately DOES work, and it works fine for ArmA 1, but it did not always seem to work in ArmA 2.

I can also delete the body of the dead player using "deleteVehicle _deadPlayer" in the script, but only after the player respawns in a new unit, and this works fine in both ArmA 1 and ArmA 2.

So back to my original complaint that the "hidebody" command does not always work in ArmA 2, I have since discovered that is does in fact work properly all the time, the reason it did not always hide the players dead body was because when my script used the command "hideBody player" it would start to do the job, but when the player had respawned and is now alive again, then the "hideBody player" command would cease and therefore the dead body would remain on the surface of the ground, sometimes it would even pop back up after being partly buried, it was all due to timing actually.

So to sum up then, the "hideBody" command is working properly in all versions that I tested, from 1.01.57631 up to 1.05.62017

Also available in: Atom PDF