Bug #4848

Self suppressing foliage

Added by 76 over 5 years ago. Updated over 4 years ago.

Status:Closed Start date:09/25/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

100%

Category:Gameplay
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When shooting through the smallest/thinnest of foliage (the very ends of tree branches and bushes) you will suppress yourself.

I understand shooting into a wall or something solid at close range causes self suppression, but self suppressing yourself through the thinnest of branches and bushes/shrubs is BS

CIT_4848_SelfSupprFoilage.Chernarus.zip (614 Bytes) Fireball, 09/29/2010 23:43


Related issues

related to ARMA2 Community Issue Tracker - Bug #5029: Bullet proof/deflecting shrubs/bushes Rejected 10/06/2009 01/02/2010
related to ARMA2 Community Issue Tracker - Bug #6292: Fatigue level increases when shooting at ground... Closed 11/27/2009

History

Updated by kju over 5 years ago

  • Priority changed from Urgent to Normal
  • Target version deleted (1.05 BETA)

do not set target version
do not set priority
ty

Updated by 76 over 5 years ago

kju wrote:

do not set target version
do not set priority
ty

:S soz kju... was never sure what fields to set, thx :)

Updated by zGuba over 5 years ago

  • Due date set to 12/25/2009
  • Status changed from New to Assigned

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Feedback
  • Reproduced by another DH user set to No

As already stated in #5029, you will possibly hear or see feedback when shooting through bushes and trees branches/foilage, but it does not deflect or stop your bullets.

If you find one that deflects/stops your bullets, please attach a repro mission.

Updated by zGuba over 5 years ago

  • Status changed from Feedback to Assigned
  • Reproduced by another DH user changed from No to Yes

It's connected to suppression effects. Script does not care whether bullet was shot by unit's own weapon.

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by 76 over 5 years ago

Fireball wrote:

Hmm, funny I cannot repro this, no matter how hard I try shooting at/through some bushes or trees. Not even if I fire directly in front of my feet. Does it need a special module or script?

Try sitting inside a bush or pine tree with low branches then move enough so you can see out of it (to see enemy) but still have some thin foliage in front of you... fire and suppress yourself.

Updated by 76 over 5 years ago

@Fireball, did you manage to repo this? its not so much shooting into a bust/tree its when you are hiding inside it and firing out from the concealment of the bush/tree through the i assume 'ends' of the branches/leaves

Updated by CarlGustaffa over 5 years ago

Yes, I'm experiencing this a lot myself. Go into 3rd person and observe the barrel being clear of your cover. But when you fire, you're hitting the cover. And thus ending up suppressing yourself. If the shooting and hitting part is too heavy to fix (I'm guessing bad fire geometry, check the Warfare walls for good example, the kind used in Domination base respawn area), at least remove the self suppression that comes from it.

Updated by kju over 5 years ago

  • Due date changed from 12/25/2009 to 03/02/2010

Updated by kju almost 5 years ago

  • Due date changed from 03/02/2010 to 07/28/2010
  • Affected ArmA II version changed from 1.04.59026 to 1.52.71816
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Very annoying.

Updated by 76 almost 5 years ago

  • I am using some Mods set to No
  • Reproducible for you set to No

Bug still present 1.52.72018

  1. Audio card: Creative X-fi Extreme PCI
  2. Size of OS swap file: 6144mb

Updated by kju almost 5 years ago

  • Due date changed from 07/28/2010 to 10/01/2010
  • Affected ArmA II version changed from 1.52.71816 to 1.53 BETA

Updated by Fireball over 4 years ago

  • Due date changed from 10/01/2010 to 12/01/2010
  • Reproducible for you changed from No to Yes

Btw. YES, I did repro this a couple of times, to my dismay!

Updated by Fireball over 4 years ago

  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA

Updated by 76 over 4 years ago

Edit by Fireball: (why bother replying a year old statement which was corrected later on?)

Updated by kju over 4 years ago

  • Due date deleted (12/01/2010)
  • Status changed from Assigned to Resolved
  • Target version set to 1.55 BETA

[73555] Fixed: My own shots no longer causing a stress.

Please confirm fix.

Updated by 76 over 4 years ago

It aint fixed.... same as it has always been, shoot through any type of foliage and suppress your self.

I'll make a video if you insist.

repo steps as follows.... load editor and shoot into/out of a shrub/bush and suppress yourself.
(using latest beta Build_73643)

[73555] Fixed: My own shots no longer causing a stress.
Never saw this fix in beta log either way is not fixed.

Updated by kju over 4 years ago

  • Due date set to 10/14/2010
  • Status changed from Resolved to Feedback

Updated by Fireball over 4 years ago

You're doing something wrong or loading the wrong build, it's fixed for me...standing in a bush, when I hit it, the leaves fall, I'm not shaky. Bottom line.

Dare me and I'll show you: http://www.youtube.com/watch?v=8JJbuhJCeTw

I used Chernarus, because I wasn't sure if the bushes on Utes exhibited the issue.

Updated by 76 over 4 years ago

Soz FB... new beta wasn't out or I didn't know (usually straight on it) and took no notice of the fix number you posted... again sorry.

And yes if works... awesome... but now shooting point blank into a wall with bits of brick and render flying into my face and Im as calm as a button... but its far better than it was

THX BI and CIT Managers, Developers and Reporters :)

Updated by 76 over 4 years ago

  • % Done changed from 0 to 100

Updated by kju over 4 years ago

no worries :)

Updated by kju over 4 years ago

  • Due date deleted (10/14/2010)
  • Status changed from Resolved to Closed

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF