Bug #4828

'Updating base class' errors in c_vehicle

Added by q1184 over 5 years ago. Updated about 5 years ago.

Status:Closed Start date:09/23/2009
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Review
Target version:-
Component:c_vehicle Affected Version:
Close Reason:

Description

Updating base class Turrets->Turrets, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/
Updating base class MainTurret->MainTurret, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/MainTurret/


Related issues

blocked by ARMA2 Community Issue Tracker - Bug #5426: Magical CATracked config inheritance tree Closed 10/25/2009

Associated revisions

Revision 1378da5c
Added by zGuba over 5 years ago

probably fixes #4828

History

Updated by zGuba over 5 years ago

Golf is fixed, others are coming.

Updated by zGuba over 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Updated by q1184 over 5 years ago

  • Status changed from Resolved to Closed

Updated by rocko over 5 years ago

  • Status changed from Closed to In progress

not fixed

Updated by rocko over 5 years ago

  • % Done changed from 100 to 30

Updated by zGuba over 5 years ago

BMP2_Base is puzzling me. It shouldn't create such error.

Updated by zGuba over 5 years ago

  • Due date set to 10/07/2009

Updated by zGuba over 5 years ago

  • % Done changed from 30 to 70

Updated by Sickboy over 5 years ago

  • Target version set to 0.6

Updated by rocko over 5 years ago

  • Due date changed from 10/07/2009 to 10/11/2009
  • Priority changed from Normal to Urgent

Updated by rocko over 5 years ago

  • Due date changed from 10/11/2009 to 10/14/2009

Updated by q1184 over 5 years ago

Updating base class Turrets->Turrets, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/
Updating base class MainTurret->MainTurret, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/MainTurret/

Still there, took a look at c_vehicle config and it looks correct, must be some other place.

Updated by rocko over 5 years ago

When the BMP2_Base part is disabled the error is gone.

Updated by zGuba over 5 years ago

That's obvious. The question is why it shows hence inheritance tree is 100% identical /maybe cfgPatches stuff, but that's incredible/.

Updated by rocko over 5 years ago

  • Due date deleted (10/14/2009)
  • Assignee deleted (zGuba)
  • Target version changed from 0.6 to 395
  • % Done changed from 70 to 0

BMP2_Base class disabled for now until known whats wrong

Updated by zGuba over 5 years ago

BIS is aware of problem and they should fix the cause in 1.05

Updated by q1184 over 5 years ago

  • Priority changed from Urgent to Normal

Updated by rocko over 5 years ago

  • Status changed from In progress to Resolved

Updated by rocko over 5 years ago

  • Category changed from Config to Review

Updated by rocko over 5 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Updated by rocko over 5 years ago

  • Target version changed from 395 to 0.6

Updated by zGuba over 5 years ago

  • Status changed from Closed to Feedback

They are back. 0.1.184

1 Updating base class Turrets->Turrets, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/ 2 Updating base class MainTurret->MainTurret, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/MainTurret/ 3 Updating base class ViewOptics->, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/MainTurret/ViewOptics/ 4 Updating base class Turrets->Turrets, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/MainTurret/Turrets/ 5 Updating base class ViewOptics->, by x\ace\addons\c_vehicle\config.bin/CfgVehicles/BMP2_Base/Turrets/MainTurret/Turrets/CommanderOptics/ViewOptics/

Updated by Sickboy over 5 years ago

  • Assignee set to zGuba

zGuba wrote:

They are back. 0.1.184

Probably from the merge issues KH was experiencing, hopefully a simple reapply is okay, otherwise we can cherry pick the changes from previous commits and properly apply em this time :)

Updated by ViperMaul over 5 years ago

  • Target version changed from 0.6 to 0.9

Updated by Sickboy over 5 years ago

  • Target version changed from 0.9 to 1.0.0

Updated by zGuba over 5 years ago

zGuba wrote:

BIS is aware of problem and they should fix the cause in 1.05

Still not fixed.

Updated by rocko about 5 years ago

  • Target version changed from 1.0.0 to 395

Updated by rocko about 5 years ago

  • Assignee deleted (zGuba)

Updated by Xeno about 5 years ago

  • Status changed from Feedback to Closed

Error in BI config, no need to keep ticket open!

Updated by rocko about 5 years ago

  • Target version deleted (395)

Also available in: Atom PDF