Bug #4677

increase CHOOSE_DURATION for visibility of class select menu

Added by CoolBox-SBS- almost 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:09/20/2009
Priority:High Due date:
Assignee:- % Done:

0%

Category:Visual - Tweak
Target version:Beta 09 V0.5 Estimated time:0.10 hour

Description

Currently it stays up for 4 seconds after you hit the key. toaster thinks it should be substantially increased, e.g. to 10 sec.

CB

History

Updated by BCA_Cat_Toaster almost 6 years ago

As long as it is up you can constantly switch classes and weapons while firing and it´s constantly up if you do that. I would recommend, that it shows up for 8s for example and then the timer starts, no matter if a class/weapon was chosen or not. Or what about a OK button, so the player can decide if he´s done? Also the distance where it works should be decreased from 20m to 5m, or is there a specific reason why someone should change classes 20m away from the armory, or do i get something completely wrong? I know it´s already a serverside switch.

Updated by BCA_Cat_Toaster almost 6 years ago

nm

Updated by CoolBox-SBS- almost 6 years ago

  • Status changed from New to Feedback

Well I upped it to 6 seconds. Lets see how that goes.

Updated by BCA_Cat_Toaster almost 6 years ago

As you already said for those who get familiar with the new system it gets annoying and for those who are completely new it 6s are still to short. I suggest an OK-Button instead of that Choose_Duration timer, so every player can decide for himself how long the menu is displayed.

Updated by Blisstick almost 6 years ago

Agreed, an OK button makes sense. Also agree that it shouldn't work more than 5m from crates... it was driving me crazy when disappearing while looking at the rifleman guns and also popping up when I was anywhere near the flag area when I was walking around WASD with talking on TS with CTRL as PTT haha!

Updated by CoolBox-SBS- almost 6 years ago

How are you going to click on an OK button when theres no mouse visible?

Updated by BCA_Cat_Toaster almost 6 years ago

Well, rofl, sorry, you´re right. Hmm, what about making that menu somehow mouse-sensitive and place an OK-Button? Isn´t that possible? If it´s not, some kind of Key-Control to close the menu will do the same job, of course. Just the same STRG+V to open it is used to close it, just removing the timer for example?

Updated by kju almost 6 years ago

IMHO you should not be able to moving while accessing the armory.
You should have a mouse cursor to operate within the interface.
Space should confirm and close (same for Enter).
AWSD and arrow keys should make it possible to steer through the dialog.

Updated by CoolBox-SBS- almost 6 years ago

I dont want people to spend time messing around in dialogs. Just hit a few hotkeys and go. And I dislike having to suddenly start using a mouse pointer mid way through a game.

I could make it so that it stays for 10 sec, and if you hit any other keys other than CTRL+C, CTRL+D or CTRL+K it disappears. How about that?

Therefore as soon as you try to move, it will disappear, bit it will stay considerably longer if you remain stationary.

Updated by CoolBox-SBS- almost 6 years ago

Yes, before you say it, I know that my own spawn menu requires you to use a mouse. But
(a) I dont like my own menu, lol, its true, i'd prefer it without mouse
(b) the pressure is a little bit relaxed when you are dead

Updated by kju almost 6 years ago

How about adding the actions for 1,2,3,4,5,6,7,8... and X,A,B,C,D,E,...
to avoid mouse use for the respawn dialog.

Updated by BCA_Cat_Toaster almost 6 years ago

Indeed, as I started playing ArmA-AAS i always pressed the A, B or whatever key to choose my spawnpoint, because i was used to it in JO. However, now i´ve learned to use the Mouse instead for making my selection as everyone else. Would be nice to add the function pressing the according Key works also, but we should not remove mouse-control because people are used to it now.

Another example i´ve experienced yesterday while playing on our server with some guys from a german clan: You won´t believe it, event without a language-barrier it took some time to explain them how to pick a class and weapons. They even weren´t used to the former versions, just using the mouse-wheel. The only way they were familiar with picking their gear was going to the armory and press "G". And those guys played AAS before on our server, until yesterday none of those four guys had an idea how to pick a class in AAS. For me that was a quite astonishing experience.

It´s bit offtopic but that story tells us that things still aren´t easy enough.

Updated by CoolBox-SBS- almost 6 years ago

Yes, gotta get into the mentality of your users! Arma 2 has not been a game for the casual gamer in the past... but thats no excuse for the usability failings of our UI.

Updated by BCA_Cat_Toaster almost 6 years ago

Well, i didn´t say that the UI fails but players need to know that there IS some sort of UI, which is different than in other ArmA2-Modes and how to access it. My example does not tell that the UI is crap, it´s just telling some players aren´t aware of it at all. ;-)

It´s not that hard to add a server-message that says "Press CTRL+V for AAS-Specific Controls (Change Class/Weapons, Toggle HUD, Zoom Minimap)" coming up within 60 seconds a new player joins and then another four times every five minutes. That´s what i did now. Maybe we can add something similar to the new Init-Screen?

For Example in ClientMainThread.sqf:

string _welcomeMessage = "\nWhat's New:\n* Improved player kit system (Press CTRL+V) //I did that now too

And of course the Hint-System could be used also to distribute that information. I´m sure you had that already in mind. Another great place for general information/explanation would be the "mapname.hpp", because while showing players have to wait for the mission to load anyway. Is that possible? I tried already but it didn´t work.

Updated by kju almost 6 years ago

Just playing on TG server. The new weapon menu isn't well received at all. :(
Hopefully you make it far better usable very soon. Thanks!

Updated by DirTyDeeDs almost 6 years ago

Just remove the SMAW from the ammo crate and leave the previous system intact.
who cares if a west unit is using an east weapon or vice versa, at least I don't
It's the persons skill with the weapon that kills, not the weapon itself.

I didn't like the new system . I couldn't easily choose weapons/loadout of my preference.

Updated by kju almost 6 years ago

I do not agree with DirTyDeeDs. And much discussion give many good points
for the changes.

The new class switching system needs improved.

Maybe make a full screen black dialog for ppl to full concentrate on the dialog.

Updated by Blisstick almost 6 years ago

Yeah, if it's possible to make a dialog come up and enable the mouse to point and click that will work easiest. These key shortcuts are getting out of hand, so if you keep them, make them something people won't hit by mistake. AFAIK all users are comfortable using a mouse by now and most use it to aim and use the crates we have, so it's not a big step for them.

Updated by kju almost 6 years ago

What I find very weird and distracting is that

a) For some reason it seems to be the dialog opens by mistake here
Should be related to the keys you used. CTRL is walk here.
It seems you also open the dialog if you are near the create and press any of these combos.
=> very bad
b) While the dialog is open, you can still move, aka key input is not
restricted to dialog control only.

Updated by CoolBox-SBS- almost 6 years ago

  • Status changed from Feedback to Resolved

Thanks for feedback peeps. Changes made:

(1) you can only change class using action menu at armoury as with the old method
(2) the dialog will pop up when you do
(3) you can then use the shortcut keys to change class/weps
(4) as soon as you walk away from the spot you were on, the menu disappears

This means the dialog wont accidentally pop up, and it goes away as soon as
you act. It will stay for 12 secs if you do nothing.

See forthcoming r276.

Updated by kju almost 6 years ago

galzohar said:

Why isn't loadout choice done during the respawn timer? That way as soon as you spawn you are good to go, which is especially good in the current Advance And Spawncamp game style.

Updated by kju almost 6 years ago

76 said

galzohar wrote:

Advance And Spawncamp game style.

LOL, thats funny ;)... there is little missions makers can do to alter the methods ppl use to kill eachother, and any measures they impose to combat camping would be rather restrictive and would affect everyone.... I say this when ppl complain about campers.... "campers make you a better player" repeatedly stalking and killing a persistent camper is going to upset him/her more that them camp killing you :)

Updated by kju almost 6 years ago

galzohar said

This was meant to be a reply to the loadout selection discussion, but apparently I hit the wrong button.

There is a difference between camping and spawn camping, but they do have one thing in common - the mission maker's job is to make sure neither of them is an effective strategy. In AAS spawn camping is not only effective, but it is the only way to have any chance of capturing a zone.

Updated by kju almost 6 years ago

Choosing equip during respawn, optional, may work.
You would still need it the current way, if you want to retain
the feature to let ppl change their class in each zone.

Feedback is welcome, yet the tone makes the music.

Multiple people do not like the spawning in the zone you are
to capture, yet there is a thread for it and a normal tone does
the job just fine.

Updated by kju almost 6 years ago

BCA_Cat_Toaster said

Besides that the title has little to do with the description and what i can read from the description this is feature request and not a bug. However changing loadouts while in spawn-queue seems attractive but also affects balance. If you got killed by a tank being a Rifleman changing to Engineer without the need going to the Armory first...hmm, does not sound too attractive.

Updated by galzohar almost 6 years ago

If you will no longer spawn right on top of enemies, then it will not be an issue. It will just cut the respawn->get weapons->head out process into respawn->head out. That will also mean there is no advantage for people who can click the gear interface faster after they spawn, nor for people who know where they spawn relative to the armory. Sure it can just be a few seconds but when you repeat it a large number of times it can get quite annoying.

In fact, in the current state it actually becomes a good thing because you actually get a chance to fight against the tank that spawn camps you, instead of getting killed every time you even think about trying to change weapons while all your AT guys are also getting spawn camped. But yeah, no matter what you change - as long as there is spawn camping, there will be problems.

Updated by CoolBox-SBS- almost 6 years ago

  • Status changed from Resolved to Closed

Thanks for feeback.

(1) Regarding removing spawn from contested zones, should be pretty easy to implement, just change the conditional on line 66 of refreshRespawnButtons.sqf, using the curBaseList (which is a list of all contested bases).

http://www.sbs-squad.org.uk/svn/arma2/aas/aas50_ChernarusTemplate.Chernarus/refreshRespawnButtons.sqf

However I'm not a fan of this idea at all, so best left for someone else's fork from the main code base.

(2) Regarding change of weapon loadout while waiting for respawn, yes its possible, but not worth the considerable
effort (estimated 8--10 hours) for the minor benefits yielded imho. Be my guest.

Let's continue these discussions in separate issues from the CHOOSE_DURATION discussion this issue was originally about.

cB

Also available in: Atom PDF