Bug #4438

AI will not engage through buildings' glass

Added by Deadfast over 5 years ago. Updated over 2 years ago.

Status:Closed Start date:09/10/2009
Priority:High Due date:
Assignee:Suma % Done:

100%

Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.59.79384 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

The AI will not engage the enemy through some buildings' glass, even if it is fully aware of him (knowsAbout = 4).

A good example is A_GeneralStore_01 (Chernarus: Object ID 363222 at 104 129), however the AI will engage if the glass is shot out with this building.
Another building affected is CAStructuresLand_A_MunicipalOffice.

noEngage.Chernarus.7z - Example mission (1005 Bytes) Deadfast, 09/10/2009 18:20

Ai_bug.avi (35.6 MB) Danil-ch, 10/29/2010 17:07

Glass.Chernarus.7z (728 Bytes) kju, 09/06/2011 09:36


Related issues

duplicated by ARMA2 Community Issue Tracker - Bug #8630: AI can not spot you if you are shooting from the window. Duplicate 01/29/2010 03/29/2010
duplicated by ARMA2 Community Issue Tracker - Bug #10200: Fire Station building AI blocked windows Duplicate 04/19/2010
duplicated by ARMA2 Community Issue Tracker - Bug #18677: - ArmA2 v1.09 Supermarket Building. Duplicate 04/03/2011

History

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by zGuba over 5 years ago

  • Due date set to 10/10/2009
  • Status changed from New to Assigned

Updated by zGuba over 5 years ago

  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Updated by Vic over 5 years ago

Somewhat related, Chernogorsk's hotel lobby windows seem to block player's view (at least partially, some distant houses disappear).

Updated by zGuba over 5 years ago

Hmmm old materials got lost there? or just view LOD is spoiled?

Updated by Dwarden over 5 years ago

  • Priority changed from Normal to High
  • Target version set to 1.05 BETA
  • Reproduced by another DH user set to No
  • CPU set to Please specify!

Updated by Fireball over 5 years ago

  • Due date changed from 10/10/2009 to 11/10/2009

Updated by kju over 5 years ago

  • Target version changed from 1.05 BETA to Upcoming version

Updated by kju over 5 years ago

  • Due date changed from 11/10/2009 to 11/25/2009

Updated by Fireball over 5 years ago

  • Due date changed from 11/25/2009 to 12/31/2009

Updated by kju about 5 years ago

  • Due date changed from 12/31/2009 to 03/02/2010

Updated by kju over 4 years ago

  • Due date changed from 03/02/2010 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Target version deleted (Upcoming version)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Updated by kju over 4 years ago

  • Due date changed from 07/14/2010 to 10/01/2010
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.05.62017 to 1.53 BETA

Updated by Danil-ch over 4 years ago

Updated by kju over 4 years ago

  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA

Updated by kju over 4 years ago

  • Due date changed from 10/01/2010 to 02/01/2011
  • Affected ArmA II version changed from 1.55 BETA to 1.55

Updated by kju over 4 years ago

  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Updated by Fireball over 4 years ago

  • Affected ArmA II version changed from 1.55 to 1.56.76134

Updated by Deadfast almost 4 years ago

  • Language set to Please set for missions

Updated by kju almost 4 years ago

  • Due date changed from 02/01/2011 to 07/01/2011
  • Affected ArmA II version changed from 1.56.76134 to 1.59.79384
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • Language deleted (Please set for missions)

Updated by Suma over 3 years ago

  • Assignee set to Suma

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Fixed in 83759 (also for other penetrable materials).

Updated by kju over 3 years ago

  • Due date deleted (07/01/2011)
  • Target version set to Upcoming version

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Confirmed working.

This should add a lot. Thanks!

Updated by Suma over 3 years ago

  • Status changed from Resolved to Closed

Updated by kju over 3 years ago

Hm here is a building with glass where AI still does not engage.

Maybe a model issue?

Repro
  1. Launch mission in the editor
  2. Notice the AI behind the glass not engage you

Updated by Fireball over 3 years ago

  • Due date set to 09/25/2009
  • Status changed from Closed to Feedback

Updated by Fireball over 3 years ago

  • Due date changed from 09/25/2009 to 09/25/2011

Updated by Suma over 3 years ago

In this case this is a model issue, and a bit different one. The AI knows the surface is penetrable, but it does not know it can see through it, as the model is using the same LOD for view and fire geometry, and the glass which is marked as penetrable for fire still acts as an obstacle for the visibility testing. There is currently no way how to mark materials as "transparent", and even if there would be, we would probably not update the Chernarus data because of this issue.

It could be possible to use heuristics based on surface "soundHit" property, and if it is a "glass", and it is thin enough, we could consider it transparent. However, while I doubt soundHit = glass is used on non-transparent thin objects, it is possible and does not sound unreasonable, therefore I would rather not implement a dirty hack like this unless really needed.

Updated by kju over 3 years ago

  • Due date deleted (09/25/2011)
  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Alright. Thanks for the clarification!

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF