Bug #4328

MP sync problem: Cargo fall out of the helicopter when switching positions during flight.

Added by Lonestar almost 6 years ago. Updated about 4 years ago.

Status:Closed Start date:09/06/2009
Priority:High Due date:
Assignee:Dwarden % Done:

90%

Category:Gameplay
Target version:1.55.75445
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs:
When i'm in a helicopter and i switch positions i fall down to the ground.

It occurs when you switch to a position right after another player does it (So let's call it synchronization problem).

Repro:
  1. Get several players in a chopper. MH-60 is one I've fallen out of several times.
  2. Have one player fly around while the others switch from backseat to gunner and crew chief, and back.

http://forums.bistudio.com/showthread.php?t=85824
It has nothing to do with role restrictions.

It happened to me a few times and according to Xeno the bug exists since ArmA 1.


Video

4328_out_while_switching

History

Updated by kju almost 6 years ago

  • Category set to Gameplay
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.04 BETA

Updated by Lonestar almost 6 years ago

Kju it was experienced with the regular patch 1.03 not the 1.04 beta.

Anyway nice to take care of this problem.

Updated by Dwarden almost 6 years ago

  • Assignee set to Dwarden

Updated by Fireball almost 6 years ago

  • Due date changed from 09/20/2009 to 10/20/2009

Updated by Dwarden almost 6 years ago

  • Priority changed from Normal to High
  • Target version set to 1.05 BETA
  • Reproduced by another DH user set to No
  • CPU set to Please specify!

Updated by Fireball almost 6 years ago

  • Due date changed from 10/20/2009 to 11/20/2009

Updated by Lonestar almost 6 years ago

CPU : Core 2 Duo E8400@stock

To reproduce it just follow the repro steps mentionned in first post :

1) Get several players in a chopper. MH-60 is one I've fallen out of several times.
2) Have one player fly around while the others switch from backseat to gunner and crew chief, and back.

Updated by shuko almost 6 years ago

I've seen this happen in chopper and even in uaz (with gunner position).

Updated by kju almost 6 years ago

  • Target version changed from 1.05 BETA to Upcoming version

Updated by kju over 5 years ago

  • Subject changed from Falling down the helicopter when switching positions to MP sync problem: Cargo fall out of the helicopter when switching positions during flight.
  • Due date changed from 11/20/2009 to 01/16/2010

Important to note. This is a MP issue.

Updated by Xeno over 5 years ago

And don't forget, it happens also in vehicles like tanks while driving.

Updated by alef over 5 years ago

  • Affected ArmA II version changed from 1.04 BETA to 1.05.62017
  • Reproduced by another DH user changed from No to Yes
  • CPU changed from Please specify! to n/a

+video

Updated by kju over 5 years ago

  • Due date changed from 01/16/2010 to 03/02/2010

Still happens.

Updated by kju about 5 years ago

  • Due date changed from 03/02/2010 to 08/01/2010
  • I am using some Mods set to No
  • Reproducible for you set to No

Any change here?

Updated by kju almost 5 years ago

  • Due date changed from 08/01/2010 to 10/14/2010

Final bump.

Updated by Lonestar almost 5 years ago

I did some testing with OA regular patch 1.54:

  1. UH-1Y and MH-60S => no problem (can't switch position in OA - compartments)
  2. Only the CH-47F (Chinook) lets the player switch from gunner to crew chief
    and it works perfectly (I did a lot of switching back and forth in the air and no bug so far)

Since OA you have to get out of a vehicle to switch position, with a few exceptions (Stryker, Chinook).

Updated by alef almost 5 years ago

  • Due date changed from 10/14/2010 to 10/16/2010
  • Status changed from Assigned to Resolved
  • Target version changed from Upcoming version to 1.55 BETA
  • % Done changed from 0 to 90

[73643]

LoneStar wrote:

Since OA you have to get out of a vehicle to switch position, with a few exceptions (Stryker, Chinook).

It's Ok when you have to get out. But if you are allowed from the game to switch via the action menu, and automatically get out, that's the bug.

I've did right now the repro in CO with UH-1Y and the bug doesn't shows. That's why I set as Resolved.
I give two weeks for feedback for any other vehicle, also if the bug title is "chopper", then we can Close it.

Updated by kju almost 5 years ago

  • Due date deleted (10/16/2010)
  • Status changed from Resolved to Closed

Updated by kju almost 5 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF