Bug #4228

Absolute paths to modfolders broken in BETA

Added by Squelch over 5 years ago. Updated about 5 years ago.

Status:Closed Start date:09/02/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:ModFolders
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

Up until patch Exe version: 1.03.58627 it was possible to include the full path to a mod by using

-mod= "path\to\addon"

This enabled addons to be loaded from any path thus keeping the ArmA 2 folder clean and more advanced use of modfolders.
The recent BETA builds appear to have broken this behaviour, resulting in multiple errors, before a shader mismatch fatal error resulting in program termination.

Placing the modfolder rooted in the ArmA2 folder restores normal behaviour, so it appears that absolute paths are not working correctly.

I hope this is just an artefact of the BETA build strategy, and absolute paths to modfolders returns in patch 1.04. Verification of whether this is a designed feature or a temporary glitch would be most welcome as there are several projects that would need to rethink how they operate as a result.

History

Updated by Dwarden over 5 years ago

as temporary workaround you can use junctions ...

Updated by Fireball over 5 years ago

  • Status changed from New to Assigned

Updated by Fireball over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball over 5 years ago

  • Due date changed from 09/30/2009 to 10/30/2009
  • Reproduced by another DH user set to No

Updated by Fireball over 5 years ago

  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Updated by Fireball over 5 years ago

  • Due date changed from 10/30/2009 to 11/13/2009
  • Status changed from Assigned to Feedback

Still an issue?

Updated by kju over 5 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 1.05 BETA

Works fine here:

-mod=X:\AddonsSSD;beta

Updated by kju about 5 years ago

  • Due date deleted (11/13/2009)
  • Assignee deleted (Dwarden)
  • Reproduced by another DH user changed from No to Yes

Just waiting for 1.05 final.

Updated by kju about 5 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.05 BETA to 1.05.62017

Also available in: Atom PDF