Feature #4216

Working cyclic X/Z and collective animation sources on helicopters

Added by zGuba over 5 years ago. Updated about 3 years ago.

Status:Closed Start date:09/01/2009
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Animations
Target version:1.51.71083
Affected ArmA II version: First affected ArmA II version:
Reproduced by another DH user:No Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:No WIKIurl:
Related to content of DLC:

Description

I know that there is unused cyclic animation source. I wonder if it could be working similarly to aircraft ailerons and elevators (already implemented). Having it instead of artificial horizon workaround would simply make helicopters prettier.

Collective animation source differs much from RPM that is currently beign used by BIS to fake the effect; better one faking it now would be gmeter which is already beign used by ACEX helicopters to turn and bend blades, however it suffers the "absolutism" of this source - gmeter seems to always have positive value.


Related issues

related to ARMA2 Community Issue Tracker - Bug #7275: Rotor animations are inconsistent thorough various helico... Assigned 12/22/2009 09/14/2011

History

Updated by zGuba over 5 years ago

  • File cyclic_animations.jpg added

Updated by zGuba over 5 years ago

  • Tracker changed from Bug to Feature

Updated by zGuba over 5 years ago

  • Subject changed from Cyclic controls on main rotors are animated incorrectly to Correct cyclic animation on helicopters

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by zGuba over 5 years ago

  • Subject changed from Correct cyclic animation on helicopters to Correct cyclic animation on helicopters, possibly contolled by input

Updated by zGuba over 5 years ago

  • Subject changed from Correct cyclic animation on helicopters, possibly contolled by input to Realistic cyclic animation on helicopters, possibly controlled by input

Updated by Vigilante over 5 years ago

  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)

Isnt it simpler to do a more 'creative' way of selecting vertices? this presented solution looks more elaborate than needed for the task at hand.. its eyecandy whats being fixed with it!? or does this way of setting up config help .. where? im curious..

Updated by zGuba over 5 years ago

It's just eyecandy. But there are tons of other eyecandies, f.e. bending rotor blades. Won't hurt.

Updated by modEmMaik over 5 years ago

I have included a simmilar "rotordive" in the RAH-66, but I am curious about weather BI finally included the source="rotorHDive" animation (definition is included in the A1-samples, but has no effect ingame of A1). I guess another axis to implement the side-tilt (may be using the horizonBank) could also have an eyecandy effect.

Updated by Fireball over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball over 5 years ago

  • Assignee changed from Dwarden to zGuba

Updated by zGuba over 5 years ago

  • Due date changed from 10/01/2009 to 11/14/2009
  • Status changed from Feedback to Assigned

modEmMaik wrote:

I have included a simmilar "rotordive" in the RAH-66, but I am curious about weather BI finally included the source="rotorHDive" animation (definition is included in the A1-samples, but has no effect ingame of A1). I guess another axis to implement the side-tilt (may be using the horizonBank) could also have an eyecandy effect.

Yes, I wish that could be implemented finally. The fact I'm using horizonDive/Bank here is simply because it works, so it's placeholder rather than final solution.

Updated by zGuba over 5 years ago

  • Subject changed from Realistic cyclic animation on helicopters, possibly controlled by input to Realistic cyclic animation on helicopters, possibly controlled by thrust vector

Updated by zGuba over 5 years ago

  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026

Updated by zGuba over 5 years ago

  • Reproduced by another DH user set to No

Cole has created video featuring my cyclic animations:

http://www.youtube.com/watch?v=UKxIVzLkRow

Updated by zGuba over 5 years ago

  • Affected ArmA II version deleted (1.04.59026)

Updated by zGuba over 5 years ago

  • Subject changed from Realistic cyclic animation on helicopters, possibly controlled by thrust vector to Working cyclic mechanism animation on helicopters, possibly controlled by thrust vector
  • Due date changed from 11/14/2009 to 01/14/2010

Updated by CarlGustaffa over 5 years ago

I have played since OFP days, and I have never ever laid my eyes on a rotor head ingame. Having numerous heli trips in real life (offshore business), and a more than usual interrest into general aviation (friend owns a plane), you might think I'd notice. But I didn't. Please enlighten me as to why on earth such a feature would mean anything.

Are people voting yes to just about any suggestion they see? If votes are used, it would mean that important stuff are left behind in order to implement such a rather completely useless (no tactical value whatsoever) feature, that would only be seen by a selected few peoples.

Edit: Whatever is implemented in addons is fine naturally. The more detail the better, usually. But keep advanced animation (enough and it WILL eventually have an impact) to the point where they are seen by "anyone" or they have a tactical value. This is a military simulation game, not a flight simulator. We're already suffering from bad performances.

Updated by zGuba over 5 years ago

Feature that is working (even partially) should be done properly.

Making such animations right would have little if any impact on performance, I'm asking for general continuity there. BTW please look at actual rotors animation that makes them bent down according to RPM if You think there's big impact on performance.

Updated by kju over 5 years ago

  • Due date deleted (01/14/2010)

Updated by zGuba about 5 years ago

  • Subject changed from Working cyclic mechanism animation on helicopters, possibly controlled by thrust vector to Eye candy: cyclic animation on helicopters
  • Assignee deleted (zGuba)
  • Maxmem parameter deleted (Not set)
  • Difficulty deleted (Not set)

Updated by zGuba about 5 years ago

  • File deleted (cyclic_animations.jpg)

Updated by zGuba about 5 years ago

  • Subject changed from Eye candy: cyclic animation on helicopters to Working cyclic X/Z and collective animation sources on helicopters

Updated by zGuba almost 5 years ago

  • Category changed from Model to Animations

Updated by zGuba about 3 years ago

  • Status changed from Assigned to Closed
  • Target version set to 1.51.71083

I don't know which build exactly had it, but there are cyclicAside and such animation source.

Updated by zGuba about 3 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF