Bug #4102

CTD from russian civilian player approaching russian civilian AI

Added by Solus over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:08/28/2009
Priority:Normal Due date:09/28/2009
Assignee:Dwarden % Done:

100%

Category:Game Crash
Target version:1.04.59026
Affected ArmA II version:1.04 BETA First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

To test: Place the player as Civilian > Russian > Civilian (Brown) in the editor, then place another one for an AI about 10-20 meters away, then start the mission and approach the AI civilian and the game should crash to the desktop.

Probably something in the core .fsm files?

Tested with latest beta.

History

Updated by zGuba over 5 years ago

  • Due date set to 09/28/2009
  • Status changed from New to Assigned
  • Priority changed from Low to Normal

Seems to be easy to reproduce, however dump files are welcome :)

Updated by Dwarden over 5 years ago

  • Status changed from Assigned to In progress
  • Assignee set to Dwarden
  • Target version set to 1.05 BETA
  • % Done changed from 0 to 10

able replicate, WIP

Updated by Dwarden over 5 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 10 to 90

should be fixed now

Updated by zGuba over 5 years ago

  • Status changed from Resolved to Closed

The issue seems to be fixed, but why do Russian civilians talk to other Russians in Chernarussian?

Updated by zGuba over 5 years ago

  • % Done changed from 90 to 100

Updated by kju over 5 years ago

  • Target version changed from 1.05 BETA to 1.04 BETA

Updated by kju over 5 years ago

  • Target version changed from 1.04 BETA to 1.04.59026

Also available in: Atom PDF