Bug #4053

Leg wounded soldiers forced to crawl can't do so when carrying Javelin

Added by Tankbuster about 6 years ago. Updated about 5 years ago.

Status:Closed Start date:08/26/2009
Priority:Normal Due date:
Assignee:- % Done:


Target version:-
Affected ArmA II version: First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:


Noticed this in Domination, but given it's appearance and context, I expect it's a game level bug rather than mission related.

After a player has been leg wounded, they have to kitten crawl everywhere, but those carrying Javelin (it's put on the back when the soldier goes prone) can not crawl. He sort of jiggles a long an inch or so like the first few frames of the anim. Sound likewise. There a brief noise, probably then first few microsecs of the crawl sound.


Updated by kju about 6 years ago

  • Status changed from New to Assigned

A simple repro mission would be very much appreciated.
Not 100% necessary, yet would speed up the fixing process.

Updated by Fireball about 6 years ago

  • Due date changed from 09/09/2009 to 09/19/2009
  • Difficulty set to Not set

Giving some more time for repro...

Updated by Tankbuster about 6 years ago

I'm not sure a repro mission would do it? I mean, can you wound a soldier specifically in the leg using code?
Would an ingame vid help?

Updated by kju about 6 years ago

  • Due date changed from 09/19/2009 to 12/19/2009

It is okay.

Updated by Tankbuster about 6 years ago

Hmm, well, I now cannot reproduce this.
The leg wounded guy goes prone if you try to move. If he's got the Javelin selected, he'll get to his knees, switch to rifle, go prone again, back to knees, swithc to rifle... this repeats all the time you press a move key.

Updated by kju about 6 years ago

Well that anim loop is as ugly..

Updated by Tankbuster about 6 years ago

Indeed. Ugly or not, I think it's bug level because the player can not move as expected when the key is pressed, so I thin I'll raise a new issue.

Updated by alef almost 6 years ago

  • Reproduced by another DH user set to No
  • CPU set to Please specify!

I've tried to repro this yesterday with 1.04. Two playable AT, just shoot other's legs, teamswitch and walk.
The switch from Jav to rifle happens, but only once. Also AI crawl fine, and can shoot.

Your points, please?

Updated by Fireball almost 6 years ago

  • Due date changed from 12/19/2009 to 12/27/2009
  • Status changed from Assigned to Feedback

Still needs feedback.

Updated by Tankbuster almost 6 years ago

I can't reproduce this reliably now and have other projects that are pressing me for time. Sorry guys.

Updated by alef over 5 years ago

  • Status changed from Feedback to Expired
  • CPU changed from Please specify! to n/a

Updated by alef about 5 years ago

  • Due date deleted (12/27/2009)
  • Status changed from Expired to Closed
  • Affected ArmA II version deleted (1.03.58627)

Also available in: Atom PDF