Bug #3936

Quad SLI not functioning

Added by Exarch_Belisarius almost 6 years ago. Updated over 4 years ago.

Status:Expired Start date:08/23/2009
Priority:Normal Due date:04/01/2011
Assignee:- % Done:

0%

Category:Performance breakdown
Target version:-
Affected ArmA II version:1.52.71816 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

While my system's quad SLI setup has worked successfully in games such as Stalker:CS, Assassin's Creed, and GTA IV, it has had trouble with Arma2.

As shown in screenshots attached, GPU0 and GPU1 appear to be under load, with temperatures around ~60 degrees Celsius, while GPU2 and GPU3 hover at an ambient ~45. In other games, GPU temp has reached ~80 degrees under load. Indicative of under-utilisation?

Case 1: Average FPS with all 'low' and 10km viewdistance is 15 in Chernogorsk, +10 in the open. Texture load times are instantaneous.

Case 2: Average FPS with 3km viewdistance and all on very high is 20 in Chernogorsk, +5 in the open. Texture load time is several seconds after load screen (ie can walk around with slight pausing as textures materialise, before framerate stabilises).

In both cases, zoomed field of view also gives +10. CPU load is ~30% over four cores, with the other four being at 0% (confirming that Arma2 does not utilise HT as yet?).

Prior to this driver update (190.62), having any SLI mode (in Nvidia control panel) greater than one GPU enabled caused a stutter or reduction in framerate which increased with the number of GPUs (ie 4GPUs stuttered at approx 3fps in menu) whereas performance with a single GPU is as expected if it were a discrete card, I gather (such as a 260). This has since been resolved with the Forceware update, but now performance does not increase irrespective of the number of cores enabled.

Possible solutions attempted to date, all unsuccessful:
Forceware 185.85, 186.18 (with and without Nvidia SLI Patch and EVGA SLI fix), 190.38.
-maxmem=2047 -winxp -nosplash -window
Arma2.cfg localvram equals 896MB in bytes
Disabled VSync in NV Control Panel, disabled PhysX acceleration
Disabled Hyperthreading in BIOS
Used Crysis SLI profile with nHancer

Other System Specs:
Intel Core i7 940 2.93GHz
4096MB 1333MHz DDR3 RAM
Two 150GB 7200rpm Western Digital HDDs in striped RAID
Gigabyte GA-EX58-EXTREME Motherboard
Corsair HX1000W PSU

Onscreen display top left is Rivatuner 2.24 and top right is Fraps. Currently unable to get Rivatuner to display VRam usage / GPU load data. Please inform me if I am mistaken in some respect, or if more information is required.

Quality_Emphasis.jpg (673.9 kB) Exarch_Belisarius, 08/23/2009 12:25

View_Distance_Emphasis.jpg (590.4 kB) Exarch_Belisarius, 08/23/2009 12:25

GPU-Z_Tests.xlsx - GPU-Z Logs of all four graphics adapters, and graphs (250.1 kB) Exarch_Belisarius, 12/29/2009 12:20

GPU-Z_Tests.ods - Open Document Spreadsheet format for OpenOffice (86.9 kB) Exarch_Belisarius, 12/29/2009 23:10

GPU-Z_Tests.xls - Excel 2003 format (637 kB) Exarch_Belisarius, 12/29/2009 23:10

GPU-Z_Sensor_Log.xlsx - Four instances (one per GPU) of GPU-Z run during Arma2OA.exe benchmarks. (174.7 kB) Exarch_Belisarius, 08/16/2010 03:01

GPU-Z_Sensor_Log.ods - Open Document Format (101 kB) Exarch_Belisarius, 08/16/2010 03:20

GPU-Z_Sensor_Log.xls - Office 2003 Format (444.5 kB) Exarch_Belisarius, 08/16/2010 03:20

History

Updated by Exarch_Belisarius almost 6 years ago

Converted screenshots to .jpg to reduce copious size with no quality reduction.

Updated by Exarch_Belisarius almost 6 years ago

  • File Users-Me-AppData-Local-ArmA2.zip added

Experienced a game crash with 10k viewdistance while piloting an AH-1Z. Sound cut out, game froze, but did not CTD. Task Manager reported game stopped responding, so I forced it to end but the error report failed to send (probably due to in-house internet configuration through proxy). Dump files attached.

Updated by Fireball almost 6 years ago

  • Due date changed from 09/06/2009 to 09/23/2009
  • Status changed from New to Assigned

I guess they'll have to look into getting dual SLI to run better first, then this will probably work out as a bonus on top.

Updated by Fireball almost 6 years ago

Belisarius, I recommend you open a separate CTD bug for your crash with the dump, else it might end up ignored in this one. Let me know and I'll remove the dump attachment from this bug when you are ready.

Updated by Exarch_Belisarius almost 6 years ago

Feel free to delete the CTD zipped data at-will, I have a backup. I'll submit another bug report if the crash happens again, I guess.

Updated by Fireball almost 6 years ago

  • File deleted (Users-Me-AppData-Local-ArmA2.zip)

Updated by Fireball almost 6 years ago

  • File deleted (Quality_Emphasis.bmp)

Updated by Fireball almost 6 years ago

  • File deleted (View_Distance_Emphasis.bmp)

Updated by Fireball almost 6 years ago

  • Due date changed from 09/23/2009 to 10/23/2009

Updated by Fireball almost 6 years ago

  • Due date changed from 10/23/2009 to 12/23/2009
  • Reproduced by another DH user set to No
  • CPU set to Please specify!

Updated by Exarch_Belisarius almost 6 years ago

CPU is Core i7 940 2.93 GHz (unable to set that value myself?)

Also note that the Case 1 and Case 2 lines should read as follows: (inaccurately reported issue the first time)

"Case 1: Average FPS with all 'low' and 10km viewdistance is 15 in Chernogorsk, +10 in the open. Texture load times are instantaneous.

Case 2: Average FPS with 3km viewdistance and all on very high is 20 in Chernogorsk, +5 in the open. Texture load time is several seconds after load screen (ie can walk around with slight pausing as textures materialise, before framerate stabilises)."

I've heard a few people muse that their GTX 295 has slower than expected texture loading speed in Arma 2, and consider that my experience supports this statement.

Updated by Fireball almost 6 years ago

  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026

Updated description according to reporter.

Updated by Fireball almost 6 years ago

  • CPU changed from Please specify! to Core i7 940 2.93 GHz

Updated by Fireball almost 6 years ago

This is probably not connected with SLI, but since you put this into description observation:

Texture loading is heavily dependent on HDD speed; it's not kept in Video RAM all the time (looking at Graphics Card with 1 GB RAM today though, you could probably load more textures earlier into Video RAM and keep it there too, but still a lot is not even buffered in regular RAM).

You could try out loading the game files onto a RAM disk (PBO files) - if anything this will improve texture load times big time, until internal optimizations could be done on part of BI.

Updated by Exarch_Belisarius almost 6 years ago

Confirmed: Affected Version 1.04; also, still present Forceware driver version 191.07 WHQL (though performance, as stated, has improved slightly once again).

Thanks for updating all that, Fireball. Also, using a RAM disk is a brilliant idea; I'm amazed I'd never heard of the concept. I guess the downside is, with a vanilla Arma 2 folder 8.3GB large, I'm going to have to purchase another 6-8GB of RAM (an upgrade planned down the track), and the commercial version of a powerful RAM disk program.

Updated by kju over 5 years ago

  • Due date changed from 12/23/2009 to 11/14/2009
  • Status changed from Assigned to Feedback

Can you please test the latest beta patch and report back:
http://www.arma2.com/beta-patch.php

[59924] Fixed: More 32b overflows caused by 8 GB RAM + large VRAM.

Updated by Exarch_Belisarius over 5 years ago

With every setting on Very High and a 3.5km view distance prior to Beta Build 59924 I seemed to be experiencing game lock-up crashes very frequently, particularly while flying fast (causing many textures to load continuously) and generally accompanied by white textures (sky and terrain) popping in and out. This issue seems to be resolved with 59924 which is brilliant.
GPU temperature distribution (separation of 10 degrees celsius between GPUs 0, 1 vs 2, 3)seems to be similar to prior, and I can't really say FPS has appreciably improved over the performance gained by Forceware 191.07 WHQL - perhaps another 5 FPS on average is possible.

Updated by kju over 5 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 1.05 BETA

Thanks a lot for testing and the confirmation!

Updated by Exarch_Belisarius over 5 years ago

Well... are we saying that the Quad SLI functionality is not an issue for this bug tracker? Because conceivably the CTDs are a separate issue to the game's optimisation for multiple GPUs. I haven't seen evidence yet of my graphic performance rivalling or surpassing that of a friend's 9800GTX+, and that was the original reason I posted this bug.

Updated by kju over 5 years ago

I have reviewed the ticket.

First of your header is pretty bad summarizing the problem ('Quad SLI not functioning').
What you are saying is that you do not get the performance you expect, right?

Most likely your bottlekneck is not the GPUs, so how should BI improve it?
You can bump up your res and video related settings probably.

So again please specify the problem in a short, best bullet point, description.
Thank you.

If you really think there is a bug in utilizing 4 GPU's and you are very sure
the game engine is the problem and nothing else, you need to provide repro
steps and demo missions.

To be realistic CPU/board/RAM/caching/streaming is the bottlekneck for the
vast majority of people - most likely for you too.

Updated by kju over 5 years ago

  • Status changed from Resolved to Feedback

Updated by kju over 5 years ago

  • Due date deleted (11/14/2009)
  • Status changed from Feedback to Resolved

No response.

Updated by Exarch_Belisarius over 5 years ago

I agree that my support ticket needed to be more clear from the outset, so I'll provide a synopsis in the future before launching into the details. Now, these are my two observations on which this ticket is now based:

A friend with an identical motherboard, a core i7 920 (compare w/- my 940), and a 9800GTX+ (compare quad ~260 chips, each presumably less powerful and less easily coded for than a single 9800GTX+), experiences smashing performance (FPS) with all graphical settings maxed out bar view distance. With the latest nVidia drivers and Arma2 patches, my performance has become comparable to what his was at the game's release. But I am hoping for more because of the combined power of these chips.

Second, before a recent Forceware driver disabled split-frame rendering for me entirely, when running Arma2, the four segments were distributed approximately so down my screen - 40%, 15%, 15%, 30% top to bottom. Additionally, temperature distributions raised above ambient are generally +15, +10 (on same board as core one), +5, +5 degrees Celsius for cores one through four respectively, leading me to believe work distribution is unequal therefore some cores are not doing as much work as they could be.

I concede, particularly in the case of view distance, that my cpu or another part could be the bottleneck, and as soon as I have funds for extra RAM I'm going to play with running Arma2 from a RAMdisk and assess whether texture load times are the governing factor. But this ticket exists in the possibility that BIS or nVidia need feedback about how an end user with Quad-SLI experiences the game, and to let them know that there may still be work to be done in this area. In the case that it is the game engine, what repro steps / demo missions could I possibly provide to demonstrate my symptoms? If it doesn't waste more of your time, I'm glad to hear which assumptions I've made are erronious for what reasons.

Updated by Fireball over 5 years ago

  • Due date set to 01/23/2010
  • Status changed from Resolved to Assigned
  • Target version deleted (1.05 BETA)

When I understand correctly, SLI performance is not given at any time; it's more like single GPU performance still.

Updated by Exarch_Belisarius over 5 years ago

Fireball wrote:

When I understand correctly, SLI performance is not given at any time; it's more like single GPU performance still.

I'm sorry, what exactly do you mean here? If the development teams are certain no further improvement can be practically made on this front due to some hardware limitation, fine by me. I'm just speculating that there is a problem, but my knowledge is obviously not as in-depth.

Updated by Fireball over 5 years ago

I was just trying to summarize your observations. I'm not implying anything - I'm not a developer, only a CIT manager and not affiliated with BIS.

Updated by kju over 5 years ago

Exarch Belisarius is it possible to provide some more in depth testing data,
like using GPU-Z to measure GPU use.

Also please check this ticket: #1745
Try its missions, measure FPS with fraps (graph), taskmanager (CPU) and other
tools.

Remember, we are only community member like you, try to help BI find issues
and users like you to make the game more playable.

Some graph data is way more useful vs some snapshot data.
And best with a mission that we can compare with others.

Updated by Exarch_Belisarius over 5 years ago

Affected Version: 1.05
No Maxmem parameter
Graphics card driver version: Forceware 195.62 WHQL

Attached are four log files within this Excel 2007 spreadsheet, one per instance of GPU-Z. Each instance was set to monitor one of the four 295GTX adapters. Graphs are shown on the fifth sheet.
Particular graphics settings are also denoted on the fifth sheet. Due to the labour intensive nature of this data gathering, I have not tried varied settings, but feel free to suggest that I do; for example i7 Hyperthreading off, if you are interested in the results.

Updated by kju over 5 years ago

Thanks. That said please attach as format viewable with OO and Excel 2002/XP.

Updated by Exarch_Belisarius over 5 years ago

Good thinking.

Updated by kju over 5 years ago

  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Thank you. Pretty good data.

It is strange as normally its said that drawing threads can be "easily"
made multithreaded and therefore share among multiple GPU processors.

One important setting your are missing though.
You need to use -cpuCount=4 (or disable HT). It is said to cause mini stutter
and FPS impact.

Updated by kju over 5 years ago

  • Due date changed from 01/23/2010 to 03/04/2010

Updated by kju almost 5 years ago

  • Due date changed from 03/04/2010 to 10/01/2010
  • Status changed from Assigned to Feedback
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Any difference in latest OA?

Updated by Exarch_Belisarius almost 5 years ago

Accidentally pressed the submit button, sorry. Here is a plot of the GPU-Z readings for each core during a run of Arma 2 OA v1.52. It appears to have the same problem as at a year ago - there is one core averaging 50% workload and the other three are at around 15%. However, it used to be one core at about 100% and the others around 40%. This probably indicates a bottleneck at the CPU. With every patch and graphics driver update since last year I would have said game performance has improved for my setup, to a point that I am now happy with it. The question is, do other games similarly use one core mainly and barely utilise the others? I may conduct further benchmarking and report back.

maxmem=2047, and the game terminated during a benchmark mission with an 'out of memory' error.
System page file (virtual memory) size = 4093MB.
Audio is motherboard Realtek High Definition Audio (RTKVHD64.sys)

I suspect the slow texture load times (which appear to generally be the cause of lower framerates for me) are symptomatic of my RAM configuration - two 2GB 1333MHz 1.60V DIMMs. The reason I believe this to be the cause is that I tried two 2GB 1333MHz 1.50V DIMMs from the same manufacturer's economy brand and noticed further performance degradation with similar characteristics, i.e. lower framerate, extended texture pop-in delays. I intend to upgrade my RAM further soon and will report if a performance increase is noticeable.

Updated by kju almost 5 years ago

  • Affected ArmA II version changed from 1.05.62017 to 1.52.71816

Thanks for the feedback mate.

Do you use 1.52 or beta patches?
If not, you should really do the later.
It makes use of 3GB+ and contains many many improvements.

Updated by kju over 4 years ago

  • Due date changed from 10/01/2010 to 04/01/2011

Any improvements here with the latest version or 1.58 RC?

Updated by Dwarden over 4 years ago

  • Status changed from Feedback to Expired
  • Language set to Please set for missions

Also available in: Atom PDF