Bug #3717

Far too drastic "weapon jitter" when fatigued

Added by dslyecxi almost 6 years ago. Updated over 5 years ago.

Status:Closed Start date:08/17/2009
Priority:Normal Due date:10/02/2009
Assignee:rocko % Done:

100%

Category:Config
Target version:0.6
Component:anims_weaponsway Affected Version:
Close Reason:

Description

As of alpha 2 the weapon sway when a player is somewhat fatigued (ie: sprinting for about 5-10 seconds) is extremely severe. The weapon jumps around on screen in wide movements. This is just painful to deal with - in reality you would be able to hold a standard battle rifle much more stable, even if fatigued.

Suggestion would be to tone this effect down significantly.


Related issues

duplicates A.C.E. for OA - Bug #3716: Sway boosts up insanely high when going from prone to sta... Closed 08/17/2009

History

Updated by Sickboy almost 6 years ago

  • Status changed from New to Duplicate

Updated by rocko almost 6 years ago

IMO this is not a duplicate. 3716 is wrong transitions sway values and this (1717) is too high values in general causing erratic ans spastic movement of the gun, once a certain fatigue level is reached (max).

Updated by rocko almost 6 years ago

POSTED ON THE 6TH TRACKER (re: pistol sway, and general sway for mg vs. rifle):
Sway might seem to be "realistic" for a M240 but not for a light carbine. Configwise there is only "one for all (rifle or pistol) value". That means the sway for a M240 is the same as for a M4. Currently it is also - almost - the same for pistols (Rifle standing: sway 7.2, Pistol standing: sway 6 [all stances])
In short: Carbines and pistols have the same sway like a heavy machinegun.

It is not possible to have different sway for different weapons, i.e M4, SVD, PK etc. Only one for all.

So one might consider to drop the sway story completely, as it causes an unfair impression when carrying a light battle rifle. Instead the recoil should be changed for machineguns while in standing stance, compensating the lack of proper sway (is then only rifle sway) and in the same time returning back acceptable sway for rifles (WAS machinegun sway then).

Updated by Sickboy over 5 years ago

  • Status changed from Duplicate to Feedback
  • Assignee set to Sonsalt

Not a duplicate then. Next time reopen it plz Rocko.

Updated by dslyecxi over 5 years ago

Easy repro as of current version is to fire a few shots at your feet to trigger 'suppression', then try crouch-walking or walking in ironsights.

Updated by Sonsalt over 5 years ago

thx will see what I can do

Updated by rocko over 5 years ago

  • Priority changed from Normal to High

Updated by dslyecxi over 5 years ago

Still behaves the same as of the latest version. Any chance of getting this fixed? I won't speak for anyone else, but for me, this is a gamebreaker to the point that I would rather not place ACE than have to deal with this.

Repro is the same. Fire a few shots at your feet and suddenly you have jello arms.

Updated by zGuba over 5 years ago

It's caused by BI bug that makes units scared of own bullet ricos, scaled with excessive ACE sway values. Next version should have this effect about half lower.

Updated by dslyecxi over 5 years ago

Tested version from today. Still extremely overdone. Why not just stick with the default BIS values, and work from there? Is there a reason this is being changed right now? It seems unnecessary at the moment. I would think that tweaking recoil values would be more gameplay-beneficial than introducing a method that makes it utterly impossible to aim.

I can provide video of the difference between default A2 and ACE2 right now as far as this goes, if needed. Same repro as in prior posts can reveal the same thing. The current system just isn't fun to deal with. Default A2 seemed to get it done fine - changing it from there doesn't seem to be doing anything but add a level of unnecessary frustration.

Updated by zGuba over 5 years ago

  • Category set to Config
  • Assignee changed from Sonsalt to ViperMaul
  • Component set to anims_weaponsway

OK, I guess that we can abandon this addon at all. Quite useless these days, with spoiled BI crouching animations etc.

Moving the token to ViperMaul: hot or not?

Updated by zGuba over 5 years ago

  • Due date set to 10/02/2009

Updated by Sickboy over 5 years ago

Dsly, just to make sure, the date/time on the ace_anims_weaponsway are indeed from Sunday? If so, I'd agree with removal.

Updated by dslyecxi over 5 years ago

Yes, they're from Sunday.

Updated by Sickboy over 5 years ago

dslyecxi wrote:

Yes, they're from Sunday.

Tnx. Have you by chance tested without mentioned addon ? If not, please do to confirm the problem is actually in our Sway adjustments.
The video you mentioned is not too important though I am personally interested to quickly see the difference :)

Updated by rocko over 5 years ago

  • Assignee deleted (ViperMaul)
  • Priority changed from High to Urgent

New values.

Please test and give feedback.

Values are vanilla values raised by 25%.

Updated by rocko over 5 years ago

  • Status changed from Feedback to Closed
  • Assignee set to rocko
  • Priority changed from Urgent to Normal
  • % Done changed from 0 to 100

Updated by Sickboy over 5 years ago

  • Target version set to 0.6

Also available in: Atom PDF