Bug #3668

AI vehicle gunner enforces weapon selection - ignores orders even with manual fire enabled

Added by TheCaptain over 5 years ago. Updated about 5 years ago.

Status:Closed Start date:08/15/2009
Priority:Normal Due date:
Assignee:- % Done:

50%

Category:AI Issues
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

While in a vehicle under command of a player, AI gunners will autonomously change their weapon and attempt to fire at enemies, overriding the weapon chosen by the player (whether manual fire is on or off).

This is acceptable behavior when commanding a tank, as the AI gunner may change to a machinegun and engage enemy infantry.

In a helicopter this behavior is very frustrating, as an AI gunner will regularly switch to unguided rockets while the player has AT missiles selected and is trying to fire at an enemy vehicle. Since the AI cannot fire these rockets without the helicopter pointing directly at the target, it is up to the player to change back to AT missiles and fire before the AI changes the weapon back to unguided rockets.

This tends to occur when the target locked is 'red' in radar as opposed to a 'yellow' target. It is possible that the AI feels threatened by a target and chooses to a more 'appropriate' weapon.

In OFP and Arma I the weapon choice was fixed to that selected by the player and this behavior did not occur.

Repro steps:
Place an attack helicopter with a pilot and gunner on the map (ah1-z, mi24d/v/p, ka-52)
Place more than one enemy tank within visual range (~1000m away)
Set the player as driver of the helicopter, switch to AT missiles, and fly towards the tanks
Things to try: manual fire on/off, selecting a target or selecting no target.

Results seen: When the targets appear red on radar, the gunner will switch weapons to unguided rockets regardless of the player selected weapon.

Desired results: The AI gunner should either NEVER override the player/commander weapon selection, or alternately, never override the selection when the player has manual fire enabled.

[I will upload a repro mission.]

ZGB_CIT_3668.utes.pbo - Tool for reproductions. (7.9 kB) zGuba, 09/17/2009 01:31


Related issues

related to ARMA2 Community Issue Tracker - Bug #16987: Gunner firing broken (blank ammo) when human pilot activa... Resolved 01/26/2011
related to ARMA2 Community Issue Tracker - Bug #29379: Helo gunners stupidly switch weapons Feedback 03/15/2012

History

Updated by Squelch over 5 years ago

  • Status changed from New to Assigned

Thanks for the report TheCaptain.

This might be closely related to the hold fire command which seems to be ignored by the AI. They select what they think to be the most appropriate weapon for the target, which in many cases is not the target you wish to be engaged, nor the weapon that you wish to use.

Updated by Fireball over 5 years ago

  • Due date set to 09/15/2009

Updated by zGuba over 5 years ago

The issue is most annoying when AI switches to AT missiles while engaging infantry targets. Quite retarded, isn't it?

Updated by arewenotmen over 5 years ago

The OP described this as acceptable when in a tank. Unfortunately, it is often fatal, so I would like to request considering of any fix's broader impact.

If you are commanding a tank crewed by AI, and in an area with both enemy infantry and enemy armor, it becomes impossible to engage the armor. You order them to switch to the cannon and select the armor target, but they will usually switch back to guns and/or ignore the targeting in order to engage infantry. This means you are unable to engage the armor, and are often destroyed by it.

In my opinion, once the player selects a target, the AI should target it and not change weapon until the target is destroyed OR the player selects 'no target'. Outside of this they should be free to resume their previous behaviour.

Updated by Fireball over 5 years ago

  • Due date changed from 09/15/2009 to 09/25/2009

Updated by Fireball over 5 years ago

arewenotmen wrote:

In my opinion, once the player selects a target, the AI should target it and not change weapon until the target is destroyed OR the player selects 'no target'. Outside of this they should be free to resume their previous behaviour.

Amen!

Updated by zGuba over 5 years ago

arewenotmen wrote:

In my opinion, once the player selects a target, the AI should target it and not change weapon until the target is destroyed OR the player selects 'no target'. Outside of this they should be free to resume their previous behaviour.

Amen as well!

Updated by Fireball over 5 years ago

  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball over 5 years ago

  • Subject changed from AI Helicopter Gunner Changes Weapon (Overrides Commander Weapon Order) to AI Vehicle Gunner Changes Weapon (Overrides Commander Weapon Order)

Updated by Dwarden over 5 years ago

  • Priority changed from Normal to High
  • Target version set to 1.05 BETA

Updated by zGuba over 5 years ago

  • File ZGB_CIT_3668.utes.pbo added

Updated by zGuba over 5 years ago

  • Subject changed from AI Vehicle Gunner Changes Weapon (Overrides Commander Weapon Order) to AI Vehicle Gunner Changes Weapon (Overrides Commander Weapon Order Even Wih Manual Fire On)

Updated by zGuba over 5 years ago

  • Subject changed from AI Vehicle Gunner Changes Weapon (Overrides Commander Weapon Order Even Wih Manual Fire On) to AI Vehicle Gunner Changes Weapon (Overrides Commander Weapon Order Even With Manual Fire On)

Updated by zGuba over 5 years ago

Reproduction tip: try strafing at enemy positions with manual fire enabled. Issue occurs when you mess around the targets for a while.

Updated by zGuba over 5 years ago

  • Subject changed from AI Vehicle Gunner Changes Weapon (Overrides Commander Weapon Order Even With Manual Fire On) to AI vehicle gunner enforces weapon selection - ignores orders even with manual fire enabled

Updated by zGuba over 5 years ago

  • File deleted (ZGB_CIT_3668.utes.pbo)

Updated by zGuba over 5 years ago

Updated by Dwarden over 5 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 50

fixed for manual fire

Updated by kju over 5 years ago

  • Priority changed from High to Normal

Updated by kju over 5 years ago

  • Due date changed from 09/25/2009 to 10/07/2009

[59030] Fix: Helicopters - when manual fire on, do not allow AI gunner to switch weapons.

Please test with latest beta patch.

Updated by Fireball over 5 years ago

  • Due date changed from 10/07/2009 to 11/07/2009
  • Reproduced by another DH user set to Yes
  • CPU set to Please specify!

Still needs testing.

Updated by zGuba over 5 years ago

Fireball wrote:

Still needs testing.

How can it come? Now gunner AI works very much like in ArmA under player's command, hence it's still not perfect.

I've noticed that AI is too dumb to switch weapons on its own now, for tanks f.e. you have to tell it to switch weapon first or it will engage other tanks with machine gun, giving up your position and wasting time/ammo again. Probably tweaks are still needed.

Updated by Fireball over 5 years ago

  • Due date changed from 11/07/2009 to 11/27/2009

If you want enhancements beyond the bugfix, open a feature request, zGuba.

Updated by kju over 5 years ago

  • Due date deleted (11/27/2009)
  • Assignee deleted (Dwarden)

Waiting for 1.05 final.

Updated by kju about 5 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.05 BETA to 1.05.62017

Also available in: Atom PDF