Bug #3505

Kill scoring is broken in MP

Added by sbsmac almost 6 years ago. Updated over 5 years ago.

Status:Closed Start date:08/09/2009
Priority:Normal Due date:09/16/2009
Assignee:- % Done:

100%

Category:Multiplayer
Target version:1.04.59026
Affected ArmA II version:1.03.58627 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

Quite often you are awarded 2 or more kills for killing an enemy. You can also often see that you are reported to have died twice even after a single respawn. I did not notice this behaviour in 1.02 although occasionally you would see duplicated "[SBS] mac" was killed which may have been related.

I have uploaded a very simple mission to demonstrate the problem.

Start as one of the west players - it doesn't seem to matter which one.
Run towards the hangar - the east AI are hidden behind it.
Press 'I' to check score - it shows 0 (actually it is blank).
Sneak round the edge of the hangar and shoot the first AI you see
Press 'I' to check score - at least 50% of the time it will show 2 kills rather than 1.

I see this behaviour using both the MP editor and a dedicated server.

I will try to upload a video later demonstrating this.

temp.utes.pbo - demonstration mission (2.9 kB) sbsmac, 08/09/2009 08:18


Related issues

related to ARMA2 Community Issue Tracker - Bug #5004: MP scoring starts randomly some time after the first coup... Assigned 10/04/2009 05/01/2011
duplicated by ARMA2 Community Issue Tracker - Bug #3979: KILLED event handler triggered more than one time Duplicate 08/24/2009 09/24/2009
duplicated by ARMA2 Community Issue Tracker - Bug #3660: Scoreboard Duplicate 08/14/2009

History

Updated by sbsmac almost 6 years ago

An alternative way of demonstrating the problem is to let yourself be killed by the AI. The scoreboard will often mark 2 deaths against you.

Updated by kju almost 6 years ago

  • Status changed from New to Assigned
  • Target version deleted (1.03.58659 server)
  • Affected ArmA II version changed from Please select... to 1.03.58627

Updated by sbsmac almost 6 years ago

http://www.youtube.com/watch?v=jFAaa4N5TJE

I've just uploaded a video showing the behaviour. It's a bit scrappy since I had to record it in 30 second sections then stitch them together.

In the first section, I create a new map in the multiplayer editor. Just a west and east player.

I then start the map (preview) as west and shoot the east AI. At this point the scoreboard shows 2 kills rather than the expected 1.

I then use 'restart' to replay the scenario several times.

It seems that headshots and upper-body shots are virtually certain to give to 2 kills whereas shots to the legs and lower body only offer 1 kill.

Updated by thomsonb almost 6 years ago

I have noticed this issue also in SINGLE PLAYER. The player is sometimes awarded double the "rating" score for a kill.
Also the KILLED event handlers for some units are activated TWICE, these are related to each other somehow...

I have only noticed this AFTER installing patch 1.3

Updated by Fireball almost 6 years ago

  • Due date set to 09/09/2009

Updated by sbsmac almost 6 years ago

See this report as well http://dev-heaven.net/issues/show/3979 which claims that the killed eventhandler is being called twice.

Updated by kju almost 6 years ago

Anyone tried to repro in the beta patches?

Updated by Armored_Sheep over 5 years ago

  • Status changed from Assigned to In progress
  • Assignee set to Armored_Sheep
  • Difficulty set to Not set

Will check that.

Updated by Dwarden over 5 years ago

  • Status changed from In progress to Resolved
  • Target version set to 1.04 BETA
  • % Done changed from 0 to 50

Updated by kju over 5 years ago

  • Due date changed from 09/09/2009 to 09/16/2009
  • Status changed from Resolved to Feedback
  • Assignee deleted (Armored_Sheep)

Thanks Armored_Sheep!

Can someone please confirm the fix.

[58930] Fixed: Broken kill scoring in MP (two points for unit kill).

Updated by Dwarden over 5 years ago

  • % Done changed from 50 to 100

resolved, retested, done, with latest builds

Updated by kju over 5 years ago

  • Status changed from Feedback to Resolved

confirmed in BIF

Updated by kju over 5 years ago

  • Status changed from Resolved to Closed

Updated by kju over 5 years ago

  • Target version changed from 1.04 BETA to 1.04.59026

Also available in: Atom PDF