Bug #3399

Analogue throttle does not work for choppers

Added by Fireball over 5 years ago. Updated over 4 years ago.

Status:Closed Start date:08/05/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Controls
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Analogue throttle does not work in choppers; workaround is to assign both digital and analogue throttle, which will eventually override the analogue throttle within planes


Related issues

related to ARMA2 Community Issue Tracker - Feature #1848: Option for analog throttle Closed 06/05/2009 08/20/2009
related to ARMA2 Community Issue Tracker - Feature #2677: Add Increase/Decrease thrust actions Assigned 07/08/2009
related to ARMA2 Community Issue Tracker - Feature #3546: Allow use of joystick full axes Closed 08/10/2009
related to ARMA2 Community Issue Tracker - Feature #3687: Analog Throttle for Airvehicles (rework) Duplicate 08/16/2009

History

Updated by Fireball over 5 years ago

You can add up what was said in the BIF http://forums.bistudio.com/showpost.php?p=1393388&postcount=5 (not sure if it's good to bundle this though), and make the throttle/break ratio something more like 80%/20% than 50%/50%.

Updated by kju over 5 years ago

  • Assignee deleted (Suma)
  • Priority changed from Immediate to Normal

Updated by Fireball over 5 years ago

  • Affected ArmA II version deleted ( 1.03.58627)

Fireball wrote:

You can add up what was said in the BIF http://forums.bistudio.com/showpost.php?p=1393388&postcount=5 (not sure if it's good to bundle this though), and make the throttle/break ratio something more like 80%/20% than 50%/50%.

As I was pointed out in a post to my YT video, it indeed has to do with the issue; since we apparently only have 50% of the throttle range. The problem with the Harrier arises. The F-35 is just more powerful, so that the 50% are enough to keep it hovering.

But that also implies, that we're never getting 100% throttle with the analogue control right now, in none of the models.

Updated by Fireball over 5 years ago

  • Affected ArmA II version set to 1.03.58627

Updated by Fireball over 5 years ago

  • Due date set to 09/05/2009

Updated by Fireball over 5 years ago

  • % Done changed from 0 to 50

Updated by Fireball over 5 years ago

  • % Done changed from 50 to 0

Updated by Fireball over 5 years ago

  • Due date changed from 09/05/2009 to 09/25/2009
  • Difficulty set to Not set

Updated by Fireball over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball over 5 years ago

  • Due date changed from 09/25/2009 to 10/25/2009
  • Status changed from Assigned to Feedback
  • Reproduced by another DH user set to No

Can this be fixed at all?

Updated by kju over 5 years ago

  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026
  • Reproduced by another DH user changed from No to Yes

Updated by Fireball over 5 years ago

  • Due date changed from 10/25/2009 to 12/25/2009

Updated by Rangoon over 5 years ago

Fireball wrote:

You can add up what was said in the BIF http://forums.bistudio.com/showpost.php?p=1393388&postcount=5 (not sure if it's good to bundle this though), and make the throttle/break ratio something more like 80%/20% than 50%/50%.

Is there any explanation as to why this is even an issue? Flight sims since the 80s have had analog cyclic/collective/pedals for helicopters, including a function for reverse input control in sims/games which supported both fixed-wing aircraft and helicopters (since the physical motion to increase/decrease power is reversed between them). I don't mean any disrespect because I love the helicopter experience in ArmA/ArmA 2 overall (I fly helicopters for a living). But why is this even an issue? I have not seen any explanation and/or how long this will take.

Updated by Rangoon over 5 years ago

Okay, I see the date set now to December.

Updated by Fireball over 5 years ago

I set the due date for next review date - I'm not from BI.

Updated by kju over 5 years ago

  • Due date changed from 12/25/2009 to 11/14/2009
  • Status changed from Assigned to Feedback
  • Target version set to 1.05 BETA

Please confirm:

[59741] Analogue throttle working for helicopters as well.

http://www.arma2.com/beta-patch.php

1) should be done. 2) not. Feedback please.

Updated by Suma over 5 years ago

"Analogue throtte is unable to keep a Harrier (F35 works btw.) hovering or increasing altitude while hovering"

It would be better to have a separate ticker for each issue, however I will reply here. I do not see an issue specific for analogu throttle. You cannot hover even using keyboard. This is by design. Fully loaded Av8 is not VTOL, only STOVL.

Updated by Suma over 5 years ago

Fireball wrote:

You can add up what was said in the BIF http://forums.bistudio.com/showpost.php?p=1393388&postcount=5 (not sure if it's good to bundle this though), and make the throttle/break ratio something more like 80%/20% than 50%/50%.

Please, do not mix issues. As individual issues can be resolved and closed, it is important to keep each issue in its own tickets. If issues seem related, they can be marked as related.

Updated by kju over 5 years ago

  • Status changed from Feedback to Resolved

There you go. Ask Suma requests, please open new tickets,
with refs to this one, for the other issues.

Updated by Fireball over 5 years ago

  • Subject changed from Multiple analogue throttle issues to Analogue throttle does not work for choppers

I stand corrected about the AV-8B - I was pretty sure I was able to keep it hovering and do VTOL with the keyboard assignments, but now I cannot reproduce that behaviour.

I'll just remove 2) from this ticket and we track the chopper issue.

Updated by kju about 5 years ago

  • Due date deleted (11/14/2009)
  • Assignee deleted (Dwarden)

Waiting for 1.05 final.

Updated by alef about 5 years ago

  • Status changed from Resolved to Closed
  • CPU changed from Please specify! to n/a

Updated by kju about 5 years ago

  • Target version changed from 1.05 BETA to 1.05.62017

Updated by Rangoon over 4 years ago

Will this be fixed - to have actual analog control over throttle/collective? In the helicopter it still is only Descend/Level/Climb based on where the analog throttle is set.

Updated by Fireball over 4 years ago

Rangoon wrote:

Will this be fixed - to have actual analog control over throttle/collective? In the helicopter it still is only Descend/Level/Climb based on where the analog throttle is set.

This bug is fixed (and thus "Closed", as you can see). It was about analogue throttle not working at all in choppers, which is no longer the case since patch 1.05.

If you want a feature request, you must open a new ticket accordingly. Here, your calls are unheard.

Updated by Rangoon over 4 years ago

Thanks Fireball - I knew it was closed, but didn't realize it was actually fixed. I simply needed to reinstate my analog thrust/brake and indeed it's working.

Also available in: Atom PDF