Bug #3233

Mi-24 instead of Mi-28

Added by Alex72 almost 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:08/01/2009
Priority:Low Due date:
Assignee:kju % Done:

100%

Category:Config
Target version:2009-09-05

Description

When targeting the MI-28 it says "MI-24". Like pressing space to indentify.

Associated revisions

Revision 9f5570d2
Added by kju almost 6 years ago

~ Fixed: added accuracy value of Mi24 base class to fix name problem. Thanks to zGuba for the tip! Fixes #3233.

History

Updated by kju almost 6 years ago

  • Status changed from New to Feedback

Replacement or normal unit?

Updated by kju almost 6 years ago

  • Assignee set to modEmMaik

Conf for both. Mike an idea?

Seems not nameSound nor displayName. Could not find any other instance.

Updated by modEmMaik almost 6 years ago

Ist is the German or international Version? AllInOne displayName's look hardcoded for me...

I am not sure, how they are converted.

Updated by kju almost 6 years ago

AllInOne and my local version I used for testing are English.

Updated by modEmMaik almost 6 years ago

Source of the issue is still unknown. I altered the entry's in the MI-24P config, which shows no effect. I am still missing the entry's called "namesound" in the A1 / OFP config.

It seems that this is handled somewhere, not in the vehicleConfig...

Updated by kju almost 6 years ago

Well there still is, yet only at the general level:

1 nameSound = "veh_TrackedAPC";

Might be related to this definition:

 1        class SpeechVariants
 2         {
 3             class Default
 4             {
 5                 speechSingular[] =
 6                 {
 7                     "veh_TrackedAPC" 
 8                 };
 9                 speechPlural[] =
10                 {
11                     "veh_TrackedAPCs" 
12                 };
13             };
14             class EN: Default {};
15             class CZ
16             {
17                 speechSingular[] =
18                 {
19                     "veh_TrackedAPC_CZ" 
20                 };
21                 speechPlural[] =
22                 {
23                     "veh_TrackedAPCs_CZ" 
24                 };
25             };
26             class CZ_Akuzativ
27             {
28                 speechSingular[] =
29                 {
30                     "veh_TrackedAPC_CZ4P" 
31                 };
32                 speechPlural[] =
33                 {
34                     "veh_TrackedAPCs_CZ4P" 
35                 };
36             };
37             class RU
38             {
39                 speechSingular[] =
40                 {
41                     "veh_TrackedAPC_RU" 
42                 };
43                 speechPlural[] =
44                 {
45                     "veh_TrackedAPCs_RU" 
46                 };
47             };
48         };

Defined in

class RadioProtocolEN: RadioProtocolBase
{
    class Words
    {

Maybe the stringtable.xml creates a set of names:

While we overwrite the default:
displayName = "$STR_DN_MI24D";

This is defined in the xml:

<Key ID="str_dn_mi24d">
    <German>Mi-24D</German>
    <English>Mi-24D</English>
    <Italian>Mi-24D</Italian>
    <Spanish>Mi-24D</Spanish>
    <French>Mi-24D</French>
    <Czech>Mi-24D</Czech>
    <Russian>??-24?</Russian>
    <Polish>Mi-24D</Polish>
    <Hungarian>Mi-24D</Hungarian>
</Key>

Updated by Xenomorph almost 6 years ago

Have you tried talking to the guys that made the F-16 model (http://www.armaholic.com/page.php?id=5900)? They seem to have avoided the problem.

Updated by kju almost 6 years ago

  • Status changed from Feedback to New
  • Assignee deleted (modEmMaik)
  • Priority changed from Normal to Low

Well he uses Plane as base class, while we inherit from the Mi24.

Updated by Xenomorph almost 6 years ago

I suppose the obvious question here would be is there some kind of "Helicopter" base class you could use instead of the Mi-24?

Updated by kju almost 6 years ago

Well this has several downsides. So not really an option for this
minor naming issue. :(

Updated by zGuba almost 6 years ago

Set the accuracy so Mi-24 generic displayname won't show up.

Sound name should be changed to "helicopter" or "gunship" if avaiable.

I've done such things for A.C.E. most recently.

Updated by zGuba almost 6 years ago

  • Category set to Config

Updated by kju almost 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Updated by kju almost 6 years ago

  • Assignee set to kju
  • Target version set to Next release

Updated by Xenomorph almost 6 years ago

I see this issue has been resolved. What was the problem?
You might also want to share it with the guys that made the RAH-66 model(http://www.armaholic.com/page.php?id=7132), since it's suffering from a similar problem.

Updated by zGuba almost 6 years ago

It's all about accuracy value. Should be as low as base class that inherits from Helicopter class (i.e. Mi24_Base, AH1_Base)

Updated by zGuba almost 6 years ago

  • Status changed from Resolved to Closed

Updated by kju almost 6 years ago

  • Target version changed from Next release to 2009-09-05

Also available in: Atom PDF