Task #32203

Sniper Tripod

Added by Gunner almost 3 years ago. Updated almost 2 years ago.

Status:Closed Start date:05/31/2012
Priority:Normal Due date:
Assignee:rocko % Done:

100%

Category:-
Target version:1.14
Component: Affected Version:
Close Reason:

Description

Rather then trying to look through grass all day long, often leaving yourself exposed in open ground or getting tunnel vision because the best you can do is move forward and push some grass down while prone why not have a sniper tripod?

It should be adjustable too so that it can be fitted at crouched height and standing height for more flexability.

It would work simply as alot of the deployable items now, carry it as an item on your back or in your kit(depending on weight and size obviously), deploy the tripod down with CSW. Instead of 'attaching' a weapon to it, you simply rest the weapon on top, so that it becomes a universal weapon platform so that not only Snipers but Marksmen and possibly LMGs can use it freely and without the added exposure and having to deploy tripod, attach a weapon, get on, get off, remove weapon, pick up tripod. This way if in a bind you can abandon the tripod and simply run to cover with weapon rather then becoming combat ineffective.

CSW would be used to adjusted the height levels.

Appicable in both Urban and Open terrain.

Deployed Crouched Height:
http://i.imgur.com/KuURr.jpg

Deployed Standing Height:
http://i.imgur.com/OfEHj.jpg

tripod.3DS (53.9 kB) styl1sh, 07/11/2012 22:58

Associated revisions

Revision 4c95772e
Added by rocko over 2 years ago

~ADDED: Sniper tripod kit (tripod can be adjusted in height to support kneeling and standing firing positions), [model by styl1sh], fixes #32203

History

Updated by rocko almost 3 years ago

  • Target version set to Planned (Needs Contributors)

Updated by ScarecrowisNOTamused. almost 3 years ago

An alternative to the crouched tripod would be a 'sitting' animation which would provide accuracy just slightly worse than prone but vastly improved over the 'crouched' position

Two options for the animation:
http://row.wikispaces.com/file/view/1133204291_334274af7c.jpg/126779173/1133204291_334274af7c.jpg
http://i.imgur.com/ATyUv.jpg

Or just increasing the accuracy of being crouched...

Updated by MagicStuffUser almost 3 years ago

  • Category set to Model

Snipers Tripod or low turnable animations be good :)!

I will try to make some test anim for this...

Updated by MagicStuffUser almost 3 years ago

  • Category deleted (Model)

Updated by MagicStuffUser over 2 years ago

Sitting Animation or Tripod model?!

Updated by ThePredator over 2 years ago

I support the idea of tripods, but these are not suited for machine guns. The tripods are mainly common camera tripods. After they have been adopted some companies started production of such tripods for snipers more durable, but they are not meant to be used by machineguns. Maybe the bipod height can be adjusted, too. I like the thought of having another tool to stabilize the rifle, but the first thing any shooter would do is adjust the bipod to be able to look over the grass.

I also support the idea of more shooting stances, like using trees, slings, the body or improvised tripods. Diversified shooting positions (hand below the rifle butt, using the knee or arm for support et cetera might also enhance the overall experience not just for snipers.

Updated by MagicStuffUser over 2 years ago

Please post here more links or pics of siting animations, and we can select one optimal variant

Question: How this animation must works? Only for soldier who have sniper rifle or for all rifles and types of soldiers?! :)

Note: I think tripod will be more difficult to realise in scripts, or my means is wrong, ACE devs, ask us please, how be better for you?

Updated by ThePredator over 2 years ago

I tried to find pictures that are close to text the book sitting supported firing position.

I could take pictures, but no one wants to see me. So these have to make due.

Basically, the rifle is supported by the knee or by the arm on the knee or the elbow in front(!) of the knee (bone on bone contact for most stable position).

What is apparent: most rifles used in this position are .308 Win, .300 Win. Mag. or .338 LM. It is rather difficult to do a follow up, the recoil is absorbed in a rotating fashion of the body. Or maybe it is just me nearly rolling backwards with a .308 Win in a "knee front" position. A kneeling position is better suited for larger calibers.

different angle

with tripod

alternative (higher stance)

foto/v00024.jpg!

Updated by rocko over 2 years ago

  • Tracker changed from Feature to Task

Updated by rocko over 2 years ago

  • Target version changed from Planned (Needs Contributors) to Model requests

Model, anyone

Updated by styl1sh over 2 years ago

  • File stojak.3DS added

Model is ready. Needs textures and scaling, but it's pretty tits. Kinda nice for a first time model :)

Updated by styl1sh over 2 years ago

I didn't weld the objects together, this one's a complete object

Updated by styl1sh over 2 years ago

  • File deleted (stojak.3DS)

Updated by MagicStuffUser over 2 years ago

styl1sh, good try :)
Animations in progress! :)

2Devs: with config, or just RTM files?!

@styl1sh: Email me please, and we can merge our work for more better results :)!

Updated by MagicStuffUser over 2 years ago

Requesting more pictures and blueprints of tripods, or post names(with links) of tripod models here please - propose variants

Updated by MagicStuffUser over 2 years ago

Thank you ThePredator, good!

Now devs must ask to us if it possible to be realized, and which model be good for everybody?!

Possible to make 2-3(or float) or more height levels - for medium, lower and for position of lying(if think its needed) stance positions?

What we must do to make it works in scripts:
- player can change height of tripod (float height), or here need 2-3 models with different heights (what tis heights must be)?
- how player attach weapon on this tripod?

2ThePredator: we need a view references (left, right, top, bottom, front, back) of confirmed model, and DIMENSIONS! :)

Updated by ThePredator over 2 years ago

I think a higher prone, a sitting, crouching and standing height would be good.

I have a small Slik tripod (same brand, different model the one shown with the cradle). It's a common camera tripod for a slightly higher prone position. Might be a good idea to add different bipod heights for prone and use tripods for sitting, crouching and standing supported firing.

Here some dimensions for the three sizes:

small tripod:
weight: 2.2 ounces w/ cradle
folded: 7.75”
minimum: 6.5"
maximum: 9"

medium tripod:
w: 1.79 lbs w/ cradle
f: 13.8"
min: 5.9"
max: 42.9"

large tripod:
w: 2.07 lbs w/ cradle
f: 18.5”
min: 6.7”
max: 63.6"

These are made by a member of aforementioned forum. I could ask him for pictures if there are not enough in his gallery http://www.precisionriflesolutions.com/apps/photos/album?albumid=7097487

For the Ashbury, I got the dimensions off their page, could ask for pictures, there are some folks who own them.

http://www.ashburyprecisionordnance.com/tact3-tactical-tripods/

Updated by rocko over 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Updated by rocko over 2 years ago

  • Assignee set to rocko
  • Target version changed from Model requests to 1.14

Added the tripod model from styl1sh.

Tripod can be adjusted in height to support kneeling and standig firing positions.

Simply use weaponrest on the tripod.

Can also be carried to change positions quickly.

I am not sure for prone positions, most rifles have a bipod to rest the weapon on - or you can take a sandbag, from the genius sys_sandbag - or rest the weapon on a backpack (if dropped)

Animations are not an option so far.

Updated by MagicStuffUser over 2 years ago

Great Rocko, but i think not fully finished :)

Extension: if height be changed, soldier animation must be switched too :)

Anims WIP, making as on screenshots...

for lower pos maby use anim as in static KORD gun

I am not sure for prone positions, most rifles have a bipod to rest the weapon on - or you can take a sandbag, from the genius sys_sandbag - or rest the weapon on a backpack (if dropped)

I tihnk we together with Styl1sh, rework model in more better variant, and prone be avaliable!
CZ, MK14, svd, Vintorez, and some other rifles dont have bipod, but wold be good to have it

Updated by styl1sh over 2 years ago

Prone model would need to be different, like the one in Predator's photo. Do we need one though? Most of sniper rifles have bipods.

Updated by MagicStuffUser over 2 years ago

Shure! Please dont watch on snipers with bipods, current tripod must be universal for all rifles, i think :)

Updated by rocko over 2 years ago

styl1sh wrote:

Prone model would need to be different, like the one in Predator's photo. Do we need one though? Most of sniper rifles have bipods.

No, we don't need a tripod for prone.
Simply use the methods I mentioned in my answer.

Updated by ScarecrowisNOTamused. over 2 years ago

rocko wrote:

Simply use weaponrest on the tripod.

wouldn't that take massive effect on performance with the whole 10,000 buckets trying to find the tripod? are there no other alternatives?

Updated by rocko over 2 years ago

  • Status changed from Resolved to Closed

Available on SU.

Updated by rocko over 2 years ago

ScarecrowisNOTamused. wrote:

rocko wrote:

Simply use weaponrest on the tripod.

wouldn't that take massive effect on performance with the whole 10,000 buckets trying to find the tripod? are there no other alternatives?

So how then would you think it should work? I am not aware that weaponresting has any performance issues.

Updated by MagicStuffUser over 2 years ago

Scarecrow, how been sayd, animations for snipers in progress now, based on pics...

Updated by M1n1d0u over 2 years ago

i make some test and for me the highter position of the tripod is too hight to rest the riffle that's bad i love the idea

Updated by rocko over 2 years ago

Request, issues and more regarding the current sniper tripod goes into a new ticket, please.
This one is closed and is not tracked anymore.

Also please note, the suggestion of animations instead of the tripod got out of hand, IMO. The OP explicitly was suggesting a tripod, not animations.

If you want to suggest animations for a sitting firing position open a new ticket.

As I wrote:

Animations are not an option so far.

Fiddling anims into this retarded animation system, it won't probably happen anytime soon. Given there are animations delivered at all.
Plus a working example how they can be merged into the game.

Updated by ScarecrowisNOTamused. over 2 years ago

rocko wrote:

ScarecrowisNOTamused. wrote:

rocko wrote:

Simply use weaponrest on the tripod.

wouldn't that take massive effect on performance with the whole 10,000 buckets trying to find the tripod? are there no other alternatives?

So how then would you think it should work? I am not aware that weaponresting has any performance issues.

Never mind, i tested it last night and found no issues with permormance, on my old PC i found that weapon resting would drop my FPS to around 5-10 but i see no impact at all, unless someone with a older PC can comment.

Updated by Dystopian over 2 years ago

Smookie Animation Pack Lite version (biforum) contains a great sniper sit animation and seems to be ACE compatible.

Also available in: Atom PDF