Bug #32187

CIM events not triggering

Added by razool almost 3 years ago. Updated over 2 years ago.

Status:Rejected Start date:05/30/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Reproduced by another DH user:Yes
Close Reason: I am using some Mods:Yes
Affected Version:

Description

since the introduction of clientside civs, we have not seen any CIM events taking place

I left a map running for a couple days and we see plenty of civilians in the streets

the server RPT is full of "Server starting new civilian event near player xyz. On civs: []"

in some instances it detects nearby players as civies "Server starting new civilian event near player s12. On civs: [s14,s38,s12]"

also it keeps running when no players are online, "Server starting new civilian event near player <NULL-object>. On civs: []", dunno if that can affect performance in any way

after restarting the mission with serverside civs and nothing else changed, events appear to trigger normally, there was a civilian demonstration right outside the base and the log shows its detecting civies

History

Updated by VRCRaptor almost 3 years ago

  • Target version set to MSO v4.4
  • Reproduced by another DH user changed from No to Yes

have noticed this as well...

Updated by wolffy.au over 2 years ago

Most likely due to ALICE client-side conversion and particular, the ALICE_population variable not being broadcast.

Will need to look at it.

Updated by Tupolov over 2 years ago

  • Target version changed from MSO v4.4 to MSO v4.6

Updated by Tupolov over 2 years ago

  • Status changed from New to Rejected
  • Target version deleted (MSO v4.6)

The CIM addon is broken and attempts to reach the author failed. We will not be supporting CIM in future releases.

Updated by razool over 2 years ago

roger that, it does work sometimes for short periods before the whole system breaks and we can`t even use civ interaction anymore

any chance you guys make your own civilian events module? demonstrations and such can really add to the whole immersion factor

Also available in: Atom PDF