Bug #32112

Infinite number of tents can be created

Added by Crow about 3 years ago. Updated about 3 years ago.

Status:Closed Start date:05/28/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-

Description

Basically I tried to set up a tent while I was in the inventory. I had problems finding a place to put it down so I moved my character forward while clicking on the "place tent" option. When it finally found a place where I could put it. I clicked the option multiple times while setting it up. I looked into my inventory and found a tent in there although I just build one. So I kicked it out of my inventory on the ground. Unfortunately it did not vanish in my inventory so I had to click it mulitple times. When I looked around I found 13 tents on the ground. Guess the bug appears from the clicking while the tent gets set up.

History

Updated by Beginner about 3 years ago

Still duping in 1.7.0.

Updated by rocket about 3 years ago

  • Status changed from New to Resolved

Resolved fixed with 1.7.1.2

Updated by rocket about 3 years ago

Please confirm if possible

Updated by Beginner about 3 years ago

Confirmed. But there is still a bug with multiple placing tents.

Updated by BTK about 3 years ago

There is another problem with tents. I'm posting this here, cause it's kinda related...

Packed tents are only deleted for the current session, not from database, it seems. So if you pack your tent, it will be standing again after server restart + you have the packed tent in your inventory.

Also, tents (sometimes?) multiply after server restarts. I had like 5 tents standing on the same place after a restart.

I think ALL tents should be deleted from database, after this has been fixed, cause the servers are full of tents.

I saw areas with like 20 tents standing around!

Updated by BTK about 3 years ago

All fixed in 1.7.1.5! Good job, thanks!

Updated by rocket about 3 years ago

  • Status changed from Resolved to Closed

Updated by tiuz about 3 years ago

Seems to be buggy again with v1.7.2.4
I created by mistake 4 tents at the same spot. Packed them and threw them away. After Server-Restart they were still there.

Also available in: Atom PDF