Bug #3204

JIP Players are unable to see flags in C&H game mode.

Added by Benjahert about 6 years ago. Updated about 6 years ago.

Status:Closed Start date:07/30/2009
Priority:Normal Due date:
Assignee:sbsmac % Done:

0%

Category:C&H
Target version:-

Description

Players that JIP after the match has begun are unable to see the flag markers on the map. If a player decides to switch team during a match they are also unable to see the markers on the map.

Meathod Of Reproduction:
1) Host server running C&H game mode.
2) Select one side.
3) Abort select other side. Notice that flag markers are not present on the map.

DGA_C_H_Chernogorsk_v4.Chernarus.pbo (3.2 MB) Benjahert, 07/30/2009 22:23

History

Updated by sbsmac about 6 years ago

Thanks, good report. Will take a look at this as a priority.

Updated by sbsmac about 6 years ago

Fixed. The problem was caused by marker state not being transferred to JIP clients. Added some code to refresh the markers every time a player joins.

Updated by sbsmac about 6 years ago

  • Status changed from New to Closed

Also available in: Atom PDF