Bug #31555

RPK74 75 rnd Mags only have 45 rounds.

Added by ekempey about 3 years ago. Updated almost 3 years ago.

Status:Rejected Start date:05/19/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Config
Target version:-
Component: Affected Version:1.13
Close Reason:By design/Not a Bug

Description

Classes:
ACE_75Rnd_545x39_S_RPK
ACE_75Rnd_545x39_T_RPK

Both display using the 45 round clip in a units magazine. Both only hold 45 rounds.

Repo:
Place unit on map, add ACE_RPK74M, plus one each of the above class names to its gear.

History

Updated by zGuba about 3 years ago

  • Status changed from New to Rejected
  • Close Reason set to By design/Not a Bug

IRL there are no 75Rnd magazines for RPK-74.

Updated by kOepi about 3 years ago

that is correct, though RPK has 75 round magazines

Updated by cyrilator about 3 years ago

kOepi wrote:

though RPK has 75 round magazines

RPK (7.62x39mm) and RPK74 (5.45x39mm) are two differents rifles.

RPK can use 75 rds drums mags.

RPK74 only use 30/45rds magasines.

the RPK74 mags classes should simply be renamed :

ACE_45Rnd_545x39_S_RPK74
ACE_45Rnd_545x39_T_RPK74

Updated by zGuba almost 3 years ago

That is so, and original magazine classes are kept for compatibility reasons.

Also available in: Atom PDF