Bug #3116

Character animation jerkiness after vehicle exit (some vehicles)

Added by flake_ almost 6 years ago. Updated almost 5 years ago.

Status:Closed Start date:07/27/2009
Priority:High Due date:
Assignee:- % Done:

0%

Category:Animations
Target version:1.07.71750
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

when characters exit some vehicles their animations are very low quality.

Try the test mission.

Three vehicles will drive toward you and the occupants will exit the vehicles.

Don't walk around, just use zoom to watch the three vehicles approach and the men exit them. when the guys exit the vehicles only the guys on the left animate fluidly. The bus and car guys on the right have jerky animations. When they all eventually walk closer they will all animate fluidly.
If you turn your view to the left and back again, all jerkyness stops.

This also happens when characters exit boats.

http://dev-heaven.net/attachments/3070/animtest.Chernarus.pbo

test.utes.pbo (10.7 kB) flake_, 07/27/2009 04:17


Related issues

related to ARMA2 Community Issue Tracker - Bug #1915: AI warping - especially at distance. Closed 06/08/2009
duplicated by ARMA2 Community Issue Tracker - Bug #1686: Beaming of Units in Singleplayer Duplicate 05/31/2009 08/30/2009
duplicated by ARMA2 Community Issue Tracker - Bug #4073: Animations lost at distance Duplicate 08/27/2009
duplicated by ARMA2 Community Issue Tracker - Bug #5640: Wrong animations after a unit disembarks, beta patch 59928 Duplicate 11/03/2009
duplicated by ARMA2 Community Issue Tracker - Bug #9937: Unit animations after they dismount from vehicle is laggy Duplicate 04/04/2010

History

Updated by zGuba almost 6 years ago

  • Category changed from Visual to Animations

Updated by flake_ almost 6 years ago

Still "New" ? Posted it 3 weeks ago lol

Updated by zGuba almost 6 years ago

  • Status changed from New to Duplicate

#3960 seems to contain the same, but is more fresh.

Updated by flake_ over 5 years ago

there is absolutely no relation whatsoever in any way shape or form. please point out where "#3960 seems to contain the same". its simply doesnt contain the same of anything. are you nuts?

Updated by kju over 5 years ago

  • Status changed from Duplicate to Assigned

Did you test with latest beta patch by chance?

Updated by nomdeplume over 5 years ago

Confirmed with latest beta, build 58879. Seems to be related to your distance from the action.

I've noticed this a fair bit with troops debarking from the Venom helo (mostly because a mission I'm working on has troops departing from that particular aircraft). I've also noticed it with units getting out of an APC that's also in the mission. Previously I thought it was related to the dust cloud effect, although there's no dust cloud visible for the car in this test mission.

Here's a video of my playthrough:

http://www.youtube.com/watch?v=DPCBOJKvq4I

At 58 seconds in it jumps to another session where I moved close to the vehicles - this is just to show the animation is only jerky when you're a distance from the units involved. I also ran backwards as the troops were departing the APC until the issue appeared again.

Some kind of optimisation of movement updates that's gone awry?

Addendum: Win7 x64, 6GB, GTX 295, 190.38, build 58879.

Updated by Fireball over 5 years ago

  • Due date set to 10/27/2009
  • Affected ArmA II version changed from 1.02.58134 to 1.04 BETA

Updated by Fireball over 5 years ago

  • Due date changed from 10/27/2009 to 11/27/2009
  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026
  • Reproduced by another DH user set to No
  • CPU set to Please specify!

Updated by Fireball over 5 years ago

  • Reproduced by another DH user changed from No to Yes

Updated by zGuba over 5 years ago

flake_ wrote:

there is absolutely no relation whatsoever in any way shape or form. please point out where "#3960 seems to contain the same". its simply doesnt contain the same of anything. are you nuts?

I ment #1915. Copy-Paste bug.

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Alex72 over 5 years ago

I noticed this happening when spawning units as well. Tested this just an hour ago and spawned units (SP) popping out just around 50-100 meters get the "jerky" animations. I saw that this might be adressed in OA (and hopefully ARMA2 when they find the problem).

But i just wanted to add this info that it isnt only when units exit vehicles.

Updated by Dwarden over 5 years ago

  • Priority changed from Normal to High

Updated by MulleDK19 over 5 years ago

It's not a bug.

The jerky animation occurs at distances to reduce performance issues.

Raise the video settings and buy better hardware.

Updated by Fireball over 5 years ago

MulleDK19 wrote:

It's not a bug.

The jerky animation occurs at distances to reduce performance issues.

Raise the video settings and buy better hardware.

So Mr. Know-It-All, explain to me then why it does only happen on some AIs (or better: exiting from some vehicles) and on some not and consistently over all types of hardware?? And when I look at nondeplumes hardware, compared with mine, then this shouldn't happen on such gear.

Updated by kju over 5 years ago

  • Due date changed from 11/27/2009 to 03/04/2010

Updated by Suma about 5 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Upcoming version

Fixed in build 70793

Updated by kju about 5 years ago

  • Due date changed from 03/04/2010 to 06/25/2010
  • Target version changed from Upcoming version to 1.06 BETA
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Updated by kju almost 5 years ago

  • Assignee deleted (Dwarden)

Can anyone confirm this fixed?

Updated by Fireball almost 5 years ago

  • Due date deleted (06/25/2010)
  • Status changed from Resolved to Closed

Confirming fixed with 71213.

Updated by kju almost 5 years ago

  • Target version changed from 1.06 BETA to 1.07.71750
  • Audio card set to Please specify!

Also available in: Atom PDF