Bug #3081

Mouse latency

Added by Tophe almost 6 years ago. Updated over 5 years ago.

Status:Closed Start date:07/25/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Controls
Target version:1.05.62017
Affected ArmA II version:1.05 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

There are some serious problems with mouse lag.
Many high end machines get mouse latency. Arma2 will respond extremely slow to mouse movement.
It's a huge drawback on the gameplay.

Here's a good video of the problem: http://www.youtube.com/watch?v=xryLypk7I9c

mouse_lag_test.Chernarus.rar (603 Bytes) aikakana, 09/07/2009 20:59


Related issues

related to ARMA2 Community Issue Tracker - Bug #2376: Mouse Lag, Mouse Acceleration on/off option Duplicate 06/29/2009 12/30/2009

History

Updated by alef almost 6 years ago

  • Priority changed from Urgent to Normal

Updated by mr.g-c almost 6 years ago

The best proof for me visible was at Placebos (grimbarian) Youtube Video (link: http://www.youtube.com/watch?v=fJsFSrg5d0A&feature=response_watch) in which he actually wanted to show that there is no Lag, however he made it private sadly.
Fact is that since Arma1 the controls/mouse-input got laggy, in OFP1 they were fluid and perfectly fast responding like in a quick FPS shooter like Counterstrike or else.
While we Arma1 Veterans are all got used to the lag, the new People instantly recognized it and leading now this campaign through the BI-Forums.
I would also love it if it would responding as quick as it was with OFP1, this adds to the overall feeling i believe.

Hint: The lagginess is bind to your overall Frames per Second, so once you got below 25-30FPS it gets really worse. On the other Hand close to 50-60FPS its "almost" not noicable. I hope this gives a hint to Suma or else.

Updated by Leopardi almost 6 years ago

Another hint: Setting Visibility to max. reduces lagginess noticeably as well. It's tied to FPS also because the lagginess might be caused by mouse smoothing.

Updated by Tophe almost 6 years ago

Leopardi wrote:

Another hint: Setting Visibility to max. reduces lagginess noticeably as well. It's tied to FPS also because the lagginess might be caused by mouse smoothing.

I don't believe it has anything to do with FPS.
Actually, when I played on my old computer a AMD6000+ at 18-20 FPS I had almost no lag.
Now I'm on a Intel Q9550 playing at 30-35 FPS and the mouse lag is absolutely unbearable.

This is a bug, nothing else.

Updated by Tophe almost 6 years ago

It would be interesting to know if BIS is aware of the problem.
An awful lot of people on the forums have this problem and many have actually stopped playing the game, returned it or decided not to buy it because of this bug.

Seeing the various systems this bug appears on it's clear that it has nothing to do with hardware perfomance.
As mentioned in my previous post I upgraded to a system that at points are giving the double FPS from my old system.
The old system worked fine (except that the game performed really bad), now the game performs rather well but the mouse latency makes in unplayable.

For me it completely killed the game and made it absolutely unplayable. You can't hit anything anymore.
Now I'll have to wait for them to fix it to be able to play the game at all.

Updated by zGuba almost 6 years ago

I'm having 15 FPS on 1680x1050/100%/textures, models low, video ram high, shaders high with Athlon X2 2 GHz, 2 GB DDR-800 RAM, Gainward 9800GT 1024MB, Vista x64. No mouse lag at all.

Updated by Squelch almost 6 years ago

  • Target version deleted (1.03.58627)

Updated by zGuba almost 6 years ago

I was wrong. I've got mouse lag too, just not in MP games. It looks like Chernarus is more likely to cause mouse lag than Utes.

Updated by kju almost 6 years ago

  • Due date set to 11/25/2009
  • Status changed from New to Assigned
  • Affected ArmA II version changed from 1.02.58134 to 1.03.58627

Still a prob in 1.03

Updated by aikakana almost 6 years ago

Running Arma2 with only 1 core eliminates this problem totally. Absolute perfect mouse movement.

I have an Intel i7, so by default Arma2 uses 8 "cores". I disabled Hyper Threading from BIOS and while starting Arma2 I changed the affinity to 1 CPU.

Results:
Dramatical FPS drop, but NO lag in the mouse what so ever.

Notes:
Before finding this out, when all maxed out in the video options to achieve a steady 2-3 FPS, I could count 10-15 frames before any of my controls (keyboard & mouse) apply to the game. Could the game engine get old data from the controller polling thing if its running in another thread & core?

Updated by kju almost 6 years ago

  • Status changed from Assigned to Feedback
  • Target version set to 1.04 BETA

The beta patch might at least improve the situation.
Please share your feedback. Also the cpuCount=1 tests result are very important.

[58758] Removed mouse smoothing to reduce mouse lag in some situations.

Updated by kju almost 6 years ago

  • Due date changed from 11/25/2009 to 09/05/2009

Updated by aikakana almost 6 years ago

It seems that mouse movement overall feels better, but the lag is just the same. "cpuCount=1" does not seem to do the same trick as setting affinity to 1 CPU or by disabling cores from bios.

My results:
No difference in lag, even with cpuCount=1

Updated by Fireball almost 6 years ago

  • Due date changed from 09/05/2009 to 09/15/2009
  • Status changed from Feedback to Resolved
  • Difficulty set to Not set

There is now even a mouse smoothing option in the controls menu in the latest beta! Please verify if this is resolved for you with that.

Updated by Tophe almost 6 years ago

It has not resolved the problem... Lowering mouse smoothing does lower the mouse lag, but instead it introduces skipping and stuttering of the mouse movement.
Mouse smoothing completely off gives a mouse movement that is unplayable because of the stuttering... when the slider is moved up until it stops stuttering it is way too laggy.

It's better than before, much better... but not resolved. There ought to be some other way to get to the mouse lag than removing all the smoothing.

Updated by aikakana almost 6 years ago

This is not resolved.

Removing mouse filtering helps with aiming, because you are in control of the crosshair and not the game, but still with FPS under 40 it's horrible.

I like to run the game with 1 core only (with HT turned off too), because that eliminates the problem COMPLETELY.

This was posted on the forums: http://www.southwindsgames.com/blog/2009/01/15/mouse-lag-keyboard-lag-direct3d-lag/

D3D buffers filling up and therefore frames are being drawn out of sync with the game engine. Could this be the case? Some people have resolved this by putting the visibility distance to the max.

So, might it be that when CPU stress is below 100% the game engine can provide data to D3D faster than the graphics card can handle -> buffers fill up -> lag.

When testing with the initial version (with mouse filtering ON) I had visibility distance in about 2500, 4 cores + 4 with HT, game running at 50-150 FPS, there was a weird spot at one airport at Chernarus where I could get 1-5 FPS when looking trough a scope. The map was empty, no AI players, no nothing but me standing there, the lag was about 10-15 frames. There could not have been much CPU stress, because there was nothing to process. For some reason that spot was very heavy on the GPU I guess.

(the information in the older post, where I said that I had all video options maxed out was not how it really was, I did not remember correctly how the case was. This looking trough a sniper scope at the airport is what I was describing earlier too.)

Sorry for the long posting, but I hope you can get some new information here.

Updated by Fireball almost 6 years ago

  • Status changed from Resolved to Assigned
  • Affected ArmA II version changed from 1.03.58627 to 1.04 BETA

Looks like this is related to certain hardware.

Updated by Dwarden almost 6 years ago

aikakana wrote:

This is not resolved.

Removing mouse filtering helps with aiming, because you are in control of the crosshair and not the game, but still with FPS under 40 it's horrible.

I like to run the game with 1 core only (with HT turned off too), because that eliminates the problem COMPLETELY.

This was posted on the forums: http://www.southwindsgames.com/blog/2009/01/15/mouse-lag-keyboard-lag-direct3d-lag/

D3D buffers filling up and therefore frames are being drawn out of sync with the game engine. Could this be the case? Some people have resolved this by putting the visibility distance to the max.

So, might it be that when CPU stress is below 100% the game engine can provide data to D3D faster than the graphics card can handle -> buffers fill up -> lag.

When testing with the initial version (with mouse filtering ON) I had visibility distance in about 2500, 4 cores + 4 with HT, game running at 50-150 FPS, there was a weird spot at one airport at Chernarus where I could get 1-5 FPS when looking trough a scope. The map was empty, no AI players, no nothing but me standing there, the lag was about 10-15 frames. There could not have been much CPU stress, because there was nothing to process. For some reason that spot was very heavy on the GPU I guess.

(the information in the older post, where I said that I had all video options maxed out was not how it really was, I did not remember correctly how the case was. This looking trough a sniper scope at the airport is what I was describing earlier too.)

Sorry for the long posting, but I hope you can get some new information here.

please provide repro spot for the FPS drops issues (ideally sample mission)

Updated by Dwarden almost 6 years ago

  • Assignee set to Dwarden

Updated by Fireball almost 6 years ago

Could everyone affected state what hardware and/or driver you're using? Processor? Motherboard? Any USB hubs? Special mice?

Updated by aikakana almost 6 years ago

For now, I could not 100% reproduce the same weird spot with very low FPS, but anyways, the same airport seems to be a good place to reproduce this anyways.

My setup in this test:
- Intel Core i7 920 default clocks, HT enabled, 4 cores
- MSI EX58-UD3R Motherboard
- Radeon HD4890 1GB
default clocks
- 6GB DDR3 triple channel
- Windows 7 Ultimate (RTM, from MSDN)
- default windows mouse drivers (a dell USB mouse)
- no other USB devices
- no other PCI devices but graphics card
- ATI Catalyst graphics drivers, version 8.632.0.0, date: 2.7.2009 (when I first tested Arma2, I had older drivers but the problem was the same)
- PS2 keyboard
- 2 monitors
- one DVD drive (IDE)
- one 1TB samsung F1 Spinpoint HDD (Sata)
- everything turned Very High in the video options. Resolution: 1440x900. Visibility 2500

I noticed a few more things:
- when shooting, the sound has NO lag, but graphics comes a half a second later
- the mouse lag can be seen also in in-game menu (press ESC > menu). Menuitems respond to mouse-over or mouse-click with the same lag as in the game, but actual cursor moves without lag
vegetation seems to be the major FPS dropper with my setup
- it didn't help to put 100 AI controlled players (to increase CPU stress)

In the attached file is a mission where you start from the airport where I previously had the worst issues. The position and the looking angle is good for reproducing the lag, but if you go down (see only vegetation) and look trough the scope, FPS drops really low and mouse lags 0,5 - almost 1 second.

I guess this will not help you much, because I didn't find the exact spot where I got the 1-5FPS with my default gaming video settings.

Do you need more information of my computer?

EDIT: updated computer specs

Updated by kju almost 6 years ago

Thanks a lot for the information aikakana!

Updated by Fireball almost 6 years ago

aikakana wrote:

In the attached file is a mission where you start from the airport where I previously had the worst issues. The position and the looking angle is good for reproducing the lag, but if you go down (see only vegetation) and look trough the scope, FPS drops really low and mouse lags 0,5 - almost 1 second.

Actually I can see what you mean now. It only happens when looking through the scope and panning over the bushes in front of the hangars - if you compare to un-scoped then you can best see the difference. I never bothered about that; I always thought it was helpful for aiming (somehow).

One must add that this behaviour does not change with reducing mouse filtering to zero.

Updated by Fireball almost 6 years ago

  • Due date changed from 09/15/2009 to 10/15/2009

Updated by kju almost 6 years ago

  • Target version changed from 1.04 BETA to 1.04.59026

Updated by kju almost 6 years ago

  • Target version deleted (1.04.59026)
  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Updated by Dwarden over 5 years ago

  • Status changed from Assigned to Closed
  • Priority changed from Normal to Low
  • Reproduced by another DH user set to No

most should be fixed

Updated by kju over 5 years ago

  • Assignee changed from Dwarden to kju
  • CPU set to Please specify!

Updated by Fireball over 5 years ago

I think I can see what others mean in the forum, that removing the mouse filtering causes the motion to become jittering. This is partictularly because A2 was never designed to have precise by weight-of-gear-uninfluenced movement such as experienced e.g. in CS:S.

But I guess it should be not so much influenced if you do small movements, while having the weapon pressed to your shoulders and do body movements mostly - opposed to arm movements.

Updated by aikakana over 5 years ago

This is still not resolved, atleast on my computer.

First I put GPU_MaxFramesAhead=0; to Arma2.cfg and the result was:
GPU_MaxFramesAhead=1000;
GPU_DetectedFramesAhead=3;

The lag was way more than 3 frames. About 10 I think.

Then I wrote GPU_MaxFramesAhead=1; and result was:
GPU_MaxFramesAhead=1;
GPU_DetectedFramesAhead=1;

.. with just the same lag :(

Could it be that my graphics drivers are not doing what you tell them to?

Edit: mouse filtering is set to zero

Updated by kju over 5 years ago

What mouse smoothing did you set ingame in control options?

Did you use the right arma2.cfg for sure?
So what was the location and whats your startup line (params).

Updated by aikakana over 5 years ago

I set mouse smoothing to minimum (left) and used Arma2 from "My Documents/Arma 2/". Startup parameters are default from the latest beta patch "-mod=beta -nosplash".

Updated by kju over 5 years ago

  • Due date changed from 10/15/2009 to 03/02/2010
  • Status changed from Closed to Feedback
  • Assignee deleted (kju)
  • Priority changed from Low to Normal
  • Affected ArmA II version changed from 1.04.59026 to 1.05 BETA

Updated by kju over 5 years ago

Sorry missed your response aikakana.
Any change for you or did you give up. :|

Updated by aikakana over 5 years ago

I gave up after I had tried everything that came to my mind. I will probably give it a new shot some day, reinstall all drivers and Arma2 too. I don't like playing with low fps or with high fps & bad lag :/

I hope there is still something I missed about the things that helps with the lag. I assume almost everyone else has the problems fixed, so it might be just something special that I have.

Updated by kju over 5 years ago

Well a friend of mine seems to have the same problem.
We will try to get as much information from him as we can. :)

Updated by aikakana over 5 years ago

Any updates?

Updated by kju over 5 years ago

Dunno. Have not heard anyone else that still has the problem. :(
Did you try to create a new profile? Reinstall the game?
Different OS?

Updated by Tophe over 5 years ago

I still have the problem. The smoothing option lets me choose between choppy or latency.
I've now tried it on two computers and on Windows 7 as well as Windows XP, same problem.
It doesn't matter what 3D-settings my nvidia card is on. I've tried all known tweaks and at least 10 different drivers.

This must be some kind of low level programming problem. I have never had this problem with any other game on any system.

Updated by Fireball over 5 years ago

The answer lies in my comment http://dev-heaven.net/issues/3081#note-29.

This case is closed from the part of BI (I'm pretty sure).

Updated by aikakana over 5 years ago

I have tried everything. Still the same lag in the mouse both in-game and in the menus.

Tried creating new profile as you said, but it didn't make any difference what so ever. How did you fix the problem on your friends computer kju?

Updated by kju over 5 years ago

Dunno. He stopped complaining shortly after.

Updated by Fireball over 5 years ago

aikakana wrote:

I have tried everything. Still the same lag in the mouse both in-game and in the menus.

Tried creating new profile as you said, but it didn't make any difference what so ever. How did you fix the problem on your friends computer kju?

Ah, you also got lag in the menus? Sounds like a pre-rendered frames issue, but before you ask here anymore, you are a case for the support and troubleshooting BI forums.

Updated by aikakana over 5 years ago

Fireball wrote:

aikakana wrote:

I have tried everything. Still the same lag in the mouse both in-game and in the menus.

Tried creating new profile as you said, but it didn't make any difference what so ever. How did you fix the problem on your friends computer kju?

Ah, you also got lag in the menus? Sounds like a pre-rendered frames issue, but before you ask here anymore, you are a case for the support and troubleshooting BI forums.

I will not ask how and where to do anything, but I can say that I have modified the Arma2.cfg file, as told at BI forums, to not prerender frames and changed my gfx driver settings to not render frames ahead. I will put this issue to rest and wait till I buy new hardware. Thanks for your efforts!

Updated by kju over 5 years ago

  • Due date deleted (03/02/2010)
  • Status changed from Feedback to Closed
  • Target version set to 1.05.62017

cheers!

Also available in: Atom PDF