Bug #30720

Local channel text & voip

Added by Burgerlolzz over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:04/27/2012
Priority:Normal Due date:
Assignee:- % Done:


Target version:-


Local channel text & voip gets broken if you use any other channel. (Doesn't matter if you write or speak, it'll break Local chat, only fix is to kill arma2oa.exe and restart the game.


Updated by ArthurA over 3 years ago

Oh I didn't know that will break the DC. Anyway DC must be fixed asap. It is essential to the PvP gameplay.
I think it worked last in .11 or .9 just well or it might have been 1.3.

Updated by tcp over 3 years ago

Possible related error, AI name varies (when someone tries talking in direct?):

No speaker given for Dobromil Nedbal

Updated by mossarelli over 3 years ago

Priority should be changed to HIGHEST as this totally breaks the game, and a player will think other player's are bullying him.
As said, cannot talk even if rejoin the server, must shutdown the .exe.

Consider moving to ACRE when you have time.

Updated by ArthurA over 3 years ago

I agree, this must be fixed asap. The lack of communication is creating a lot of unnecessary PKing.
No need for ACRE if DC is fixed. In other Arma2 mods like PR, DC works really well.

Imo the OP description is not accurate, at least in my experience. It doesn't matter if u change channels or not. The DC either works, or it doesn't, sometimes even in the same server after a reconnect/server restart. No matter what method u use to talk with it, or do you change channels or whatnot.
Sometimes u can hear syllable from DC but it is still useless and iirc even in that case the DC text chat doesn't work. Sometimes the avatars mouth moves, and sometimes it doesn't when trying to use DC, iirc.

And when u finally find a server where it works, u can change channels and whatnot and it will work, unless the server is about to crash and then the DC might stop working, but in that case u have to reconnect anyways.

Damn hard to create a repro for this. Perhaps do some locked server testing to see if and when DC works and how many are affected in the server.

Updated by tarciop over 3 years ago

maybe related to SelectPlayer (see ticket #30991 )

Updated by ArthurA over 3 years ago

I have had instances where the DC voice works but not the text DC. I think the voice DC is perm. fixed atm. It has worked since the OA beta 93040 iirc. And this DC chat not working was with the latest beta and 1.7.0. Has anyone had similar experiences?

Updated by rocket over 3 years ago

  • Status changed from New to Closed

Confirmed fixed with

Also available in: Atom PDF