Bug #3066

MoveObject File/Folder replacementList no longer works. Only first item is processed.

Added by kju over 5 years ago. Updated over 5 years ago.

Status:Rejected Start date:07/25/2009
Priority:Low Due date:
Assignee:mikero % Done:

0%

Category:MoveObject (Dos Tools)
Target version:Completed
Affected Version:

Description

Replacement list:

"ca\air\data\car_light_flare2" "caa1\ca\air\data\car_light_flare2" 
"ca\air\data\materialy\env_co" "caa1\ca\air\data\materialy\env_co" 
"ca\air\data\m134_co" "caa1\ca\air\data\m134_co" 
"ca\air\data\m134_ns" "caa1\ca\air\data\m134_ns" 
"ca\air\data\uh60_2_co" "caa1\ca\air\data\uh60_2_co" 
"ca\air\data\uh60_3_co" "caa1\ca\air\data\uh60_3_co" 

App call:

T:\pbodll>MoveObject.exe P:\x\CAA1\addons\p_Models_DBE1\ T:\tools\repathObjectsInWrp\ReplacePathAwithB_QG.txt

T:\pbodll>MoveObject.exe P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d T:\tools\repathObjectsInWrp\ReplacePathAwithB_QG.txt

Log:

T:\pbodll>MoveObject.exe P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d T:\tools\repathObjectsInWrp\ReplacePathAwithB_QG.txt
MoveObject.exe Version 1.67, Dll Version 2.24
=================
P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d
ODOL40 (arma) nLods=24
Hunting ca\air\data\car_light_flare2.....
0 replacements
Creating output
No Error(s)
Checking output.....
ODOL40 (arma) nLods=24

No Error(s)

T:\pbodll>MoveObject.exe P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d T:\tools\repathObjectsInWrp\ReplacePathAwithB_QG.txt
MoveObject.exe Version 1.67, Dll Version 2.24
=================
P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d
ODOL40 (arma) nLods=24
Hunting ca\air\data\m134_co.....
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
Replacing ca\air\data\m134_co with caa1\ca\air\data\m134_co.paa
10 replacements
Creating output
No Error(s)
Checking output.....
ODOL40 (arma) nLods=24

No Error(s)

T:\pbodll>MoveObject.exe P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60.p3d T:\tools\repathObjectsInWrp\ReplacePathAwithB_QG.txt
MoveObject.exe Version 1.67, Dll Version 2.24
=================
P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60.p3d
ODOL40 (arma) nLods=22
Hunting ca\air\data\m134_ns.....
0 replacements
Creating output
No Error(s)
Checking output.....
ODOL40 (arma) nLods=22

No Error(s)

T:\pbodll>MoveObject.exe P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d T:\tools\repathObjectsInWrp\ReplacePathAwithB_QG.txt
MoveObject.exe Version 1.67, Dll Version 2.24
=================
P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d
ODOL40 (arma) nLods=24
Hunting ca\air\data\m134_ns.....
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
Replacing ca\air\data\m134_ns with caa1\ca\air\data\m134_ns.paa
10 replacements
Creating output
No Error(s)
Checking output.....
ODOL40 (arma) nLods=24

No Error(s)

T:\pbodll>MoveObject.exe P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d T:\tools\repathObjectsInWrp\ReplacePathAwithB_QG.txt
MoveObject.exe Version 1.67, Dll Version 2.24
=================
P:\x\CAA1\addons\p_Models_DBE1\UH60Desert\uh_60mg.p3d
ODOL40 (arma) nLods=24
Hunting ca\air\data\materialy\env_co.....
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
Replacing ca\air\data\materialy\env_co with caa1\ca\air\data\materialy\env_co.paa
9 replacements
Creating output
No Error(s)
Checking output.....
ODOL40 (arma) nLods=24

No Error(s)

History

Updated by kju over 5 years ago

PS: The lower entries from the log have their order rotated manually to get them processed.

Updated by kju over 5 years ago

  • Status changed from New to Assigned

Updated by mikero over 5 years ago

the latest dll is 2.25 which does not explain THIS error, but certainly explains similar ticket (p3d corruption)

i cannot find a problem using a replacement.lst here.

Updated by kju over 5 years ago

  • Status changed from Assigned to Feedback

Issue solved. File do not have windows CR LF.

Mikero is it possible to check for the mistake please?

Updated by kju over 5 years ago

  • Priority changed from High to Low

Updated by mikero over 5 years ago

  • Status changed from Feedback to Resolved
  • Target version set to Completed

the 'fault' is caused by lack of linefeed characters so that the entire file will be read as a single line, and thus only the 1st two tokens processed.

next revision of moveobject (1.70) will check that linefeeds are in the replacement text

Updated by mikero over 5 years ago

  • Status changed from Resolved to Rejected

Also available in: Atom PDF