Feature #30632

Fragmentation System

Added by Nou almost 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:04/23/2012
Priority:Normal Due date:
Assignee:Nou % Done:

100%

Category:-
Target version:-
Component: Affected Version:
Close Reason:

Description

Implement a system that automatically creates a network efficient fragmentation effect to explosives that meet certain criteria for the effect.

I worked on a fragmentation system last week that adds in the ability to be hit by far reaching fragmentation bits. Its based off a number of factors (indirect hit values/ranges, size of objects around explosion, etc) and creates individual fragmentation effects for people and vehicles around an explosion that is relatively efficient network wise in multiplayer.

This is a critical aspect of game play that has been ignored since the series started. Explosive effects in real life extend beyond heat and pressure and out a much further distance by the throwing of metal fragments. This makes explosions often dangerous to be around sometimes hundreds of meters away as the there is a chance that you might be hit with fragmentation.

I plan to implement this system in a way that automatically adds the effects to any ammo fired that meets certain criteria for the effects (based on indirect hit ranges/values) or being forced on the ammo by config. The system can be enabled or disabled on a per-server or per-mission base. I would like to have this system enabled by default.

A video of this system can be viewed here: http://www.youtube.com/watch?v=ZzvY-EHftWQ

History

Updated by Xeno almost 3 years ago

Does this work for (server) AI too ?

Updated by Nou almost 3 years ago

Does it target AI you mean? Yes. Does it work for AI shooting explosive weapons? Yes, but the accuracy of the fragmentation's point of origin might be off a bit due to script lag in some situations (client fired ammo is tracked in a PFH, but the server has to use a normal scheduled loop).

Updated by Xeno almost 3 years ago

Hm, makes me wonder when we finally get this:
https://dev-heaven.net/issues/24926

Updated by rocko almost 3 years ago

go go

Updated by Nou almost 3 years ago

  • % Done changed from 30 to 60

Yep, should have something to commit tonight. Needs a bit of testing as far as making sure there are no weird situations where we delete certain ammunition and replace it that doesn't take place inside the frame as the adding the tracker... I've looked for all the situations I can think of, but if any one else can think of them probably a good idea to make a note for it and compensate for it (you'll see in the CfgAmmo entries I am modifying).

Updated by Nou almost 3 years ago

  • % Done changed from 60 to 90

Pretty much good to go. Needs some more tweaks, but its defo playable now. For ACE devs, turn on debug mode in module in SP to see traces of fragments.

Work that needs to be done in the near future:

1. Optimize for direction, don't spam more fragments than realistic at grouped up people.
2. Add custom fragment types, right now using a combo of 7.62, 5.56, and the 12 gauge slugs.
3. Maybe add custom noises for fragment impacts.

Updated by tpM almost 3 years ago

Taking a quick look at my sound collection here I see (hear) I have some good recordings of fragments/debris passing by.

Updated by MagicStuffUser almost 3 years ago

Great, Nou, good idea! :)
Posible to add this feature for all obviously posible explosives?
Grenades, IED's, M203 grenades, Satchels, etc.
Thanks :)

Updated by kOepi almost 3 years ago

suggestion:

to simulate the impact of a fragment, do not use any rifle ammo, since that ammunition has much more power, like in real life.

Ill do a research what kind of ammo should be equal to fragments.

Updated by Jman almost 3 years ago

I've found a small issue. When firing a mortar, fragments are thrown over the gunner and cargo unit (loader) which results in injury/death to them.

Updated by Nou almost 3 years ago

Is this with a specific mortar system?

Updated by Jman almost 3 years ago

I used a Podnos 2B14 with 8Rnd_82mmHE_2b14

Updated by Nou almost 3 years ago

I know, but was this using the ACE mortar system, the BIS mortar system, R3F, or something else?

The problem is with systems that remove the round after its fired (and not in the same frame, which is confusing because the fired EH is where it would be done and unless someone is stupidly using a spawn it should all take place in the same frame...) and the frag tracking system things it blew up so it spawns frags.

Updated by Jman almost 3 years ago

Standard BIS Arty module system
Video here: http://www.youtube.com/watch?v=Ha0See-f3ZQ

Updated by Nou almost 3 years ago

Artillery computer (OA) or the old artillery module from A2?

Updated by Jman almost 3 years ago

I just placed the Artillery module on the map and synced the AI gunner to it.

Updated by Nou almost 3 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 90 to 100

That bug should be fixed for BIS arty module. Please report any new bugs (or if this didn't fix it) in their own tickets assigned to me.

Also available in: Atom PDF