Feature #30567

M9 recoil

Added by Jester814 about 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:04/22/2012
Priority:Normal Due date:
Assignee:Robalo % Done:

100%

Category:-
Target version:1.14
Component:c_weapon Affected Version:
Close Reason:

Description

The recoil on the M9 was changed some time in the past few months to about 2-3x what it was in the past. It's now more or less uncontrollable for quick shooting. I haven't tested any of the other pistols as I don't use any others. This is disappointing because I know that I have submitted this before and it was lessend, but now it was raised again...?

Please return it's recoil to where it was before the change. Considering you have to hit a target 5-7 times to kill them with the m9 the follow up shots are extremely important. Everyone in my unit(15th MEU Realism Unit) has stopped carrying one because it's basically unusable in it's current condition.

Lastly, realism wise, it's way too much recoil. When you shoot your muscle memory pretty much brings your sights back to very very close to where you were aiming.

Thanks

ace_c_weapon.7z (1.9 MB) Robalo, 05/04/2012 03:53

Associated revisions

Revision e40d4c8e
Added by Robalo almost 3 years ago

minor pistol recoil tweaks, refs #30567

History

Updated by ScarecrowisNOTamused. about 3 years ago

So its not just me, i was starting to think all pistols included in ace had ridiculously a large amount of recoil as double taping targets started to seem near impossable, while i find the recoil is at least semi realistic it doesn't reset to the original position quickly which is the issue.

Updated by Sickboy about 3 years ago

  • Status changed from New to Feedback
  • Target version set to 1.14
  • Component set to c_weapon

Updated by ScarecrowisNOTamused. about 3 years ago

Hmm, either way, the recoil seems realistic, is it possable to adjust the rate/speed that it resets back onto target?

Updated by Robalo about 3 years ago

It was a long time ago, I haven't tweaked the recoils myself, just added them to the pistol configs since they were unused. Nobody cared then, did it to align the pistols with the overall ACE recoil settings. I found even the Colt's recoil manageable which is higher than the M9's, at least last I played. Instead of going back to vanilla recoils, I'd rather tweak the recoils a bit if needed. Perhaps master of the recoils Q can share his thoughts on this ?

Updated by Jester814 about 3 years ago

Ok I tested all the different pistols in both ACE and Vanilla and I have to say that I like the vanilla recoil a lot more. The recoil for all ACE pistols seems to have been changed by the "recent" change. Not just the M9. It still causes muzzle climb but it's actually fairly easily controllable, as opposed to ACE where, by the time I'm done shooting 7 rounds, I've dragged my mouse from the middle of my mousepad all the way to the bottom and have to stop shooting, pick my mouse up, and return it to the middle of the mouse pad.

For reference, I play ArmA with the sensitivity at 0, as far down as it will go. This was one of my original complaints when the new recoil system was introduced over a year ago. People that play at insanely high sensitivity can just barely move their mouse to adjust their recoil, but people like me that play at very, very low sensitivity are unfairly punished by this type of recoil model.

All that said though, the pistol recoil, as stated already here, was increased six months ago. I didn't post about it back then because I figured it was either an error, or someone else would post to get it reverted. I basically procrastinated until I died because of it in game when my rifle went dry and I quick swapped to my pistol, and after the first round my point of aim was about 1-2 feet above my targets head.

It's all about where the point of aim ends up after each shot, not about the amount of visual recoil when the shot happens. If it could be made so that the POA would return to very close to the original POA after each shot, that would be great, as that's the primary issue. The issue isn't how much the pistol "jumps" when it's shot, it's that the sights don't re-align to anywhere near the target.

Updated by Huggy about 3 years ago

Never had problems with my USP tbh............ even with the latest version

If someone needs 5-7 hits to strike a target with a pistol then a visiting a shooting range does wonders compared to any change the ACE team can do.

Updated by Jester814 about 3 years ago

"If someone needs 5-7 hits to strike a target with a pistol then..."

You seem to have a reading comprehension issue. "5-7 hits to strike a target" doesn't even make sense. 5-7 hits IS 5-7 strikes. I said it takes 5-7 hits to kill a target.

So what you're saying is that you use the USP, which is a .45, and kills targets in 1-3 hits, and you basically have no idea how the M9, which is a 9mm works, because it takes 5-7 hits to kill it's target.

I'm in a realism unit. I don't get to choose between a 9mm and .45 or I'd damn sure be carrying a .45. My only choice is the m9 or more bandages.

Updated by Robalo almost 3 years ago

Made some small adjustments. Please test with attached pbo.

Updated by Jester814 almost 3 years ago

Feels 100% better to me. I can make fairly quick, accurate follow up shots with both the 9mm and the .45s now. Thanks a ton.

Updated by Robalo almost 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 50 to 100

Setting this as done then, thanks.

Updated by Sickboy almost 3 years ago

  • Status changed from Resolved to Closed

Available on Six Updater.

Also available in: Atom PDF