Bug #30286

Laser Designator autoreload

Added by Magician about 3 years ago. Updated about 3 years ago.

Status:Rejected Start date:04/13/2012
Priority:Low Due date:
Assignee:tcp % Done:

0%

Category:Config
Target version:-
Component:sys_rangefinder Affected Version:
Close Reason:

Description

Here is the problem, if use left mouse button (LMB) laser beam active but it deceiver me because you need press "R" key to reload a battery even if the first time, i f talk to realism i dnot have my cellular phone without battery before use it.
My suggestion is Laser Designator must have autoreload when use LMB and disable laser point when no battery

History

Updated by Sickboy about 3 years ago

  • Status changed from New to Feedback
  • Assignee set to tcp
  • Priority changed from Normal to Low
  • Component set to sys_rangefinder

AFAIK this is by design, I believe due to engine limitations.

Updated by Magician about 3 years ago

do not think so,

class CfgWeapons {
    class Binocular;
    class Laserdesignator: Binocular {
        autoreload = 1;
    };
};
class Extended_PostInit_EventHandlers {
    TCP_RF_postinit = "[] execVM '\TCP_RF\initRF.sqf'";
};

Updated by Sickboy about 3 years ago

What are you trying to show ?

Also in the future please use pre or code tags, i've updated the comment.

Updated by tcp about 3 years ago

  • Status changed from Feedback to Rejected

What if you want to turn on the overlay to take direction and elevation readings without firing the laser (so that you don't waste battery, interfere with another fire mission, or alert the enemy)? You aren't reloading when you press R or whatever key you have that set to, you are turning it on. If you want to use the laser in the old way, unassign the R key or never press it. If you don't want to be confused by the laser operating in the old way with old style batteries, have the mission maker swap battery types available. Also, I am not going to be adding a key and mouse handler to all the fire buttons because no other system has needed it, and there is no justification to add one. If you understood the configs and how the addon system worked, you would be able to explain what you propose better.

Updated by Magician about 3 years ago

tcp wrote:

What if you want to turn on the overlay to take direction and elevation readings without firing the laser (so that you don't waste battery, interfere with another fire mission, or alert the enemy)? You aren't reloading when you press R or whatever key you have that set to, you are turning it on. If you want to use the laser in the old way, unassign the R key or never press it. If you don't want to be confused by the laser operating in the old way with old style batteries, have the mission maker swap battery types available. Also, I am not going to be adding a key and mouse handler to all the fire buttons because no other system has needed it, and there is no justification to add one. If you understood the configs and how the addon system worked, you would be able to explain what you propose better.

I dnot use A.C.E.(sometimes try to achieve such realism that you lose the essence of the game and engine limitations) but sometimes play in multiplayer ace servers,

...What if you want to turn on the overlay to take direction and elevation readings without firing the laser (so that you don't waste battery, interfere with another fire mission, or alert the enemy)?...

that benefit is the binocular or rangefinder?
your laser designator has everything that is needed is, I think that's an imbalance, anyway I care little just wanted to make a suggestion

Also available in: Atom PDF