Bug #30274

Faulty tail rotor animation for UH-60M and UH-1Y

Added by stun almost 3 years ago. Updated over 2 years ago.

Status:Assigned Start date:04/12/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Vehicles
Target version:-
Affected ArmA II version:1.62.95248 First affected build:1.60
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:Both
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When rotors get up to full speed on UH-60M and UH-1Y helicopters the wrong animation/effect is used. Also horizontal stabiliser is no longer animated on UH-60M

For UH-60M when rotors are at full speed the tail rotor reverts to a slow rotation animation and is no longer blurred. Also when forward speed picks up the horizontal stabiliser no longer animates to tje high speed position as it does on UH-60S.

Repro
Load UH-60M in editor with external view. Start up helicopter and take off and fly at high speed. Observe tail rotor and stabilizer when helicopter is at full speed.

Similar issue for UH-1Y at full speed the tail rotor reverts to a slow animation with slightly blurred rotor effect.

For the repro, make sure the screen refresh rate above 60 Hz and ensure that the config refresh rate is above 60fps as well. This is also the reason, why a video is not feasible.

Notes
UH-60S does not suffer from this bug.

I've noticed this bug quite a while ago and am pretty sure it appeared prior to 1.60.

History

Updated by zGuba almost 3 years ago

  • Status changed from New to Feedback
  • Assignee set to stun

Please add screens or video, otherwise fine report.

Updated by stun almost 3 years ago

The issue can't be capture using a screen shot or video I'm afraid. A screen shot can't display the issue unfortunately as it is an animated event - I tried but in the screen shots it looks fine. I also tried capturing it on video but as soon as fraps starts recording it locks the fps at 60 fps and the issue is no longer apparent.

This made me curious. I normally have my screen refresh rate at 75Hz with vsync enabled. When I set my refresh rate to 60Hz in windows and in my ArmA2OA config file the issue disappered the same as it did when running fraps. It looks like the issue is caused when fps are running above 60fps. The strange thing is that the tail rotors on other helicopters are fine when I'm running at 75 fps.

So my repro needs to be changed to run a screen refresh rate above 60 Hz and ensure that the config refresh rate is above 60fps as well.

I hope this helps.

Updated by Fireball almost 3 years ago

  • Description updated (diff)
  • Status changed from Feedback to Assigned
  • Assignee deleted (stun)

Updated by kju over 2 years ago

  • Affected ArmA II version changed from 1.61 Beta to 1.62.95248

Also available in: Atom PDF