Bug #30194

Higher mouse response time causes lag freeze during turns or mouse look

Added by Mikhail over 3 years ago. Updated about 3 years ago.

Status:Rejected Start date:04/10/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Controls
Target version:-
Affected ArmA II version: First affected build:Please Specify...
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

The behaviour is as follows. When you I move my mouse up or down, or move it sideways slowly - all is ok. When I perform a quicker turns left or right the game lags\freezes at some points. So whenever I wanted to turn quicly to 90 degrees or so, cursor stops at random positions, then I have to continue turn again with my mouse, it freezes again and thus I perform this turn in a three or four laggy crazy turns waving my mouse insanely :)

For a looong time I thought that this "turn lag" was caused by my low system specs. It was very annoying for more than half a year or even more, can't remember. But recently I bought a new mouse from A4tech X7 series. While I fiddled with it's many settings I noticed a "Response Time" parameter. It had some six presets starting from "Office" as the lowest and spanning to "Game" as the highest response time. Here's the description:

Adjustable Mouse Key Response Time You can set mouse key responding time between 3-30ms.
It not only extends the mouse key switch lifetime but also offers quick response over your opponents during the game play.

I presume, it had some default setting set to, let's say, Average. I switched it to the highest gaming mode and my good old turning lag heavily increased! I realized that it's the cause of all the trouble. I turned it to the lowest and this lag disappeared without any visible impact on my "response over my opponents during the game play". =)
I hope this can help other people with similar issues to fix this lag, which really spoils a lot of fun.
I'm happy I could solve this myself but I'm still not sure it's Arma engine bug, though it appears to be so. In case it's my own clientside specific hardware bug - sorry :)

Thanks for your attention.


Related issues

related to ARMA2 Community Issue Tracker - Bug #27127: Mouse acceleration Assigned 12/17/2011

History

Updated by Mikhail over 3 years ago

  • Description updated (diff)

Updated by Fireball about 3 years ago

  • Status changed from New to Rejected

Guess we need to know if it's an engine bug or not. One thing is clear, there is a mouse acceleration of some kind (see #27127), which is annoying to some, but I guess it's not related to yours.

Rejecting for now, because, as you already noted, it seems definitely be related to your hardware in your case, it will show up in anyone's search.

Also available in: Atom PDF