Bug #30191

NOMAD lets you join back in after lives are exceeded

Added by highhead almost 3 years ago. Updated over 2 years ago.

Status:Closed Start date:04/09/2012
Priority:High Due date:
Assignee:Tupolov % Done:

0%

Category:Script
Target version:MSO v4.55
Component:Core Reproduced by another DH user:No
Close Reason: I am using some Mods:No
Affected Version:

Description

Repro on dedicated with latest GIT version (unofficial):

- Start up Takistan MSO (Savestate: Manual, Lives restriced to 3, else standard)!
- Wait till its fully loaded before connecting
- Respawn and wait till you back up
- you should get kicked to lobby now instantly
- From lobby, join back in!

--> Klick on Save player state (interaction menu) gets you kicked.

Seems like since there is no check on lives after JIP.

History

Updated by highhead almost 3 years ago

Also "infinite lives" is not working, maybe can be fixed in one scratch

Updated by wolffy.au almost 3 years ago

  • Target version set to MSO v4.4

Updated by wolffy.au almost 3 years ago

  • Priority changed from Normal to High

Updated by Tupolov over 2 years ago

  • Category set to Script
  • Status changed from New to In progress
  • Assignee changed from wolffy.au to Tupolov
  • Target version changed from MSO v4.4 to MSO v4.55
  • Component set to Core

Updated by Tupolov over 2 years ago

  • Target version changed from MSO v4.55 to MSO v4.6

Updated by highhead over 2 years ago

  • Status changed from In progress to Closed

Excluded limited respawns. Only infinte respawns possible now, so indirectly fixed due feature-remove!

Updated by highhead over 2 years ago

  • Target version changed from MSO v4.6 to MSO v4.55

Also available in: Atom PDF