Bug #29970

Nomad currently kicks the player after 1 death (does not enforce number of lives)

Added by Tupolov almost 3 years ago. Updated over 2 years ago.

Status:Rejected Start date:04/01/2012
Priority:High Due date:
Assignee:Tupolov % Done:

0%

Category:Script
Target version:MSO v4.55
Component:Core Reproduced by another DH user:Yes
Close Reason: I am using some Mods:No
Affected Version:

History

Updated by Ross514 almost 3 years ago

  • Reproduced by another DH user changed from No to Yes

editing these lines in the "description-mso.EXT" has no effect nor does editing nomad's params in game

//http://community.bistudio.com/wiki/Description.ext#Respawn...
respawn = 3;
respawnDelay = 15;
respawnDialog = false;

for a quick I have used the "rmm_nomad" and "description-mso" from previous version and it works fine

Updated by highhead almost 3 years ago

Seems like a feature not a bug!

You have "x lives" per "Reset Lives value"! Means if you set up "3 lives per day", NOMAD divides 24h/3 lives = 8 hours per life!
PLS have a look at that!

Updated by Ross514 almost 3 years ago

i thought that at first until changing in game params or the values in the description-mso.ext has no effect as my post says. also if you read it swapping files from prior version works as intended. i havent made time to go through it line by line but its probably just a script typo or something. if i find the issue ill post a fix but as i said prior files fix the issue and ive also tested it on the RHRC server without any errors or breaking the script after no less than three hours up

Updated by Tupolov almost 3 years ago

  • Target version changed from MSO v4.3 to MSO v4.4

Updated by Tupolov almost 3 years ago

  • Priority changed from Immediate to Normal

NOMAD currently disconnects players when they die (and lives are NOT set to infinite). On disconnect the player is informed that their next life is in eg. 7.55 hours. Players can exceed number of lives.

Updated by Tupolov almost 3 years ago

  • Subject changed from Nomad currently kicks the player after 1 death to Nomad currently kicks the player after 1 death (does not enforce number of lives)

Updated by wolffy.au almost 3 years ago

  • Priority changed from Normal to High

Updated by Tupolov over 2 years ago

  • Target version changed from MSO v4.4 to MSO v4.55

Updated by Tupolov over 2 years ago

  • Assignee changed from wolffy.au to Tupolov

Updated by Tupolov over 2 years ago

  • Status changed from Assigned to In progress

Updated by highhead over 2 years ago

Wont be fixed in regular MSO anymore. Will be rewritten/redesigned in MSO Next Generation!

Updated by highhead over 2 years ago

  • Status changed from In progress to Rejected

Also available in: Atom PDF