Bug #29310

1.61 beta: Aim of AI AT soldiers (RPG) is significantly worse than in beta 89647

Added by OMAC about 3 years ago. Updated over 2 years ago.

Status:Closed Start date:03/11/2012
Priority:Normal Due date:
Assignee:hladas % Done:

80%

Category:AI Issues
Target version:1.63 BETA
Affected ArmA II version:1.62.95248 First affected build:1.60.90242
Reproduced by another DH user:No First affected ArmA II version:1.61 Beta
I am using some Mods:No Single / Multi Player?:SP Only
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

In beta 90242, the aiming accuracy of AI AT soldiers using RPGs is dramatically reduced from beta 89647. Compare attached mission in editor using 89647 and 90242. In 89647, relatively few shots at armor are missed, and squad completes task by moving to Dragon's Teeth after vehicles are destroyed. In beta 90242, up to 30% of shots are usually missed, and squad often cannot complete destroy tasks since they run out of ammo.

I don't know if this issue is related to this recent fix:

[89899] Fixed: Helicopter is more accurate with unguided rockets


Side note: I have noticed that the LAV-25 (HQ) can sustain up to 6-7 RPG hits and still not be destroyed, making it tougher than any other US armored vehicle that I have found. Even the turned-out turret MG gunner isn't harmed after multiple direct hits. Also, this vehicle is much harder to hit than any other vehicle (something to do with the model?), and a Metis cannot lock onto it, even with beta 89647. The Metis can lock onto the turret MG gunner, but most shots will miss. Still, AI with Metis will eventually take out the vehicle after many misses and glancing blows. If someone can duplicate this and agrees that this is unexpected or undesirable behavior, I can make another ticket dedicated to that.

arma2oa_2012_05_10_18_54_04_318.jpg (96.4 kB) OMAC, 05/14/2012 13:50

ATgunner_aim_test.Chernarus.zip (1.6 kB) OMAC, 05/25/2012 03:23

AT_aim_test2.Desert_E.zip (1.5 kB) OMAC, 05/25/2012 03:24


Related issues

related to ARMA2 Community Issue Tracker - Bug #28865: Javelin locking intermittent in MP Closed 02/22/2012
related to ARMA2 Community Issue Tracker - Bug #34275: AI RPG-18 only fire when enemy is close Assigned 06/22/2012
related to ARMA2 Community Issue Tracker - Bug #62100: Locking guided missiles, AI-fired RPGs, and BMP-2 have tr... Assigned 10/29/2012

History

Updated by OMAC about 3 years ago

  • First affected build changed from Please Specify... to 1.60.90242

The aiming in the beta 89647 seems normal.

Updated by OMAC about 3 years ago

  • Description updated (diff)

Updated by OMAC about 3 years ago

  • Description updated (diff)

Updated by OMAC about 3 years ago

  • Description updated (diff)

Updated by OMAC about 3 years ago

  • Subject changed from 1.61 beta: Aim of AI AT soldiers (RPG) is drastically worse than in 1.60 to 1.61 beta: Aim of AI AT soldiers (RPG) is drastically worse than in beta 89647

Updated by OMAC about 3 years ago

  • Description updated (diff)

Updated by OMAC about 3 years ago

  • Description updated (diff)

Updated by OMAC about 3 years ago

  • Description updated (diff)

Updated by OMAC about 3 years ago

  • Subject changed from 1.61 beta: Aim of AI AT soldiers (RPG) is drastically worse than in beta 89647 to 1.61 beta: Aim of AI AT soldiers (RPG) is significantly worse than in beta 89647

Updated by OMAC about 3 years ago

Still true in beta 91138. In repro mission, opfor AT soldiers cannot destroy all vehicles before running out of ammo.

Updated by OMAC about 3 years ago

  • Difficulty changed from Not set to Veteran

Updated by Dwarden almost 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Target version set to 1.61 BETA

Updated by Dwarden almost 3 years ago

if possible can you make repro mission only for OA (all units and maps from OA)?

Updated by OMAC almost 3 years ago

No problem. I'll do it this evening.

Updated by OMAC almost 3 years ago

  • File AT_aim_test.Desert_E.zip added

Updated by OMAC almost 3 years ago

  • File deleted (AT_aim_test.Desert_E.zip)

Updated by OMAC almost 3 years ago

  • File AT_aim_test2.Desert_E.zip added

Here's a mission on the Desert OA map with only OA vehicles and AT men (Takistani army). In 89647, the AT men usually destroy all vehicles and go to dragon's teeth, but in 92612, more AT shots are missed, and all the vehicles are not destroyed most of the time (men will not proceed to dragon's teeth).

Updated by OMAC almost 3 years ago

Here is a shot of what happens when you try to use Metis to attack LAV-25 (HQ). Only the turned-out driver is locked on, not the vehicle itself.

Updated by OMAC almost 3 years ago

With beta 92767, it is nearly impossible for an AI AT gunner to hit the LAV-25 (HQ). 97%+ of RPG shots miss, most likely due to a modelling issue where only the turned-out gunner/commander is targeted, not the vehicle.

Edit: The reason I care so much about AI hitting the LAV-25 (HQ) is that that vehicle is included in the intro of a mission of mine (Retaliation, http://forums.bistudio.com/showthread.php?133457-OMAC-Mission-Pack-1).

Updated by tonci87 almost 3 years ago

AT AI is terribly ineffective. They take quite long to aim with their launcher and then they often miss or get killed by the tank before they can fire.

Updated by OMAC almost 3 years ago

  • File deleted (ATgunner_aim_test.Chernarus.7z)

Updated by OMAC almost 3 years ago

  • File deleted (AT_aim_test2.Desert_E.zip)

Updated by OMAC almost 3 years ago

I'm replacing both repro missions as there may have been destroy waypoints in them that weren't properly linked to target vehicles.

Updated by OMAC almost 3 years ago

Updated by hladas almost 3 years ago

  • Assignee changed from Dwarden to hladas
  • Target version changed from 1.61 BETA to 1.62 BETA
  • % Done changed from 0 to 10

Updated by hladas almost 3 years ago

  • % Done changed from 10 to 80

Updated by kju almost 3 years ago

  • Target version changed from 1.62 BETA to 1.63 BETA

Updated by kju almost 3 years ago

  • Affected ArmA II version changed from 1.61 Beta to 1.62.95248

Updated by Fireball over 2 years ago

  • Status changed from Assigned to Resolved

We could call this resolved, due to my last testing connected with #60304. Anyone objecting?

Updated by OMAC over 2 years ago

Aim does seem better as of 98443. The model problem remains with the LAV-25 HQ mentioned in the notes, but that perhaps should be its own ticket, eh?

Updated by Fireball over 2 years ago

  • Status changed from Resolved to Closed

Absolutely. I think the LAV-25 HQ is probably made this way because it's only used in Warfare and thus hardened for balance - probably a design decision, not a bug.

Updated by OMAC over 2 years ago

I see. That makes sense about the LAV-25. As BIS only put the fix work at 80% done, I was wondering if they thought they had more work to do?

Updated by Danil-ch over 2 years ago

I'm still get AT soldiers cannot destroy all vehicles before running out of ammo.

Updated by OMAC over 2 years ago

Yes, in the repro missions, the AT soldiers never make it to the Dragon's teeth as they used to, and many shots are missed.

Updated by kju over 2 years ago

I'd say the situation is perfectly fine.
Given the fact that they have 0.2 skill only, the result is pretty good.
If you bump it to 1, the accuracy is near perfect.

Except the LAV HQ case which needs an extra ticket.

Updated by OMAC over 2 years ago

Yes, I agree.

Also available in: Atom PDF