Bug #29186

Linux Server Crash caused by Unrecognized texture type '.jpg':

Added by thhamm almost 3 years ago. Updated over 2 years ago.

Status:Closed Start date:03/06/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Server
Target version:1.62.95248
Affected ArmA II version:1.61 Beta First affected build:1.60.89986
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:MP Only
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Users connecting with custom facetextures stored as .jpg cause immediate Linuxserver crash.

Linuxserver Version 1.60.89986

core.bz2 (729.3 kB) thhamm, 03/06/2012 18:37

History

Updated by thhamm almost 3 years ago

19:30:32 [AI]Muecke uses modified data file - Arma 2;Arma 2: Operation Arrowhead;Arma 2: British Armed Forces;Arma 2: Private
19:30:32 Player [AI]Muecke connecting.
Unrecognized texture type '.jpg': 'tmp2302\players\[ai]muecke\face.jpg'

Updated by thhamm almost 3 years ago

  • First affected build changed from Please Specify... to 1.60.89986
  • Single / Multi Player? set to MP Only

Updated by Dwarden almost 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Target version set to 1.61 BETA
  • Affected ArmA II version set to 1.61 Beta

Updated by Banshee almost 3 years ago

Same problem here. Server crashes directly upon player connecting with a custom face.

Updated by bebul almost 3 years ago

I have found the problem. It can be easy fixed.
Will do it tommorow, new linux server will be most probably deployed.
Thx.

Updated by Dwarden almost 3 years ago

  • Status changed from Assigned to In progress
  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Updated by thhamm almost 3 years ago

Nice, thanks!

Updated by bebul almost 3 years ago

  • Status changed from In progress to Resolved

I have fixed it. It still complains about unrecognized texture type 'jpg', but does not crash.
Uploaded at ftp://downloads.bistudio.com/arma2.com/update/a2oa-server-1.60.90909.tar.bz2

Updated by Hanzu over 2 years ago

  • Assignee changed from Dwarden to thhamm

thhamm or anyone please verify the fix with 1.61.94594 RC1 or equal or newer beta so we can close this ticket.

Updated by thhamm over 2 years ago

sorry unable to install an 1.61 RC right now and there's no 1.61 linuxserver right now anyway.

but it's never been an issue since 1.60.90909 up until 1.60.94876 linux DS. i think it's closed.

Updated by Hanzu over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (thhamm)

Thank you thhamm for the report and bebul for the fix.

Updated by kju over 2 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Also available in: Atom PDF