Bug #2912

AI in static defense are shooting at enemy without line of sight

Added by Fireball about 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:07/19/2009
Priority:Normal Due date:09/25/2009
Assignee:Fireball % Done:

0%

Category:AI Issues
Target version:1.04.59026
Affected ArmA II version:1.02.58134 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

AI i.e. in a TOW tripod are just shooting at any thing they might be able to lock on, but they ignore the own base buildings standing in the way and will flatten the building eventually.

Just had it happening that my own AI shot down my light vehicle factory using TOWs, because some enemy was far away behind some wood, obstructed by the LF.

mission.sqm (2.5 kB) Fireball, 09/14/2009 21:30


Related issues

related to ARMA2 Community Issue Tracker - Bug #1701: Unrealistic, Impossible Detection mechanism (AI AND Player!) Closed 06/01/2009 11/08/2009

History

Updated by zombiemod about 6 years ago

I have had TOW operators in a custom "defend the base" mission blow themselves up by shooting a wall of the CPU-generated sandbag fort.

Can't trust the AI with AT weapons in such missions! :)

Updated by zGuba about 6 years ago

  • Category changed from Warfare to AI Issues

So: AT missiles shouldn't be used for suppressive fire...

Updated by Fireball about 6 years ago

Not sure if it's really a "surpressive fire" in this case or if they just don't see/ignore the building built over some time at a point.

Updated by Fireball almost 6 years ago

  • Due date set to 09/19/2009
  • Status changed from New to Feedback
  • Difficulty set to Not set

Needs verification for patch 1.03 and beta patches.

Updated by Fireball almost 6 years ago

  • Due date changed from 09/19/2009 to 09/07/2009

Updated by Fireball almost 6 years ago

  • Due date changed from 09/07/2009 to 09/15/2009
  • Assignee set to Fireball

Updated by Fireball almost 6 years ago

  • File mission.sqm added
  • Status changed from Feedback to Resolved
  • Target version set to 1.04 BETA

Fixed for me, cannot reproduce with attached mission.

Repro:
1. wait for the BTR-90 to appear
2. reveal it to your squad member using right-click

Result now:
- it does not shoot without light of sight

Updated by Fireball almost 6 years ago

  • Due date changed from 09/15/2009 to 09/25/2009

Updated by kju almost 6 years ago

  • Target version changed from 1.04 BETA to 1.04.59026

Updated by Fireball almost 6 years ago

  • Status changed from Resolved to Closed

Closing.

Also available in: Atom PDF