Bug #2906

AI unable to board more than 1 vehicle when ordered through synch'd GETIN/LOAD waypoints

Added by fabrizioT over 5 years ago. Updated over 2 years ago.

Status:Assigned Start date:07/19/2009
Priority:Normal Due date:02/01/2011
Assignee:Dwarden % Done:

0%

Category:Scripting: Problem
Target version:-
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

The wiki (http://community.bistudio.com/wiki/ArmA:_Mission_Editor#Waypoints_Mode_.28F4.29) states:

If the spatial Get In waypoint is synchronized with a waypoint of another friendly group with unused vehicle spaces, the group* will mount any available vehicle spaces* of its own before boarding the other group's transport.

Now give an AI infantry group (5 units) a "GET IN" waypoint synched with a "LOAD" waypoint of a group having 2 HHMMVV (6 cargo positions).
See infantry boarding just ONE of the HHMMVV so 2 soldiers will follow on foot your convoy ;(

Just an example of the more general problem.

See attached mission.

board_vehicles_bug.Desert_E.7z (1 kB) kju, 08/09/2010 08:47

board_vehicles_bug.Utes.7z (952 Bytes) kju, 08/09/2010 08:47

History

Updated by Fireball over 5 years ago

  • Due date set to 09/29/2009
  • Category changed from AI Issues to Scripting: Problem
  • Status changed from New to Feedback
  • Difficulty set to Not set

Is this still a problem in 1.03 or later beta?

Updated by fabrizioT over 5 years ago

Still a problem in 1.04 beta build 59025.
Not fixed.

Updated by zGuba over 5 years ago

  • Due date changed from 09/29/2009 to 11/29/2009
  • Status changed from Feedback to Assigned
  • Operating system deleted (Vista 64 bit)
  • Graphics card deleted (M9800GTX)
  • Affected ArmA II version changed from 1.02.58134 to 1.04.59026
  • Reproduced by another DH user set to Yes

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by kju over 4 years ago

  • Due date changed from 11/29/2009 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Still valid in 1.07 / OA?

Updated by kju over 4 years ago

Added repro mission for CO/OA.

Updated by kju over 4 years ago

  • File deleted (board_vehicles_bug.Chernarus.zip)

Updated by kju over 4 years ago

  • Assignee set to Dwarden

Updated by kju over 4 years ago

  • Due date changed from 11/01/2010 to 02/01/2011
  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes

Still true with latest 1.55 beta.

Also available in: Atom PDF