Bug #2905

Multiple units under one AI leader in Warfare block eachother

Added by Fireball almost 6 years ago. Updated over 4 years ago.

Status:Closed Start date:07/19/2009
Priority:Normal Due date:12/20/2009
Assignee:- % Done:

0%

Category:Warfare
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

It was amazing, how I discovered the reason for units in Warfare suddenly stopping on the point and not moving anymore!

I was recording the issue, that one of my AI units just stopped moving - in fact many units just stop over time on the spot and refuse to move despite of repeated move orders.

Then I decided to kill the leader speaking out the repeated commands (likely related to #1753) and see there, the next in the chain of command was a soldier somewhere out in the wild, very far away, and thus probably made the original leader wait for him on the spot - open remains the question why the leader only ordered him to stop all the time, basically eliminating the chances for the stray unit to return.

I hope this discovery helps to fix a couple of very nasty bugs (quite a bit excited about my finding)!

Evidence video: http://www.youtube.com/watch?v=KAHK1v3GhJA


Related issues

related to ARMA2 Community Issue Tracker - Bug #1753: AI Units cohesion problem Closed 06/03/2009
related to ARMA2 Community Issue Tracker - Bug #1706: AI Commander: Unlimited Repeat of single Order Closed 06/01/2009
related to ARMA2 Community Issue Tracker - Bug #3785: High Command stops relaying orders completely Expired 08/19/2009
duplicated by ARMA2 Community Issue Tracker - Bug #3449: Platoon not responding to orders Duplicate 08/07/2009 10/26/2009

History

Updated by Fireball almost 6 years ago

I noticed that it may happen instantly, as soon as I "send" my units to some KI and the existing units of the KI are far away. That's probably the easiest way to reproduce the behaviour for debugging.

Updated by Fireball almost 6 years ago

Another AI just stopping and being blocked by something; can't tell by what this time:

http://www.youtube.com/watch?v=m_hBU1rFabQ

It does repeat the move order I give to its driver, but they don't bother moving or engaging nearby enemies. I even was shot by some Jeep with an MG at some point after I stopped recording and they didn't bother to fire back.

I hope it's related to waiting for other AI (would be easier to fix), but I'm not sure.

Updated by Fireball almost 6 years ago

I've observed the "blocked" AI behaviour a bit longer and it seems that it happens fairly often with LAVs. But then I see sometimes, that the leader prefers to order other units under his lead around and stays put while they run. This doesn't make particularly sense, when he's blocking his comparably strong LAV this way, denying his units the support it could give. I guess this also applies to other vehicles.

Updated by kju almost 6 years ago

  • Assignee deleted (Suma)

Do not assign tickets yourself please.

Updated by Fireball almost 6 years ago

  • Status changed from New to Assigned

Updated by alef almost 6 years ago

  • Due date set to 11/03/2009

Updated by Fireball over 5 years ago

  • Category changed from AI Issues to Warfare
  • Difficulty set to Not set

Updated by Fireball over 5 years ago

  • Due date changed from 11/03/2009 to 09/20/2009
  • Difficulty changed from Not set to Veteran

Updated by Fireball over 5 years ago

  • Due date changed from 09/20/2009 to 10/20/2009

Updated by Fireball over 5 years ago

  • Affected ArmA II version changed from 1.02.58134 to 1.04.59026
  • Reproduced by another DH user set to No
  • CPU set to Please specify!

Updated by Fireball over 5 years ago

  • Due date changed from 10/20/2009 to 11/20/2009

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Feedback

Latest BETA requires re-verification of all Warfare bugs.

Updated by zGuba over 5 years ago

  • Due date changed from 11/20/2009 to 12/20/2009
  • Assignee set to Fireball

Updated by Fireball over 5 years ago

  • Status changed from Feedback to Closed
  • Target version set to 1.05 BETA

I think that was never a Warfare bug only to begin with. Though, I must admit, lately, the only stuck units I had was probably because they couldn't maneuver out of a difficult terrain (i.e. wheeled vehicles surrounded by trees) or they got stuck on rails or the low stone walls.

The base issue of this probably got resolved as side effect of some general AI issues fixing. Closing directly.

Updated by Fireball over 5 years ago

  • Assignee deleted (Fireball)

Updated by kju over 5 years ago

  • Target version changed from 1.05 BETA to 1.05.62017

Also available in: Atom PDF