Bug #29040

EOD Loudspeaker functionality seems to disappear after reconnect

Added by Tupolov about 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:03/01/2012
Priority:Normal Due date:
Assignee:Tupolov % Done:

100%

Category:Script
Target version:MSO v4.3
Component:EOD Reproduced by another DH user:No
Close Reason: I am using some Mods:No
Affected Version:4.2

Description

EOD Loudspeaker functionality seems to disappear after reconnect.

Also noticed that the EOD Loudspeaker doesn't work on dedicated server. Civs don't actually clear the area.

Have fixed the reconnect issue and added code to run the clearing of civs on the server. Two test cases:

1. Client A joins mission at start, walks up to vehicle and has Loudspeaker option available in command menu. Client A disconnects. Client B still has Loudspeaker option available at vehicle. Client A rejoins mission, Client A should be able to successfully launch the loudspeaker function from the vehicle.

2. Client A walks up to Vehicle, selects Loudspeaker from command menu (mouse wheel), Client B then also attempts to activate the loudspeaker on same vehicle
expected behaviour: Client A successfully triggers loudspeaker and it plays a loud warning to civilians. Civilians maybe affected, if so, they briefly put their hands on their head and then move away from the area. Client B should get a hint message saying "Loudspeaker is currently in use."

Note: You need EOD add-on running on server and client for this work. MSO and EOD require CBA.

History

Updated by Tupolov almost 3 years ago

  • Status changed from New to In progress

Updated by Tupolov almost 3 years ago

  • Status changed from In progress to Feedback
  • % Done changed from 0 to 100

Updated by Tupolov almost 3 years ago

  • Description updated (diff)

Updated by Tupolov almost 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF