Bug #28997

Units have See through helmets

Added by ScarecrowisNOTamused. over 3 years ago. Updated about 2 years ago.

Status:Closed Start date:02/28/2012
Priority:Normal Due date:
Assignee:PacUK % Done:

100%

Category:-
Target version:2.666
Close Reason: I am using some Mods:Yes
Affected Version: I am using:
Graphics card driver version: Reproducible for you:No
Affected ArmA II version: BIForumURL (Use new instead):
Reproduced by another DH user:No Single / Multi Player?:

Description

I did not have much time to test this issue but in the short time i did have i noticed many of the us units have 'see through' helmets under particular lighting conditions and is noticeable particularly in the models wihtout foilage nets on the helmets and seems to be predominant on the terrain, 'battle of the bulge' as seen here

Normal: http://i.imgur.com/sLXpf.jpg

'See through': http://i.imgur.com/pi9K3.jpg

Foliage net see through (only seen while in tank): http://i.imgur.com/u3S7f.jpg

Sorry i do not know of the class names, i will try with diffrent factions at a later date.

History

Updated by PacUK over 3 years ago

It's a bug that only affects certain ATI graphic card chipsets / drivers. If you disable standard AA it won't happen. If you use FXAA (or SMAA introduced in a recent beta patch) it should fix it. As I don't own an ATI card I cannot trace and fix the initial cause of it unless someone already knows.

Updated by ScarecrowisNOTamused. over 3 years ago

Ah, wow that is interesting, could you suggest any ways to track it down?, i may be able to help you seeing im (obviously) running a ATI card (6950)

Updated by PacUK about 3 years ago

  • Target version set to Future
  • Reproduced by another DH user set to No

As I don't own an ATI card I've not been able to trace this in anyway, as Homer is now part of the team and has one we hope to be able to find some clue as to the cause of this in the future.

Updated by HomerJohnston about 3 years ago

  • Target version changed from Future to 2.62

reckon we might as well put this one in the spotlight, always annoyed me in the past :)

Updated by ScarecrowisNOTamused. about 3 years ago

I also noticed some of the winter british units appear to have a similar issue, but insted of being see through they appear to have a 'aura' of thier clothing :\

Updated by PacUK about 3 years ago

"Clothing Aura" is likely a seperate issue, and "some" does not help us locate the issue, please report with more specific detail in a new ticket thanks!

Updated by HomerJohnston about 3 years ago

  • Assignee set to HomerJohnston

Probably won't "fix" the issue myself but will try to investigate a solution

Updated by PacUK about 3 years ago

  • Target version changed from 2.62 to 2.63

Moving to future version until we can track it down further.

Updated by PacUK over 2 years ago

  • Assignee changed from HomerJohnston to PacUK
  • Target version changed from 2.63 to 2.65

I now own an ATI card and can finally see these issues! Will make a defined effort to fix them now I can see what units are actually affected and when.

Updated by PacUK over 2 years ago

  • Target version changed from 2.65 to 2.7

Tracking and fixing this issue is gonna take a lot longer than is possible for 2.65 hotfix, I am getting closer but it looks like quite an intensive fix so delaying for now, but will continue to experiment. Likely cause a mix of transparency layer ordering + incorrectly ratio's on textures. Some LOD's display fine, others only cause the issue at certain distances. Very class/model specific too as some seem completely unaffected.

Waffen SS seem to have most issues with feet and helmets randomly going transparent.

Updated by PacUK over 2 years ago

  • Target version changed from 2.7 to 2.666

Updated by ScarecrowisNOTamused. over 2 years ago

PacUK wrote:

Tracking and fixing this issue is gonna take a lot longer than is possible for 2.65 hotfix, I am getting closer but it looks like quite an intensive fix so delaying for now, but will continue to experiment. Likely cause a mix of transparency layer ordering + incorrectly ratio's on textures. Some LOD's display fine, others only cause the issue at certain distances. Very class/model specific too as some seem completely unaffected.

Waffen SS seem to have most issues with feet and helmets randomly going transparent.

Yea, it's weird from memory, i think this was before there was much on the side of British and german Inf.

I've since upgraded to a Nvidea card so i can't help :P
Though i've noticed recently it still happens on my Nvidea card, but less often with third party addons, like when smoke is present and such :S

Updated by PacUK about 2 years ago

  • Target version changed from 2.666 to 2.7

Delaying so we can get the patch out quicker.

Updated by PacUK about 2 years ago

  • Target version changed from 2.7 to 2.666

https://dl.dropbox.com/u/9624177/I44A3/alphshole.jpg

Macolik discovered the root cause, hoping to get this fix applied asap.

Updated by PacUK about 2 years ago

  • % Done changed from 0 to 50

US Airborne fixed

Updated by PacUK about 2 years ago

  • % Done changed from 50 to 80

Germans fixed

Updated by PacUK about 2 years ago

  • % Done changed from 80 to 100

Brits may still need a fix but haven't seen any gfx issues, if there are any left will fix for 2.7

Updated by PacUK about 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF