Bug #28903

ToH beta 1.03.89707 - Analog collective controls non-functional most of the time

Added by OMAC over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:02/24/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Controls
Target version:1.04.90137
Difficulty:Expert Reproducible for you:Yes
Reproduced by another DH user:No First affected build:1.03.89707
CPU: Affected TOH version:1.04 BETA
I am using some Mods:No First affected TOH version:1.04 BETA
I am using: Single / Multi Player?:

Description

Using ToH beta 1.03.89707, on expert with kb/mouse, challenges using medium heli are mostly unplayable as analog collective controls (raise and lower) are either completely inoperable, or become inoperable during challenge. Pressing assigned keys has no effect, and only Q/Z digital collective controls are useable. Only way to get keys to work (intermittently) again is to quit and restart game.

I played Emergency Response challenge twice (different random missions each time), and analog controls either didn't work at all, or worked at start but then failed after several minutes (when a landing was required).

This issue could be related to recent change, although I was playing in SP only:

MP: collective would sometimes be set to hardware position without active input

Side note (probably deserves another ticket): when trying to land without analog collective controls, the medium heli went into an uncontrollable clockwise spin and quickly became damaged, ending mission. Pedal controls will not stop spin. This is related to 1.04 FM, and has been reported in beta forums.

History

Updated by Master85 about 3 years ago

  • Due date set to 03/09/2012
  • Status changed from New to Feedback
  • Assignee set to OMAC

Just to make sure:
you've mapped analogue throttle controls to keyboard/mouse?

Updated by OMAC about 3 years ago

Yes:

collective raise (analog): Left Shift
collective lower (analog): Left Windows

I've used that setup since ToH community previews.

Updated by Master85 about 3 years ago

  • Due date deleted (03/09/2012)
  • Status changed from Feedback to Assigned
  • Assignee deleted (OMAC)

Updated by OMAC about 3 years ago

I think this issue has been fixed in beta 1.04.89942.

Updated by Master85 about 3 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.04 BETA

Updated by Master85 about 3 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.04 BETA to 1.04.90137

Also available in: Atom PDF