Bug #28894

There are conflicting configs for R3F Logistics

Added by Tupolov about 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:02/23/2012
Priority:Low Due date:
Assignee:Tupolov % Done:

100%

Category:Script
Target version:MSO v4.2
Component:R3F Reproduced by another DH user:No
Close Reason: I am using some Mods:No
Affected Version:

Description

Two conflicting configs exist, I'm not sure how it came about.

support\modules\R3F_logistics\R3F_LOG\config.sqf

and

support\modules\R3F_logistics\R3F_LOG\addons_config\arma2_CO.sqf

The former includes the latter, but the data is redundant. We should clean this up.

History

Updated by Tupolov about 3 years ago

  • Assignee set to highhead

Updated by highhead about 3 years ago

  • Status changed from New to In progress

Updated by highhead about 3 years ago

The only thing thats messy is the vehicleclass-duplicates in the configs and that the addon-configs are loaded without check if they are existing on server actually.
for example:

---------------------
config.sqf:
R3F_LOG_CFG_remorqueurs = ["TowingTractor", "tractor"]

addons_config\arma2_CO_objects.sqf:
R3F_LOG_CFG_remorqueurs = R3F_LOG_CFG_remorqueurs + ["TowingTractor", "Tractor"];

---------------------
bottom of config.sqf
#include "addons_config\ACE_OA_objects.sqf"
#include "addons_config\BAF_objects.sqf"
#include "addons_config\arma2_CO_objects.sqf"

--> no check on addons (only within ACE-OA_objects.sqf itself)
------------------

Since i haven't got any issues with it i assume it is just a "nice to have".
I believe it just adds ALL POSSIBLE vehicleclasses for logistics system, so if an object (fe. "S1203_TK_CIV_EP1" ) is not loaded because the addons simply is not present (in this case CO / OA) there is also no problem with it. Only as a mission maker you will have to go thru all 3 config-files now, if you want to remove a certain vehicleclass (like the "Tractor"). Can anyone confirm errors or a real ingame-bug because of this?

Updated by highhead about 3 years ago

Moved content of /addons_config config-files to config.sqf and deleted obsolete folder. Should be easier for mission makers to exclude/include vehicleclasses.
If no bugs are reported caused by duplicates i will close the bug.

Updated by highhead about 3 years ago

  • Status changed from In progress to Feedback
  • Target version changed from MSO v4.3 to MSO v4.2
  • % Done changed from 0 to 50

Updated by highhead about 3 years ago

  • Assignee changed from highhead to Tupolov

Updated by Tupolov about 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 50 to 100

Updated by Tupolov almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF