Bug #28671

M2 Slams and M4 Slams IR and magnetic modes not detecting vehicles

Added by csuml@yahoo.co.uk about 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:02/14/2012
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:1.14
Component:sys_explosives Affected Version:1.13
Close Reason:

Description

Versions used:
ACE v1.13 r525
CBA v0.8.3 r177

The problem
The M2 and M4 slam mines don't seem to be detecting vehicles.
If you put them in magnetic mode and drive a vehicle over the top of them nothing happens.
If you setup IR mode and drive in front or over the top of the mine it still doesn't go off.
Remote detonation however seems to work.

Reproduction steps
1. Place M2 or M4 on the ground and sight in.
2a. Remove the IR strip then pull the pin. OR
2b. Pull the pin to arm magnetic mode.
3. Drive a UAZin front of, on top of and all over the mine.
4. Attempt to disarm the mine and it will explode.

Expected results
When a UAZ drives in front of the mine when in IR mode it should fire off a penetration rocket.
When a UAZ drives over a magnetically set mine it should hit the bottom of the vehicle

Actual results
The mine never goes off.

Further to this if you try and disarm the mine it always explodes.

fnc_menuDef.sqf.patch - show disabled "Disarm" menu for armed M2/M4 in "Side" and "Bottom" modes (1.1 kB) Dystopian, 03/22/2012 22:37

History

Updated by rocko about 3 years ago

  • Status changed from New to Resolved
  • Target version changed from TBD to 1.14
  • % Done changed from 0 to 100
  • Component set to sys_explosives

Updated by Sickboy about 3 years ago

  • Status changed from Resolved to Closed

Available on SU.

Updated by Dystopian almost 3 years ago

What about explosion after disarming? Is it correct effect?

Updated by rocko almost 3 years ago

Dystopian wrote:

What about explosion after disarming? Is it correct effect?

B. SUMMARY OF PROBLEM: TWO ACCIDENTS RECENTLY OCCURRED DURING M2 SLAM TRAINING EXERCISES RESULTING IN SERIOUS INJURY. THE INCIDENTS INVOLVE SOLDIERS APPROACHING AN UNDETONATED SLAM. 
BECAUSE OF THE FIRST INCIDENT, USASOC SUSPENDED ALL USE OF THE SLAM (REF 1) PENDING THE RESULTS OF THE ACCIDENT INVESTIGATION. 
SUBSEQUENTLY, USASOC AUTHORIZED THE SLAM FOR CONTINGENCY/OPERATIONAL USE (REF 2). 
THIS AUTHORIZATION EMPHASIZED THAT OPERATORS SHOULD BE AWARE OF THE CHARACTERISTICS OF THIS MUNITION, ESPECIALLY THE ANTITAMPERING AND MAGNETIC SENSING CHARACTERISTICS OF THE MUNITION WHEN IN THE MINE MODE (THESE CHARACTERISTICS ALSO APPLY TO THE SIDE ATTACK MODE), AND THEY SHOULD ALSO BE AWARE THAT ONCE THE MUNITION IS ACTIVATED, THE MODE ORIGINALLY SET CANNOT BE CHANGED. 
IN RESPONSE TO THE SECOND ACCIDENT, USASOC AGAIN SUSPENDED USE OF THE SLAM (REF 3). 
PROCEDURAL ERRORS WERE FACTORS IN BOTH ACCIDENTS; 
NO SPECIFIC MATERIAL FAILURE ISSUES WERE VALIDATED; 
HOWEVER, IT IS UNCLEAR IF MATERIEL FAILURE ISSUES WERE CONTRIBUTING FACTORS.

Updated by Dystopian almost 3 years ago

  • File fnc_menuDef.sqf.patch added

Maybe we should disable "disarm" menu for armed M2/M4 then? The patch for ace_sys_explosives\fnc_menuDef.sqf is attached.

P.S. There are errors in fnc_action_defuse.sqf ("localize "STR_ACE_EXPL_DEFUSE"") and fnc_action_submerge.sqf ("localize "STR_ACE_EXPL_SUBMERGEIED"") - there aren't such strings in stringtable.xml.

Updated by rocko almost 3 years ago

Dystopian wrote:

Maybe we should disable "disarm" menu for armed M2/M4 then?

No, we expect you to learn your stuff.

Updated by Dystopian almost 3 years ago

rocko wrote:

No, we expect you to learn your stuff.

Morphine or epinephrine overdose can lead to death, but ACE let us use them only when we need it.
I fixed my patch to show disabled "Disarm" menu.

In fact I think that we should have "Examine" menu for each armed M2/M4 (like for any person using ACE Wounds). If it can be defused, "Disarm" sub-menu should be enabled, otherwise disabled. In both cases "hintSilent" message with current detonation mode should be shown. Shall I create feature request or is it useless or is it enough of this post?

Updated by Dystopian almost 3 years ago

  • File deleted (fnc_menuDef.sqf.patch)

Updated by rocko almost 3 years ago

I see... sounds like a plausible explanation to allow medic to pump morphine or epi into other players EVEN IF they are not needing it (though that finally needs some effects to be done, like blurring etc, which is again not possible due to dynamicBlur not supported by the engine anymore...)

However, maybe you should just see it as "expression of free will" when it comes to disarming the mines. Technically you can 'try' to disarm a M2. But the M2 will just explode in your hands if you try to disarm it and it is in these certain modes. I don't think the Interaction menu should do the thinking for you and not show the Disarm option, when the M2 is about to blow in your face if you try to disable it.

You can for example examine the M2 visually. If you see it upright and the IR cover is removed (this should be viewable on the model) DON'T touch it and try to disable it by shootig or using C4. Same if it just lies on the ground (it could either be not armed or in Bottom Attack mode). Again, DON'T touch it, disable it.

Updated by Dystopian almost 3 years ago

rocko wrote:

You can for example examine the M2 visually.

rocko
I'm sorry about my previous posts. I've just realized that each mode looks different. But I think it will be much clearer if Explosives wiki contains information about M2/M4 disarming.

Also available in: Atom PDF