Bug #28660

FPS degradation since build 524

Added by Robalo about 3 years ago. Updated about 3 years ago.

Status:Closed Start date:02/13/2012
Priority:Immediate Due date:
Assignee:Sickboy % Done:

100%

Category:-
Target version:1.14
Component:sys_repair Affected Version:
Close Reason:

Description

There seems to be something very bad about last update (today's ?). Both server and client FPS drop steadily to 5 FPS after the start of any mission. Problem seems to be related to changes in sys_repair, at least on a local MP game without this pbo the issue disappeared.
I spotted a new nearestObjects call in the menu def, that looks dangerous, might be the source of the problem ?
https://dev-heaven.net/projects/ace-mod2/repository/revisions/f5374f6834eee758e710eff720ca957e48ab55d3/diff/Addons/sys_repair/fnc_menuDef.sqf
Sorry I can't debug any further right now.

#ACE_TEST_LAG.Desert_E.7z (591 Bytes) Sickboy, 02/13/2012 19:19

Associated revisions

Revision 1fb9fdb1
Added by Sickboy about 3 years ago

~ FIXED: Infinite loop spawning JerryCans. fixes #28660

History

Updated by Xeno about 3 years ago

  • Status changed from New to Feedback
  • Private changed from No to Yes

Updated by Xeno about 3 years ago

  • Private changed from Yes to No

Updated by Xeno about 3 years ago

The nearestObjects call has a radius of 7 meter, not a problem.
And it also doesn't affect server performance as it only runs on a client.

Updated by Sickboy about 3 years ago

Cannot reproduce with a basic test mission.

Updated by Sickboy about 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Updated by Robalo about 3 years ago

After removing ace_sys_repair I got back to a normal steady 50 FPS on the server instead of the fast drop to 5 FPS, on a simple classic mission.

Updated by Xeno about 3 years ago

Sickboy has fixed it, infinite loop caused by jerry cans

Updated by Robalo about 3 years ago

Thanks a bunch !

Updated by Sickboy about 3 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Sickboy
  • Priority changed from High to Immediate
  • Target version changed from TBD to 1.14
  • Component set to sys_repair

Loop elinfinitas, spotted once I threw a bunch of vehicles on the map ;-)
Jerry's are also vehicles, based on Car, hence InitPost EH on Cars that was handling jerry's was also running for jerry's themselves and creating more little jerry's :-)

Updated by zGuba about 3 years ago

It's all them Germans :P

Updated by rocko about 3 years ago

And I blamed the beta for my degrading FPS issue with a brandnew GTX 560

Also available in: Atom PDF