Bug #2861

M203 Grenades sometimes do not explode

Added by solrac42 almost 6 years ago. Updated almost 6 years ago.

Status:Rejected Start date:07/16/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Gameplay
Target version:-
Affected ArmA II version:1.02.58134 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

As the title says, the M203 grenades do not explode if they land too close to the player.

Also when fired into walls they do not always explode.

History

Updated by delevero almost 6 years ago

M203 grenades work just like in real life.. The reason why they do not explode close to the player/soldier is simply that they first activate the grenade after some meters of flight simply to keep the soldier safe... its the same with anti tank systems and many other weapons.
Actually the law launcher ( standard 1 shot anti tank ) have to fly more than 50m before it arm it self... some gangsters tried some years ago in denmark to shoot a house but it did not arm it self also there is a big difference inbetween a tank round and a HE round.. The tank round will just make a tiny hole in the outside and inside there will be alot of heat... while the HE will just explode outside anything it hit.

But one thing that is not simulated in arma is that if you fire the m203 or a non letal weapon that work the same way then if you shoot someone close by the grenade will pass through their body and kill them... imagine being hit by a grenade that size flying wiht more than 100km an hour ;-)

I have not had any problems with M203 grenades fired into walls.

Updated by solrac42 almost 6 years ago

I must have been too close to the walls so the grenades did not arm themselves.

Thanks for the info delevero.

Updated by Squelch almost 6 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF