Bug #2846

Eliteness doesn't like DePbo 2.17

Added by Xeno almost 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:07/15/2009
Priority:Normal Due date:
Assignee:Xeno % Done:

100%

Category:Eliteness
Target version:Completed
Affected Version:

Description

Eliteness doesn't start with DePbo 2.17.

It produces an error, ?ErrorString@DeRap@QAEPBDW4RapError@@z not found in DePbo.dll

2.16 is fine.

History

Updated by Xeno almost 6 years ago

And as an addition, don't want to file a new ticket, Eliteness opens the file, when used with 2.16, it shows it shortly but then it vanishes.

Updated by mikero almost 6 years ago

  • Status changed from New to Resolved
  • Target version set to Completed

should all be resolved with eliteness 2.44 / dll 2.18
thanks for the feedback

Updated by kju almost 6 years ago

  • Category set to Eliteness
  • Assignee set to Xeno

Updated by Xeno almost 6 years ago

So I only have to wait until 2.18 is available as download :)

Btw, would be nice if you could remove the older versions from the download (Files) page.

Updated by Xeno almost 6 years ago

Ah, found it, am blind.

But...

If I open a config.bin file with Eliteness, I can see the text for a second and then it's gone. Blank viewer control :(

That is when I open a config.bin file with mouse double click (it automatically starts Eliteness, worked fine with older versions).

Updated by kju almost 6 years ago

  • Status changed from Resolved to Feedback

Config.bin work fine for me with Eliteness 2.44 and dll at 2.18.

Please supply problematic config.

Updated by Xeno almost 6 years ago

Hm, the config.bin file doesn't matter, it happens with all.

Eliteness pops up, shows the config text, my floppy disk drive shortly says hello and then the viewer control gets emptied. Nothing in there anymore. I can still open the bin file manually with File -> Open.

Previous version didn't have that behaviour.

Updated by kju almost 6 years ago

  • Assignee changed from Xeno to mikero

Mikero any ideas?

You are on XP Xeno?

Updated by Xeno almost 6 years ago

kju wrote:

You are on XP Xeno?

Yes, XP Prof SP3

Updated by mikero almost 6 years ago

  • Status changed from Feedback to Resolved

this has nothing to do with eliteness. you can dbl click, right click, or file->open INSIDE eliteness gui and everything works as advertised.

the issue you are raising is being unable to associate eliteness with total commander via some reg keys. I have never written reg associations for eliteness and wouldn't know what has gone bang.

Updated by Xeno almost 6 years ago

Found Eliteness 2.30 and DePbo.dll 1.85 on my HD.

With those it works exactly as expected. Eliteness opens the file, it stays :)

Updated by kju almost 6 years ago

weird

Updated by Xeno almost 6 years ago

I've talked allready with mikero about it.

Associating a file type with an application means only that a file gets passed as parameter to the app.
Mikero said he changed something in newer versions of Eliteness which might cause the problem, he'll look into it.

Updated by kju almost 6 years ago

good to hear!

Updated by mikero almost 6 years ago

fixed at version 2.47 of eliteness

it would have been helpful to know in the first place that this was an external opening problem rather than inability to dbl click or open files from within elitness itself. Very confusing

Updated by kju almost 6 years ago

  • Assignee changed from mikero to Xeno

please confirm

Updated by Xeno almost 6 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Works fine with 2.47 :) Thank you.

Closed.

Also available in: Atom PDF