Bug #28366

DeleteVehicle doesn't delete crew units properly.

Added by zapat over 3 years ago. Updated almost 3 years ago.

Status:Assigned Start date:02/03/2012
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Scripting: Problem
Target version:-
Affected ArmA II version:1.62.95248 First affected build:Please Specify...
Reproduced by another DH user:Yes First affected ArmA II version:1.60.87580
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs:
Deleting crew units of a vehicle doesn't work properly.
1. If only crew are deleted only but vehicle is not: nothing happens, crew stay on.
2. If only vehicle is deleted and crew are not: vehicle disappers, crew stays on (fall from their place).
3. If crew is deleted, and then the vehicle is deleted too: everything disappears.

Exp: {Deletevehicle _x} foreach crew; vehicle should delete crew.
Deletevehicle vehicle; should not delete vehicle, leaving crew in air.

Repro:
1. Load attached mission in editor.
2. Zoom in on player
3. Place player in either of the 3 triggers (they represent the above points).
4. Run the mission
5. hint shows what should happen.

deleteVehicleBug.Chernarus.zip (1023 Bytes) zapat, 02/03/2012 20:30

History

Updated by zGuba over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to zapat

What about:

{moveOut _x; deletevehicle _x} foreach crew _vehicle?

and:

{deleteVehicle _x} forEach ([_vehicle] + (crew _vehicle))

Updated by zapat over 3 years ago

Yes, both of these work.
If you setPos crew away (instead of moveOut)it works too.

You cannot delete crew-only without moving them from their seats though. (which you could do prior to 1.60)

Updated by kju over 3 years ago

  • Description updated (diff)
  • Category set to Scripting: Problem

Updated by kju about 3 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from zapat to Dwarden
  • Affected ArmA II version set to 1.61 Beta
  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Most likely due the fix of crash when deleting a vehicle with units still inside.

Updated by kju almost 3 years ago

  • Affected ArmA II version changed from 1.61 Beta to 1.62.95248

Also available in: Atom PDF