Bug #28347

Wind changes too rapidly

Added by admin over 3 years ago. Updated almost 3 years ago.

Status:Expired Start date:02/03/2012
Priority:Normal Due date:04/26/2012
Assignee:- % Done:

0%

Category:-
Target version:1.14
Component:sys_wind Affected Version:
Close Reason:

Description

http://forums.bistudio.com/showthread.php?129084-ACE-for-OA-1-13&p=2099789&viewfull=1#post2099789

By Guba:

Please check out following post on BIF:
http://forums.bistudio.com/showthread.php?129084-ACE-for-OA-1-13&p=2099789&viewfull=1#post2099789

Also ccording to my contact, RL commando sniper, wind in ACE changes approximately 2 times too drastically.

Would be great, if somebody responsible took that in account and decreased the intensity of wind changes in ACE. From my research the solution should be inside one of these two files:

P:\x\ACE\Addons\sys_wind_deflection\XEH_postServerInit.sqf
P:\x\ACE\Addons\sys_wind_deflection\XEH_preInit.sqf

By Xeno:

Because of the sleep 7 + floor random bla in worst case the wind does change every 7 seconds.

ace_sys_wind_deflection.pbo (294.9 kB) Sickboy, 02/03/2012 09:19

Associated revisions

Revision cf29f400
Added by Sickboy over 3 years ago

~ CHANGED: Made minimum wind change time configurable in global variable: ace_sys_wind_deflection_min_wind_change_time. refs #28347

Revision 15c0b84b
Added by Sickboy over 3 years ago

~ CHANGED: MinWindChangeTime default from 7 seconds to 10. closes #28347

History

Updated by Sickboy over 3 years ago

  • Description updated (diff)
  • Status changed from New to Assigned
  • Assignee set to Nou
  • Target version changed from TBD to 1.14
  • Component set to sys_wind

Updated by Sickboy over 3 years ago

For starters, i've made the min wind change time configurable in a global variable.
ace_sys_wind_deflection_min_wind_change_time default value is 7

Updated by Sickboy over 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 20 to 100

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Updated by Sickboy over 3 years ago

  • Status changed from Closed to Feedback
  • % Done changed from 100 to 60

Updated by Sickboy about 3 years ago

  • Due date set to 03/26/2012

Rocko says: Status Nou?

Updated by Nou about 3 years ago

Does anyone have any other statistical information I can use to base these changes off of? "2 times too drastically" is not really much to go off of. What changes too drastically? Direction? Speed?

Updated by ScarecrowisNOTamused. about 3 years ago

Nou wrote:

Does anyone have any other statistical information I can use to base these changes off of? "2 times too drastically" is not really much to go off of. What changes too drastically? Direction? Speed?

To me it seems as if the direction change is too fast, in one game recently i remember watching the wind direction contiuiously spining every second for a full 2-3 minutes before settling down, i think the direction shouldn't spin but be a little more constant and gust in the direction with small changes in wind (e.g if the wind is going to 2 o'clock it would shift between 12 and 3 o'clock) and a slightly reduced chance of it changing direction completely (but still allow it to but slow before doing so not snaping straight back).

Updated by rocko about 3 years ago

I'd recommend direction changes every ~10 minutes.

Updated by Nou about 3 years ago

This is the study I used for the changes I made: http://onlinelibrary.wiley.com/doi/10.1256/wea.176.04/pdf

I should look back over and see if the data does correlate. Wind is rather fickle, and some of the limitations of the game engine make it rather hard to simulate in an extremely proper way (due to network sync issues).

Updated by ScarecrowisNOTamused. about 3 years ago

Nou wrote:

limitations of the game engine make it rather hard to simulate in an extremely proper way (due to network sync issues).

Hopefully Arma 3 will help you out there :)

Updated by Xeno about 3 years ago

ScarecrowisNOTamused. wrote:

Hopefully Arma 3 will help you out there :)

I would not bet on it.

Updated by Nou about 3 years ago

BTW, wind does stay fairly constant, at least in direction. Wind speed is never a real constant.

In my spare time I have been working on a aerosol simulation for chemical weapons and I am using ACE wind.

See this screen shot: http://raceriv.com/arma2/aerosol_test.png

That is the cloud after 7:30 minutes. Its pretty much moving just in one direction.

Updated by Xeno about 3 years ago

Nou, that's fine and dandy. The problem is as soon as overcast comes into play in MP wind is completely different on connected clients.

Updated by rocko about 3 years ago

  • Due date changed from 03/26/2012 to 04/26/2012

Updated by Nou about 3 years ago

Xeno wrote:

Nou, that's fine and dandy. The problem is as soon as overcast comes into play in MP wind is completely different on connected clients.

Not in ACE. There is slight differences but for the most part its the same on every client. We set the wind every single frame based on a algorithm that is seeded from the server and changes over time with updates from the server.

Updated by Xeno about 3 years ago

Nou wrote:

Not in ACE. There is slight differences but for the most part its the same on every client. We set the wind every single frame based on a algorithm that is seeded from the server and changes over time with updates from the server.

That's only true for wind deflection :)

Updated by Nou about 3 years ago

No, its not, read the code. Everything that uses wind in ACE uses ACE_wind which calls the deflection function for the wind. There is a loop in sys_wind_deflection that also calls the SQF function setWind every single frame with the same value that you get from ACE_wind at that frame. Those values are sync'd across the network using a deterministic algorithm that will be the same on every client at the same time +/- the latency from the last seed update, which happens roughly every 30-60 seconds.

Updated by Xeno about 3 years ago

You still don't understand it, Nou.

As soon as a mission itself changes overcast values you can set whatever wind value you want on a client send from the server, the wind then still behaves totally random on each client. Which was the reason to create our own wind system in wind deflection.

Updated by Nou about 3 years ago

So you are saying that calling the BIS command setWind has no effect at all?

http://raceriv.com/arma2/ace_wind_speed.png

??? Its not 100% accurate but its within pretty tolerable bounds. Thats total velocity in m/s over time (in seconds).

Updated by rocko almost 3 years ago

  • Status changed from Feedback to Expired
  • Assignee deleted (Nou)
  • % Done changed from 60 to 0

Also available in: Atom PDF