Bug #28307

Error messages with 1.4.2

Added by saok over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:02/01/2012
Priority:Immediate Due date:
Assignee:Psychobastard % Done:

100%

Category:Scripts
Target version:JSRS 1.4.3
BIForumURL:

Description

I am using the optinal pbo´s that came with 1.4.1 and 1.4.2. I get now these error messages time to time while playing.

Error in expression <0) / 343;    sleep _time;    (_this select 1) say3D (_this select 2);    sleep 3.994;    del>
Error position: <say3D (_this select 2); sleep 3.994; del>
Error say3d: Type Bool, expected Array,String
File JSRS_Distance\scripts\ammo\D81.sqf, line 2
Error in expression <0) / 343; sleep _time; (_this select 1) say3D (_this select 2); sleep 3.994; del>
Error position: <say3D (_this select 2); sleep 3.994; del>
Error say3d: Type Bool, expected Array,String
File JSRS_Distance\scripts\ammo\pkt.sqf, line 2
Error in expression <0) / 343; sleep _time; (_this select 1) say3D (_this select 2); sleep 3.994; del>
Error position: <say3D (_this select 2); sleep 3.994; del>
Error say3d: Type Bool, expected Array,String
File JSRS_Distance\scripts\ammo\DSHK.sqf, line 2

Else a priceless great mod, thanks :)


Related issues

duplicated by J.S.R.S. 1.5 - Bug #28451: Another error message in 1.4.2 Closed 02/06/2012

History

Updated by saok over 3 years ago

Few more:

Error in expression <0) / 343; sleep _time; (_this select 1) say3D (_this select 2); sleep 3.994; del>
Error position: <say3D (_this select 2); sleep 3.994; del>
Error say3d: Type Bool, expected Array,String
File JSRS_Distance\scripts\ammo\scar.sqf, line 2
Error in expression <0) / 343; sleep _time; (_this select 1) say3D (_this select 2); sleep 3.994; del>
Error position: <say3D (_this select 2); sleep 3.994; del>
Error say3d: Type Bool, expected Array,String
File JSRS_Distance\scripts\ammo\m24.sqf, line 2

Forgot to add game version: 1.60 + beta 88850

Updated by tonci87 over 3 years ago

  • Category set to Scripts
  • Assignee set to LordJarhead
  • Priority changed from Normal to High

Updated by tonci87 over 3 years ago

  • Priority changed from High to Immediate

Confirmed by others including me
I think I have a performance decrease since the hotfix, especially in longer Missions with lots of shooting.
http://brigade2010.de/forum/viewthread.php?thread_id=146&pid=5045#post_5045

Updated by LordJarhead over 3 years ago

  • Assignee changed from LordJarhead to Psychobastard

This maybe caused with the new Beta Patch.. not sure corze it says Error say3d: Typ Bool, erwartet Array,Zeichenfolge. So I guess 1# I missed something 2# I messed something up or 3# theres are change in the BIS engine, but this would not be done with a beta patch. Have to ask Psycho.

Updated by tonci87 over 3 years ago

Maybe its related to the Event Handler changes in this Beta:
http://forums.bistudio.com/showthread.php?130765-ARMA-2-OA-beta-build-88918-%281-60-MP-compatible-build-post-1-60-release%29

+ EH improvement on serialization
The various eventHandlers in game are implemented with the following BUG.
AddEventHandler adds handler into the array and return its index as a unique handle to be used for possible later removal.
RemoveEventHandler removes the item on the specified index.
Which means, the array is shifted and other "unique handles" does not match the proper index after remove.
Fix implements in the similar way as implemented eventHandlers for UI.
Renamed these to class EventHandler and class EventHandlers.

The weird part is that these Errors only appear if you use the JSRS Hotfix

Updated by Sickboy over 3 years ago

Should be unrelated. As the error indicates, the call to say3D, receives a bool instead of an array/string.
Im guessing the content of _this select 2 is wrong.

Updated by LordJarhead over 3 years ago

Alright, I guess your right. But if so, there had to be a change somewhere with the eventhandlers as Tonci mentioned. Since we already playing with this content a month or so and never had such an error. Now its just showing up with the latest beta.

Updated by Sickboy over 3 years ago

The eventhandler change is only about removing eventhandler. Are you sure it is only reproduceable with the latest betas, aka did you actually try older betas?

Updated by Psychobastard over 3 years ago

  • Assignee changed from Psychobastard to LordJarhead

Yes, the problem occurs since the hotfix. Nothing was changed at script since 1.4.2.
@LJ, you have to check the config names and given names for these weapons where the error occurs.

(this select 2) is the name of the sound. It's maybee wrong or non string.

btw: I played without any beta's and i can reproduce this error. It is not a problem of the eh's.
btw2: We have more than this one weapon with this new error!

regards

Updated by Yokhanan over 3 years ago

Aye, confirmed as well when LJ asked me to double-check my rpt from the co-op's played. Had many duplicates of the same general kind of error but for different weapons.

Updated by LordJarhead over 3 years ago

Psychobastard wrote:

Yes, the problem occurs since the hotfix. Nothing was changed at script since 1.4.2.
@LJ, you have to check the config names and given names for these weapons where the error occurs.

(this select 2) is the name of the sound. It's maybee wrong or non string.

btw: I played without any beta's and i can reproduce this error. It is not a problem of the eh's.
btw2: We have more than this one weapon with this new error!

regards

I never changed anything in the script! I dont know whats causing this. It say that the say3D needs an array or string. The only thing I fixed with the HotFix was the snip1 entry. Why is this now showing up? I never did anything to the Macro sqf or other sqf files instead of the snip1. Also I did not edited the config file. Damn, I going to use the old script from 1.4.2 and see if there is any difference.

Will do some tests. Also Yokhanan is helping testing the edited files!

Updated by LordJarhead over 3 years ago

All my tests were useless. I still got this error message. I changed the given names in the configs, in the script, I used the older script from 1.42, I changed the script entries. No matter what I was doing, it was all useless. The error still appears! I'm out of ideas......

Updated by Psychobastard over 3 years ago

  • Status changed from New to Resolved
  • Assignee changed from LordJarhead to Psychobastard

done

Updated by Psychobastard over 3 years ago

  • % Done changed from 0 to 100

Updated by LordJarhead over 3 years ago

Many thanks!!

Updated by Psychobastard over 3 years ago

  • Target version set to JSRS 1.4.3

Updated by Psychobastard over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF