Bug #28219

BMD locality issue with reload sounds

Added by tyrspawn over 3 years ago. Updated over 2 years ago.

Status:Rejected Start date:01/29/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:BIS / Engine problem

Description

The BMD has out of scope locality with the reload sounds, causing hundreds of reload hundreds to accumulate and then play in order in missions with more than a handful of players.

Video of 70 player tvt at UO with this happening:

http://www.youtube.com/watch?v=aUVjuw9Olck

Check out the end of the video when I am closer to the BMDs to hear it obviously happening, although it happens all throughout the video.

file.rpt (64 kB) Sickboy, 01/30/2012 09:17

History

Updated by tyrspawn over 3 years ago

http://www.youtube.com/watch?feature=player_detailpage&v=aUVjuw9Olck#t=989s

Link to part where it's clearly noticeable. You can hear this at lower volume at ranges up to 800 meters or so.

Updated by rocko over 3 years ago

  • Due date set to 01/31/2012
  • Status changed from New to Feedback
  • Assignee set to tyrspawn

Updated by Sickboy over 3 years ago

Updated by Sickboy over 3 years ago

BMD1 or 2?

Updated by Sickboy over 3 years ago

I don't see any special (custom / scripted) reload sounds for the BMD1.
Probably a BIS issue (In that case create a CIT ticket), perhaps issue in the beta: 1.60.87816. Try a newer one. Or perhaps try and old 1.59 beta to confirm.
Or perhaps related to the many other warnings and errors in the RPT file indicating config issues etc. Try reproducing it without other mods.

Updated by rocko over 3 years ago

  • Due date deleted (01/31/2012)
  • Status changed from Feedback to New
  • Assignee deleted (tyrspawn)
  • Target version deleted (TBD)
  • Close Reason set to BIS / Engine problem

https://dev-heaven.net/issues/28201

I suggest following the CIT as it seems to be a BIS problem ATM.
The mentioned tickets describes mult. sounds played - per each player connected - for the reloadSound[] parameter , which is actually used by the weapon of the BMD1 in ACE but also for other vehicles (see below).

Surprisingly the range parameter is missing in the ACE config, but I doubt it has to do with the problem.

reloadSound[] = {"\ca\Sounds\weapons\cannon\gun120reload",1,1}

Instead of:

reloadSound[] = {"\ca\Sounds\weapons\cannon\gun120reload",1,1,20};

ATM this is the only sound that has the range-parameter missing in the config.

There are other vehicles that use weapons with that parameter:
- M119 (not the ACE Artillery piece)
- D30
- M1A1/M1A2

(Those vehicles should use the vanilla reloadSound, but have the range parameter)
If the reloading is also hearable for these vehicles then it seems pretty much like a BIS problem.

Updated by rocko over 3 years ago

  • Status changed from New to Rejected

Updated by tyrspawn over 3 years ago

FYI this is apparently getting fixed in the next arma2 beta. Win.

Also available in: Atom PDF